aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/vmw/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-21 21:01:32 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-21 21:01:32 +0800
commit2e6aa66a788460c316af021af689be58f958f09e (patch)
tree5bbc21769c2be7871c2ae3f659aea9ae0bcb4d6b /emulators/vmw/Makefile
parent75b13a3dbe90ce1667f732917e9129a3dcbcfe96 (diff)
downloadfreebsd-ports-gnome-2e6aa66a788460c316af021af689be58f958f09e.tar.gz
freebsd-ports-gnome-2e6aa66a788460c316af021af689be58f958f09e.tar.zst
freebsd-ports-gnome-2e6aa66a788460c316af021af689be58f958f09e.zip
VMware Command Line Tools
On this page, you'll find command line programs which can replace and/or supplement the VMware's official VMwareTools. These programs use VMware's undocumented and therefore not officially supported feature to communicate with VMware (see VMware Backdoor I/O Port). Information on these functions have come entirely from my personal research and quite a few contributions by fellow VMware users. These programs are intended partly as illustrative examples of how to use the VMware backdoor function and I have cut many corners writing them. * vmw: generic backdoor access program * vmshrink: virtual disk shrink program * vmftp: host-guest file transfer program WWW: http://chitchat.at.infoseek.co.jp/vmware/vmtools.html
Diffstat (limited to 'emulators/vmw/Makefile')
-rw-r--r--emulators/vmw/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/emulators/vmw/Makefile b/emulators/vmw/Makefile
new file mode 100644
index 000000000000..ccc91cb858f0
--- /dev/null
+++ b/emulators/vmw/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: vmw
+# Date created: 18 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= vmw
+PORTVERSION= 060510
+CATEGORIES= emulators
+MASTER_SITES= http://chitchat.at.infoseek.co.jp/vmware/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= VM Back Command Line Tools for VMware
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+USE_ICONV= yes
+
+SBINS= vmw vmshrink vmftp
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README-eucj.TXT README-sjis.TXT README.TXT
+.for i in ${SBINS}
+PORTDOCS+= ${i}-eucj.txt ${i}-sjis.txt ${i}.txt
+.endfor
+.endif
+.for i in ${SBINS}
+PLIST_FILES+= sbin/${i}
+.endfor
+
+do-install:
+.for i in ${SBINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/.. && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>