aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/vmware2
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-09-15 18:19:47 +0800
committerknu <knu@FreeBSD.org>2000-09-15 18:19:47 +0800
commit8f47152db49138ec55469193e18b03aaa4bbce4b (patch)
tree59d5e96b8df8398e2c46f825fd6fb5215cb8695c /emulators/vmware2
parenta5e936d058a0113554c90992ef4cfc3728456944 (diff)
downloadfreebsd-ports-gnome-8f47152db49138ec55469193e18b03aaa4bbce4b.tar.gz
freebsd-ports-gnome-8f47152db49138ec55469193e18b03aaa4bbce4b.tar.zst
freebsd-ports-gnome-8f47152db49138ec55469193e18b03aaa4bbce4b.zip
Add support for the latest current. (a bit kind of ad hoc)
Diffstat (limited to 'emulators/vmware2')
-rw-r--r--emulators/vmware2/Makefile3
-rw-r--r--emulators/vmware2/files/patch-bc11
-rw-r--r--emulators/vmware2/files/patch-bd25
3 files changed, 38 insertions, 1 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index 0362e957a8d8..212e1906b76a 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -8,6 +8,7 @@
PORTNAME= vmware2
PORTVERSION= 2.0.2.621
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= http://www4.vmware.com/software/ \
http://vmware-svca.www.conxion.com/software/ \
@@ -48,7 +49,7 @@ MAN1= vmware.1
BROKEN= "Systems prior to 400013 is out of support"
.endif
-.if !defined(HAVE_LINPROCFS) && !exists(/modules/linprocfs.ko) && !exists(${PREFIX}/modules/linprocfs.ko)
+.if !defined(HAVE_LINPROCFS) && !exists(/modules/linprocfs.ko) && !exists(/boot/kernel/linprocfs.ko) && !exists(${PREFIX}/modules/linprocfs.ko)
BROKEN= "This software absolutely requires Linux procfs support"
.endif
diff --git a/emulators/vmware2/files/patch-bc b/emulators/vmware2/files/patch-bc
new file mode 100644
index 000000000000..b2764c90596a
--- /dev/null
+++ b/emulators/vmware2/files/patch-bc
@@ -0,0 +1,11 @@
+--- vmnet-only/freebsd/vmnet.c.orig Mon Jul 31 08:36:25 2000
++++ vmnet-only/freebsd/vmnet.c Mon Sep 11 00:34:08 2000
+@@ -164,7 +164,7 @@
+
+ s = splimp();
+ if_attach(ifp);
+- ether_ifattach(ifp);
++ ether_ifattach(ifp, ETHER_BPF_SUPPORTED);
+ bpfattach(ifp, DLT_EN10MB, sizeof(struct ether_header));
+ splx(s);
+
diff --git a/emulators/vmware2/files/patch-bd b/emulators/vmware2/files/patch-bd
new file mode 100644
index 000000000000..e88a69bf5af5
--- /dev/null
+++ b/emulators/vmware2/files/patch-bd
@@ -0,0 +1,25 @@
+--- vmmon-only/freebsd/driver.c.orig Thu Jun 29 21:06:18 2000
++++ vmmon-only/freebsd/driver.c Thu Sep 14 14:03:42 2000
+@@ -73,6 +73,22 @@
+ #include "private.h"
+ #endif
+
++#if __FreeBSD_version >= 500013
++enum intr_type {
++ INTR_TYPE_TTY = 1,
++ INTR_TYPE_BIO = 2,
++ INTR_TYPE_NET = 4,
++ INTR_TYPE_CAM = 8,
++ INTR_TYPE_MISC = 16,
++ INTR_HEAVY = 32, /* heavyweight interrupt process */
++ INTR_LIGHT = 64, /* light weight interrupt thread */
++ INTR_THREADED = INTR_LIGHT | INTR_HEAVY, /* any kind of interrupt thread */
++ INTR_FAST = 128,
++ INTR_EXCL = 256, /* exclusive interrupt */
++ INTR_MPSAFE = 512 /* this interrupt is SMP safe */
++};
++#endif
++
+ #ifdef SUPPORT_PASSTHROUGH
+ #include "passthrough.h" // _driver_ version of passthrough.h
+ #endif