aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-01-10 03:12:55 +0800
committergerald <gerald@FreeBSD.org>2010-01-10 03:12:55 +0800
commit825a74855ee3aae2215fb0f5dbe2228df7d29b77 (patch)
tree073b34757a89b5d30155ac0125427f439ba98c28 /emulators/wine
parent1f15f7dfb09c5868036530fa9dec2373ee916601 (diff)
downloadfreebsd-ports-gnome-825a74855ee3aae2215fb0f5dbe2228df7d29b77.tar.gz
freebsd-ports-gnome-825a74855ee3aae2215fb0f5dbe2228df7d29b77.tar.zst
freebsd-ports-gnome-825a74855ee3aae2215fb0f5dbe2228df7d29b77.zip
Force the use of flex from the Ports Collection and make it a build
dependency over the old version in the base. Reported by: Andrew Lankford <lankfordandrew@charter.net>
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 7093c029dbe3..48eb26325d62 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -16,6 +16,7 @@ MASTER_SITES= SF/${PORTNAME}/Source \
MAINTAINER= gerald@FreeBSD.org
COMMENT= Microsoft Windows compatibility layer for Unix-like systems
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/devel/flex
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.10:${PORTSDIR}/graphics/jpeg \
@@ -29,7 +30,8 @@ CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
--without-gsm --without-mpg123 --without-openal \
--without-sane --without-xcursor
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ FLEX="${LOCALBASE}/bin/flex"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
MAKE_JOBS_SAFE= yes
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \