aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/xmame/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-10-12 06:37:23 +0800
committeredwin <edwin@FreeBSD.org>2004-10-12 06:37:23 +0800
commit69d6faaaafdb40c57183d338d0d08ef4cf6628cb (patch)
tree06e3d60069ada05889e08a0f2e860d7678408120 /emulators/xmame/Makefile
parent5e62710047eb84708bf4d2ce04335492944f289d (diff)
downloadfreebsd-ports-gnome-69d6faaaafdb40c57183d338d0d08ef4cf6628cb.tar.gz
freebsd-ports-gnome-69d6faaaafdb40c57183d338d0d08ef4cf6628cb.tar.zst
freebsd-ports-gnome-69d6faaaafdb40c57183d338d0d08ef4cf6628cb.zip
[Maintainer update] emulators/xmame to 0.86
I was holding this in hope they would get networking fixed. No dice. *NETWORKING DOESN'T WORK IN THIS VERSION* and is disabled in the Makefile. Some people have reported success on !i386, so I've removed the ARCH restriction for now. We'll see how it turns out. This version makes gxmame stop working, see the other PR about gxmame for a fix. PR: ports/71252 Submitted by: Miguel Mendez <flynn@energyhq.es.eu.org>
Diffstat (limited to 'emulators/xmame/Makefile')
-rw-r--r--emulators/xmame/Makefile42
1 files changed, 21 insertions, 21 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 19cf703b52a3..6d389a6dd93d 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= xmame
-PORTVERSION?= 0.83.1
+PORTVERSION?= 0.86
CATEGORIES= emulators
MASTER_SITES= http://x.mame.net/download/:xmame \
http://www.sys2064.com/files/util/:history \
@@ -126,12 +126,13 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
post-extract:
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/uhsdat${HIVER}.zip \
+ ${UNZIP_CMD} -q ${DISTDIR}/${DIST_SUBDIR}/uhsdat${HIVER}.zip \
hiscore.dat
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/history.dat.zip history.dat
+ ${UNZIP_CMD} -q ${DISTDIR}/${DIST_SUBDIR}/history.dat.zip \
+ history.dat
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/cheat.zip cheat.dat
+ ${UNZIP_CMD} -q ${DISTDIR}/${DIST_SUBDIR}/cheat.zip cheat.dat
.else
PLIST_SUB+= DATFILES="@comment "
.endif
@@ -214,29 +215,22 @@ USE_GNOME= esound
ESOUNDCOMMENT=\#
.endif
+# XXX Network support is *broken* in 0.85+, leave commented out for now
# Option WITH_NETWORK
-.if ${MAMEMESS} == "mame"
-.if !defined(WITH_NETWORK)
-WITH_NETWORK= yes
-.endif
+#.if ${MAMEMESS} == "mame"
+#.if !defined(WITH_NETWORK)
+WITH_NETWORK= no
+#.endif
.if ${WITH_NETWORK:L} != "no"
NETWORK=
.else
NETWORK=\#
.endif
-.endif
+#.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-.if ${ARCH} != "i386" && ${OSVERSION} >= 502102
-BROKEN= "Does not compile on 5.x !i386"
-.endif
-
#
# Regular targets
#
@@ -282,12 +276,15 @@ do-configure:
-e "s@^SDL_CONFIG.*@SDL_CONFIG = ${SDL_CONFIG}@g" \
-e "s@^GLLIBS += .*@GLLIBS += ${PTHREAD_LIBS}@g" \
${WRKSRC}/makefile.unix
+.if ${DISPLAY_TARGET:L} == "sdl"
+ ${REINPLACE_CMD} -e "s@# JOY_SDL = 1@JOY_SDL = 1@g" ${WRKSRC}/makefile.unix
+.endif
# png.h conflicts with libpng.
-.for file in mess/artworkx.c mess/artworkx.h src/artwork.c \
+.for f in mess/artworkx.c mess/artworkx.h src/artwork.c \
src/common.c src/png.c src/unix/video-drivers/glexport.c
- ${REINPLACE_CMD} -e "s@\"png.h\"@\"mame_png.h\"@g" ${WRKSRC}/${file}
+ ${REINPLACE_CMD} -e "s@\"png.h\"@\"mame_png.h\"@g" ${WRKSRC}/${f}
.endfor
${LN} -s ${WRKSRC}/src/png.h ${WRKSRC}/src/mame_png.h
@@ -304,6 +301,9 @@ post-build:
${WRKSRC}/doc/x${MAMEMESS}rc.dist.sed > ${WRKSRC}/doc/x${MAMEMESS}rc.dist
post-install:
+.if ${MAMEMESS} == "mame"
+ ${INSTALL_PROGRAM} ${WRKSRC}/xml2info ${PREFIX}/bin
+.endif
${MV} ${PREFIX}/bin/x${MAMEMESS}.${DISPLAY_METHOD} \
${PREFIX}/bin/x${MAMEMESS}
${CHOWN} root:games ${PREFIX}/bin/x${MAMEMESS}
@@ -319,8 +319,8 @@ post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/x${MAMEMESS}
${MKDIR} ${PREFIX}/share/doc/x${MAMEMESS}/img
-.for file in ${ALLDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/x${MAMEMESS}
+.for f in ${ALLDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${PREFIX}/share/doc/x${MAMEMESS}
.endfor
.endif
.if ${MAMEMESS} == "mess"