aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/xmame
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /emulators/xmame
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'emulators/xmame')
-rw-r--r--emulators/xmame/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 67676c0d4b01..f83eef163065 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= xmame
PORTVERSION?= 0.106
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= emulators
MASTER_SITES= http://www.franksworld.org/dist/xmame/ \
http://x.mame.net/download/ \
@@ -143,9 +143,9 @@ SDLSOUNDCOMMENT=
.endif
.if defined(WITH_OPENGL)
-USE_XLIB= yes
+USE_XORG+= x11
DISPLAY_TARGET= opengl
-CFLAGS+= ${PTHREAD_CFLAGS} -I${X11BASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
USE_GL= yes
DISPLAY_METHOD= x11
PLIST_SUB+= OPENGL=""
@@ -157,13 +157,13 @@ PLIST_SUB+= OPENGL="@comment "
.if defined(WITH_SVGALIB)
DISPLAY_TARGET= svgalib
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
-USE_XPM= yes
+USE_XORG+= xpm
DISPLAY_METHOD= svgalib
.endif
.if defined(WITH_X11)
DISPLAY_METHOD= x11
-USE_XLIB= yes
+USE_XORG+= x11
.endif
# Option WITH_ESOUND
@@ -203,7 +203,7 @@ do-configure:
-e "s@# SOUND_SDL@${SDLSOUNDCOMMENT}SOUND_SDL@g" \
-e "s@^DISPLAY_METHOD.*@DISPLAY_METHOD = ${DISPLAY_METHOD}@g" \
-e "s@# X11_DGA@X11_DGA@g" \
- -e "s@/usr/X11R6@${X11BASE}@g" \
+ -e "s@/usr/X11R6@${LOCALBASE}@g" \
-e "s@^SDL_CONFIG.*@SDL_CONFIG = ${SDL_CONFIG}@g" \
-e "s@^GLLIBS += .*@GLLIBS += ${PTHREAD_LIBS}@g" \
${WRKSRC}/makefile.unix