aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2020-02-28 05:49:06 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2020-02-28 05:49:06 +0800
commit4f2b7e7a7400cf292319d8a3c44e7033e9da714d (patch)
tree4c6a43207dc685388f189ecbcf17b1e4e0060b9d /emulators
parent10215db971b339f604caab297599538420870ef4 (diff)
parenta995385cd5bbed36028d50f5ac7c6fdda84fa373 (diff)
downloadfreebsd-ports-gnome-master.tar.gz
freebsd-ports-gnome-master.tar.zst
freebsd-ports-gnome-master.zip
Merge remote-tracking branch 'upstream/master'master
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/files/patch-Externals_glslang_glslang_Include_PoolAlloc.h26
-rw-r--r--emulators/ppsspp/files/patch-ext_glslang_glslang_Include_PoolAlloc.h25
-rw-r--r--emulators/wine-devel/Makefile21
3 files changed, 60 insertions, 12 deletions
diff --git a/emulators/dolphin-emu/files/patch-Externals_glslang_glslang_Include_PoolAlloc.h b/emulators/dolphin-emu/files/patch-Externals_glslang_glslang_Include_PoolAlloc.h
new file mode 100644
index 000000000000..0461e410084a
--- /dev/null
+++ b/emulators/dolphin-emu/files/patch-Externals_glslang_glslang_Include_PoolAlloc.h
@@ -0,0 +1,26 @@
+https://github.com/KhronosGroup/glslang/commit/24b3e8384e93
+
+In file included from Externals/glslang/glslang/GenericCodeGen/CodeGen.cpp:35:
+In file included from Externals/glslang/glslang/GenericCodeGen/../Include/Common.h:107:
+Externals/glslang/glslang/GenericCodeGen/../Include/PoolAlloc.h:307:54: error: 'operator=' is a private member of 'glslang::TPoolAllocator'
+ void setAllocator(TPoolAllocator* a) { allocator = *a; }
+ ~~~~~~~~~ ^ ~~
+Externals/glslang/glslang/GenericCodeGen/../Include/PoolAlloc.h:244:21: note: declared private here
+ TPoolAllocator& operator=(const TPoolAllocator&); // don't allow assignment operator
+ ^
+In file included from Externals/glslang/glslang/GenericCodeGen/CodeGen.cpp:36:
+In file included from Externals/glslang/glslang/GenericCodeGen/../Include/ShHandle.h:46:
+Externals/glslang/glslang/GenericCodeGen/../Include/../Public/ShaderLang.h:85:22: warning: '__fastcall__' calling convention is not supported for this target [-Wignored-attributes]
+SH_IMPORT_EXPORT int __fastcall ShFinalize();
+ ^
+
+--- Externals/glslang/glslang/Include/PoolAlloc.h.orig 2019-10-07 00:46:03 UTC
++++ Externals/glslang/glslang/Include/PoolAlloc.h
+@@ -304,7 +304,6 @@ class pool_allocator { (public)
+ size_type max_size() const { return static_cast<size_type>(-1) / sizeof(T); }
+ size_type max_size(int size) const { return static_cast<size_type>(-1) / size; }
+
+- void setAllocator(TPoolAllocator* a) { allocator = *a; }
+ TPoolAllocator& getAllocator() const { return allocator; }
+
+ protected:
diff --git a/emulators/ppsspp/files/patch-ext_glslang_glslang_Include_PoolAlloc.h b/emulators/ppsspp/files/patch-ext_glslang_glslang_Include_PoolAlloc.h
new file mode 100644
index 000000000000..834ab36ebeb6
--- /dev/null
+++ b/emulators/ppsspp/files/patch-ext_glslang_glslang_Include_PoolAlloc.h
@@ -0,0 +1,25 @@
+https://github.com/KhronosGroup/glslang/commit/24b3e8384e93
+
+In file included from Common/Vulkan/VulkanContext.cpp:28:
+In file included from ext/glslang/SPIRV/GlslangToSpv.h:42:
+In file included from ext/glslang/SPIRV/SpvTools.h:47:
+In file included from ext/glslang/SPIRV/../glslang/MachineIndependent/localintermediate.h:42:
+In file included from ext/glslang/SPIRV/../glslang/MachineIndependent/../Include/intermediate.h:55:
+In file included from ext/glslang/SPIRV/../glslang/MachineIndependent/../Include/../Include/Common.h:108:
+ext/glslang/SPIRV/../glslang/MachineIndependent/../Include/PoolAlloc.h:307:54: error: 'operator=' is a private member of 'glslang::TPoolAllocator'
+ void setAllocator(TPoolAllocator* a) { allocator = *a; }
+ ~~~~~~~~~ ^ ~~
+ext/glslang/SPIRV/../glslang/MachineIndependent/../Include/PoolAlloc.h:244:21: note: declared private here
+ TPoolAllocator& operator=(const TPoolAllocator&); // don't allow assignment operator
+ ^
+
+--- ext/glslang/glslang/Include/PoolAlloc.h.orig 2019-06-18 08:00:46 UTC
++++ ext/glslang/glslang/Include/PoolAlloc.h
+@@ -304,7 +304,6 @@ class pool_allocator { (public)
+ size_type max_size() const { return static_cast<size_type>(-1) / sizeof(T); }
+ size_type max_size(int size) const { return static_cast<size_type>(-1) / size; }
+
+- void setAllocator(TPoolAllocator* a) { allocator = *a; }
+ TPoolAllocator& getAllocator() const { return allocator; }
+
+ protected:
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 1271d8f77f53..dba965a5cb23 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -98,6 +98,14 @@ MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
OPENAL_CONFIGURE_WITH= openal
OPENAL_USES= openal
+STAGING_MASTER_SITES= https://github.com/wine-staging/wine-staging/archive/:staging
+COMP_DIST= v${DISTVERSION}.tar.gz
+STAGING_DISTFILES= ${COMP_DIST}:staging
+STAGING_EXTRACT_DEPENDS= bash:shells/bash \
+ git:devel/git \
+ autoconf>0:devel/autoconf
+STAGING_LIB_DEPENDS= libtxc_dxtn.so:graphics/s2tc
+
V4L_CONFIGURE_WITH= v4l2
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
@@ -146,20 +154,9 @@ post-patch:
PLIST_SUB+= WINE32="" WINE64="@comment "
.endif
-.if ${PORT_OPTIONS:MSTAGING}
-MASTER_SITES+= https://github.com/wine-staging/wine-staging/archive/:cho
-COMP_DIST= v${DISTVERSION}.tar.gz
-DISTFILES+= ${COMP_DIST}:cho
-
-EXTRACT_DEPENDS=bash:shells/bash \
- git:devel/git \
- autoconf>0:devel/autoconf
-LIB_DEPENDS+= libtxc_dxtn.so:graphics/s2tc
-
-post-extract: fix-shebang
+post-extract-STAGING-on: fix-shebang
cd ${WRKSRC} && ${TAR} xf ${DISTDIR}/${COMP_DIST} --strip-components 1
cd ${WRKSRC} && bash ./patches/patchinstall.sh --backend=patch DESTDIR=${WRKSRC} --all
-.endif
pre-build:
cd ${WRKSRC} && ${MAKE_CMD} depend