aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-08-08 14:27:24 +0800
committergerald <gerald@FreeBSD.org>2017-08-08 14:27:24 +0800
commit0294d7efcc00638d822bf152f72f2cc7e6fb8d1d (patch)
tree79a46c1948933e56fa0d822fcf7cc0b71862f088 /emulators
parent2b7e0a9e9d1254611782db5f176b92eda8021ca7 (diff)
downloadfreebsd-ports-gnome-0294d7efcc00638d822bf152f72f2cc7e6fb8d1d.tar.gz
freebsd-ports-gnome-0294d7efcc00638d822bf152f72f2cc7e6fb8d1d.tar.zst
freebsd-ports-gnome-0294d7efcc00638d822bf152f72f2cc7e6fb8d1d.zip
Update to Wine 2.14. This includes the following changes:
- Mono engine updated with some bug fixes. - C++ calling convention workarounds in the IDL compiler. - Various bug fixes. Sort ONLY_FOR_ARCHS.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile4
-rw-r--r--emulators/wine-devel/distinfo10
-rw-r--r--emulators/wine-devel/pkg-plist10
3 files changed, 17 insertions, 7 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 5ef3cb1c40ab..3f5b8b81e61a 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wine
-DISTVERSION= 2.13
+DISTVERSION= 2.14
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -41,7 +41,7 @@ WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
.endif
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= amd64 i386
USES= bison compiler:c11 desktop-file-utils gmake shebangfix tar:xz
SHEBANG_FILES= tools/make_requests tools/winemaker/winemaker \
tools/winedump/function_grep.pl
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 9b7cd1cbed48..d99e978aed67 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1501016035
-SHA256 (wine-2.13.tar.xz) = 6fbca3ddd19b061ce65a267639efae93cf38cfabbe4a9c148a17a44703587ef8
-SIZE (wine-2.13.tar.xz) = 19439328
-SHA256 (v2.13.tar.gz) = 0796440ebfa2aa651051e7081cc64f83774f966f26353876e024e42c59e24b46
-SIZE (v2.13.tar.gz) = 10137549
+TIMESTAMP = 1502172149
+SHA256 (wine-2.14.tar.xz) = 03f934d95181f728600ca04d395f10e821ee38cfa31655e872e4d27d2a8795c6
+SIZE (wine-2.14.tar.xz) = 19447812
+SHA256 (v2.14.tar.gz) = cd4c8e400a808cbfa5c5cf088ea874c761d09db897f25bc33eab840101020b19
+SIZE (v2.14.tar.gz) = 10179829
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index cabc896aadae..b883d5a3f7e0 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -145,6 +145,8 @@ include/wine/windows/cierror.h
include/wine/windows/clusapi.h
include/wine/windows/cmdbas.idl
include/wine/windows/cmdtxt.idl
+include/wine/windows/cmnquery.h
+include/wine/windows/cmnquery.idl
include/wine/windows/colinf.idl
include/wine/windows/comcat.h
include/wine/windows/comcat.idl
@@ -738,6 +740,8 @@ include/wine/windows/uiautomationclient.idl
include/wine/windows/uiautomationcore.h
include/wine/windows/uiautomationcore.idl
include/wine/windows/uiautomationcoreapi.h
+include/wine/windows/uiribbon.h
+include/wine/windows/uiribbon.idl
include/wine/windows/unknwn.h
include/wine/windows/unknwn.idl
include/wine/windows/urlhist.h
@@ -1250,6 +1254,7 @@ lib/wine/dpvoice.dll.so
lib/wine/dpwsockx.dll.so
lib/wine/drmclien.dll.so
lib/wine/dsound.dll.so
+lib/wine/dsquery.dll.so
lib/wine/dssenh.dll.so
lib/wine/dswave.dll.so
lib/wine/dwmapi.dll.so
@@ -1633,6 +1638,7 @@ lib/wine/fakedlls/dpvoice.dll
lib/wine/fakedlls/dpwsockx.dll
lib/wine/fakedlls/drmclien.dll
lib/wine/fakedlls/dsound.dll
+lib/wine/fakedlls/dsquery.dll
lib/wine/fakedlls/dssenh.dll
lib/wine/fakedlls/dswave.dll
lib/wine/fakedlls/dwmapi.dll
@@ -1930,6 +1936,7 @@ lib/wine/fakedlls/rsabase.dll
lib/wine/fakedlls/rsaenh.dll
lib/wine/fakedlls/rstrtmgr.dll
lib/wine/fakedlls/rtutils.dll
+%%STAGING%%lib/wine/fakedlls/runas.exe
%%WINE32%%lib/wine/fakedlls/rundll.exe16
lib/wine/fakedlls/rundll32.exe
lib/wine/fakedlls/samlib.dll
@@ -1999,6 +2006,7 @@ lib/wine/fakedlls/twain_32.dll
%%WINE32%%lib/wine/fakedlls/typelib.dll16
lib/wine/fakedlls/ucrtbase.dll
lib/wine/fakedlls/uiautomationcore.dll
+lib/wine/fakedlls/uiribbon.dll
lib/wine/fakedlls/unicows.dll
lib/wine/fakedlls/uninstaller.exe
lib/wine/fakedlls/unlodctr.exe
@@ -2585,6 +2593,7 @@ lib/wine/rsabase.dll.so
lib/wine/rsaenh.dll.so
lib/wine/rstrtmgr.dll.so
lib/wine/rtutils.dll.so
+%%STAGING%%lib/wine/runas.exe.so
%%WINE32%%lib/wine/rundll.exe16.so
lib/wine/rundll32.exe.so
lib/wine/samlib.dll.so
@@ -2654,6 +2663,7 @@ lib/wine/twain_32.dll.so
%%WINE32%%lib/wine/typelib.dll16.so
lib/wine/ucrtbase.dll.so
lib/wine/uiautomationcore.dll.so
+lib/wine/uiribbon.dll.so
lib/wine/unicows.dll.so
lib/wine/uninstaller.exe.so
lib/wine/unlodctr.exe.so