aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-04-12 21:31:05 +0800
committermat <mat@FreeBSD.org>2017-04-12 21:31:05 +0800
commit147aebba39b68c8bc7b7ba4ef94a01e46884b861 (patch)
treec6271b92933176a47f69ffdb2d0741980851a403 /emulators
parent1db240e0550fda0cd577874108b40002f58db5b9 (diff)
downloadfreebsd-ports-gnome-147aebba39b68c8bc7b7ba4ef94a01e46884b861.tar.gz
freebsd-ports-gnome-147aebba39b68c8bc7b7ba4ef94a01e46884b861.tar.zst
freebsd-ports-gnome-147aebba39b68c8bc7b7ba4ef94a01e46884b861.zip
fix ports using xargs directly.
Sponsored by: Absolight
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine-devel/Makefile.i3868
-rw-r--r--emulators/i386-wine/Makefile.i3868
2 files changed, 8 insertions, 8 deletions
diff --git a/emulators/i386-wine-devel/Makefile.i386 b/emulators/i386-wine-devel/Makefile.i386
index f31d842eeb52..4288de503267 100644
--- a/emulators/i386-wine-devel/Makefile.i386
+++ b/emulators/i386-wine-devel/Makefile.i386
@@ -37,7 +37,7 @@ post-install-script:
${REINPLACE_CMD} -e 's!lib/!lib32/!g' ${TMPPLIST}
# Install bounce script to access the 32-bit executables
${INSTALL_SCRIPT} ${SLAVEDIR}/files/binbounce ${STAGEDIR}${PREFIX}/bin/wine
- for i in `grep ^bin ${TMPPLIST} | xargs -n1 basename` ; do \
+ for i in `grep ^bin ${TMPPLIST} | ${XARGS} -n1 basename` ; do \
[ "$${i}" = "wine" ] || ${LN} -f ${STAGEDIR}${PREFIX}/bin/wine ${STAGEDIR}${PREFIX}/bin/$${i} ; \
echo bin32/$${i} >> ${TMPPLIST} ; \
done
@@ -52,7 +52,7 @@ post-install-script:
done
# Find all soft dependencies (via strings(1))
grep -v '[@%]' ${TMPPLIST} | sed "s!^!${STAGEDIR}${PREFIX}/!g" | \
- xargs -n1 file -F' ' | grep ELF | cut -f1 -d' ' | xargs strings | \
+ ${XARGS} -n1 file -F' ' | grep ELF | cut -f1 -d' ' | ${XARGS} strings | \
grep '^lib.*\.so' | sort -u > ${WRKDIR}/winesoftlibs
for i in `cat ${WRKDIR}/winesoftlibs` ; do \
if [ -e ${LOCALBASE}/lib/$${i} ] && [ -z "`grep $${i} ${TMPPLIST}`" ]; then \
@@ -62,8 +62,8 @@ post-install-script:
done
# Find all libraries that are linked too (via ldd(1))
grep -v '[@%]' ${TMPPLIST} | sed "s!^!${STAGEDIR}${PREFIX}/!g" | \
- xargs -n1 file -F' ' | grep ELF | cut -f1 -d' ' | \
- env LD_LIBRARY_PATH=${STAGEDIR}${PREFIX}/lib32:${LD_LIBRARY_PATH} xargs ldd -f '%p\n' \
+ ${XARGS} -n1 file -F' ' | grep ELF | cut -f1 -d' ' | \
+ env LD_LIBRARY_PATH=${STAGEDIR}${PREFIX}/lib32:${LD_LIBRARY_PATH} ${XARGS} ldd -f '%p\n' \
| sort -u | grep -v '^\(/usr\)\?/lib' | grep -v "^${STAGEDIR}${PREFIX}/lib32/libwine.so" \
| grep -v "^${STAGEDIR}${PREFIX}/lib32/wine" > ${WRKDIR}/winelibs
for i in `cat ${WRKDIR}/winelibs` ; do \
diff --git a/emulators/i386-wine/Makefile.i386 b/emulators/i386-wine/Makefile.i386
index c4994e87c046..913424817773 100644
--- a/emulators/i386-wine/Makefile.i386
+++ b/emulators/i386-wine/Makefile.i386
@@ -37,7 +37,7 @@ post-install-script:
${REINPLACE_CMD} -e 's!lib/!lib32/!g' ${TMPPLIST}
# Install bounce script to access the 32-bit executables
${INSTALL_SCRIPT} ${SLAVEDIR}/files/binbounce ${STAGEDIR}${PREFIX}/bin/wine
- for i in `grep ^bin ${TMPPLIST} | xargs -n1 basename` ; do \
+ for i in `grep ^bin ${TMPPLIST} | ${XARGS} -n1 basename` ; do \
[ "$${i}" = "wine" ] || ${LN} -f ${STAGEDIR}${PREFIX}/bin/wine ${STAGEDIR}${PREFIX}/bin/$${i} ; \
echo bin32/$${i} >> ${TMPPLIST} ; \
done
@@ -52,7 +52,7 @@ post-install-script:
done
# Find all soft dependencies (via strings(1))
grep -v '[@%]' ${TMPPLIST} | sed "s!^!${STAGEDIR}${PREFIX}/!g" | \
- xargs -n1 file -F' ' | grep ELF | cut -f1 -d' ' | xargs strings | \
+ ${XARGS} -n1 file -F' ' | grep ELF | cut -f1 -d' ' | ${XARGS} strings | \
grep '^lib.*\.so' | sort -u > ${WRKDIR}/winesoftlibs
for i in `cat ${WRKDIR}/winesoftlibs` ; do \
if [ -e ${LOCALBASE}/lib/$${i} ] && [ -z "`grep $${i} ${TMPPLIST}`" ]; then \
@@ -62,8 +62,8 @@ post-install-script:
done
# Find all libraries that are linked too (via ldd(1))
grep -v '[@%]' ${TMPPLIST} | sed "s!^!${STAGEDIR}${PREFIX}/!g" | \
- xargs -n1 file -F' ' | grep ELF | cut -f1 -d' ' | \
- env LD_LIBRARY_PATH=${STAGEDIR}${PREFIX}/lib32:${LD_LIBRARY_PATH} xargs ldd -f '%p\n' \
+ ${XARGS} -n1 file -F' ' | grep ELF | cut -f1 -d' ' | \
+ env LD_LIBRARY_PATH=${STAGEDIR}${PREFIX}/lib32:${LD_LIBRARY_PATH} ${XARGS} ldd -f '%p\n' \
| sort -u | grep -v '^\(/usr\)\?/lib' | grep -v "^${STAGEDIR}${PREFIX}/lib32/libwine.so" \
| grep -v "^${STAGEDIR}${PREFIX}/lib32/wine" > ${WRKDIR}/winelibs
for i in `cat ${WRKDIR}/winelibs` ; do \