aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-10-12 07:16:18 +0800
committeredwin <edwin@FreeBSD.org>2004-10-12 07:16:18 +0800
commit1ac7b2039a43e7feadee58f24367dff4dec8e40b (patch)
treec16f0adb05f149f1f76f2070fc3494a6b108c53c /emulators
parentb7e124425ab829c30e5efc0cabab0a42fdaf32d5 (diff)
downloadfreebsd-ports-gnome-1ac7b2039a43e7feadee58f24367dff4dec8e40b.tar.gz
freebsd-ports-gnome-1ac7b2039a43e7feadee58f24367dff4dec8e40b.tar.zst
freebsd-ports-gnome-1ac7b2039a43e7feadee58f24367dff4dec8e40b.zip
Update: emulators/dosbox to 0.62
Updates dosbox from 0.61 to 0.62. Updates are speed/stability increases, general updates, and gcc 3.4 support without the patch. Note, the file 'files/patch-include-dos_inc.h' and the directory 'files' have been removed. PR: ports/72289 Submitted by: Tom Carrick <knyghtmare@knyghtmare.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dosbox/Makefile4
-rw-r--r--emulators/dosbox/distinfo4
-rw-r--r--emulators/dosbox/files/patch-include-dos_inc.h33
3 files changed, 3 insertions, 38 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index 64d28b9cdfad..72c523284042 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dosbox
-PORTVERSION= 0.61
-PORTREVISION= 1
+PORTVERSION= 0.62
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -30,7 +29,6 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --enable-core-inline
post-patch:
- @${REINPLACE_CMD} -e 's#SDL\/#SDL11\/#g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's#\/usr\/share\/doc\/dosbox#${DOCSDIR}#g' \
${WRKSRC}/docs/dosbox.1
@${SED} 's#%%DOCSDIR%%#${DOCSDIR}#' ${PKGDIR}/pkg-message > \
diff --git a/emulators/dosbox/distinfo b/emulators/dosbox/distinfo
index c3671d2ff802..21394ab78838 100644
--- a/emulators/dosbox/distinfo
+++ b/emulators/dosbox/distinfo
@@ -1,2 +1,2 @@
-MD5 (dosbox-0.61.tar.gz) = dcb549eb2a9e6fe6995b973ef9ac6e9f
-SIZE (dosbox-0.61.tar.gz) = 567200
+MD5 (dosbox-0.62.tar.gz) = 80b10f438119f9d83b44dcf175493dcb
+SIZE (dosbox-0.62.tar.gz) = 633259
diff --git a/emulators/dosbox/files/patch-include-dos_inc.h b/emulators/dosbox/files/patch-include-dos_inc.h
deleted file mode 100644
index 08ea8b3f171d..000000000000
--- a/emulators/dosbox/files/patch-include-dos_inc.h
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -u -r1.43 -r1.44
---- include/dos_inc.h 2004/05/05 21:56:04 1.43
-+++ include/dos_inc.h 2004/05/15 07:57:02 1.44
-@@ -214,22 +214,22 @@
-
- class MemStruct {
- public:
-- INLINE Bit8u GetIt(Bit8u&,PhysPt addr) {
-+ INLINE Bit8u GetIt(Bit8u,PhysPt addr) {
- return mem_readb(pt+addr);
- }
-- INLINE Bit16u GetIt(Bit16u&,PhysPt addr) {
-+ INLINE Bit16u GetIt(Bit16u,PhysPt addr) {
- return mem_readw(pt+addr);
- }
-- INLINE Bit32u GetIt(Bit32u&,PhysPt addr) {
-+ INLINE Bit32u GetIt(Bit32u,PhysPt addr) {
- return mem_readd(pt+addr);
- }
-- INLINE void SaveIt(Bit8u&,PhysPt addr,Bit8u val) {
-+ INLINE void SaveIt(Bit8u,PhysPt addr,Bit8u val) {
- mem_writeb(pt+addr,val);
- }
-- INLINE void SaveIt(Bit16u&,PhysPt addr,Bit16u val) {
-+ INLINE void SaveIt(Bit16u,PhysPt addr,Bit16u val) {
- mem_writew(pt+addr,val);
- }
-- INLINE void SaveIt(Bit32u&,PhysPt addr,Bit32u val) {
-+ INLINE void SaveIt(Bit32u,PhysPt addr,Bit32u val) {
- mem_writed(pt+addr,val);
- }
- INLINE void SetPt(Bit16u seg) { pt=PhysMake(seg,0);}
-