aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-06-06 05:09:18 +0800
committererwin <erwin@FreeBSD.org>2006-06-06 05:09:18 +0800
commit2113fcb43c60914566dfedd2032bb6a064e49429 (patch)
tree6869d1b4d575b91bf011260340479d8601c997bb /emulators
parent5fe7a08a29706597e4f66ba9d42233926c0c61dd (diff)
downloadfreebsd-ports-gnome-2113fcb43c60914566dfedd2032bb6a064e49429.tar.gz
freebsd-ports-gnome-2113fcb43c60914566dfedd2032bb6a064e49429.tar.zst
freebsd-ports-gnome-2113fcb43c60914566dfedd2032bb6a064e49429.zip
Add linux_base-gentoo-stage3 2006.0, files from Gentoo distribution, for
Linux compatibility. PR: ports/97152 Submitted by: Gabor Kovesdan
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/linux_base-gentoo-stage3/Makefile74
-rw-r--r--emulators/linux_base-gentoo-stage3/distinfo9
-rw-r--r--emulators/linux_base-gentoo-stage3/pkg-deinstall36
-rw-r--r--emulators/linux_base-gentoo-stage3/pkg-descr3
-rw-r--r--emulators/linux_base-gentoo-stage3/pkg-install43
-rw-r--r--emulators/linux_base-gentoo-stage3/pkg-message16
-rw-r--r--emulators/linux_dist-gentoo-stage3/Makefile74
-rw-r--r--emulators/linux_dist-gentoo-stage3/distinfo9
-rw-r--r--emulators/linux_dist-gentoo-stage3/pkg-deinstall36
-rw-r--r--emulators/linux_dist-gentoo-stage3/pkg-descr3
-rw-r--r--emulators/linux_dist-gentoo-stage3/pkg-install43
-rw-r--r--emulators/linux_dist-gentoo-stage3/pkg-message16
13 files changed, 363 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 9039877e8021..a920cabc1487 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -71,6 +71,7 @@
SUBDIR += linux_base-fc4
SUBDIR += linux_base-gentoo-stage1
SUBDIR += linux_base-gentoo-stage2
+ SUBDIR += linux_base-gentoo-stage3
SUBDIR += linux_base-rh-9
SUBDIR += linux_base-suse-9.1
SUBDIR += linux_base-suse-9.2
diff --git a/emulators/linux_base-gentoo-stage3/Makefile b/emulators/linux_base-gentoo-stage3/Makefile
new file mode 100644
index 000000000000..9bf60720b7dd
--- /dev/null
+++ b/emulators/linux_base-gentoo-stage3/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: linux_base-gentoo-stage3
+# Date created: 11 May 2006
+# Whom: Gabor Kovesdan
+#
+# $FreeBSD$
+
+PORTNAME= linux_base-gentoo-stage3
+PORTVERSION= 2006.0
+CATEGORIES= emulators linux
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Files from Gentoo distribution, for Linux compatibility
+
+RESTRICTED= binaries licensed under GNU GPL without accompanying source
+
+CONFLICTS= linux_base-7* linux_base-8* linux_base-debian* \
+ linux_base-rh* linux_base-suse* linux_base-fc* \
+ linux_base-gentoo-stage[12]-*
+
+DIST_SUBDIR= gentoo-linux
+NO_BUILD= YES
+NO_FILTER_SHLIBS= YES
+NO_MTREE= YES
+ONLY_FOR_ARCHS= i386 amd64
+PLIST= ${WRKDIR}/pkg-plist
+PREFIX= ${LINUXBASE}
+USE_BZIP2= YES
+GENTOO_OPTIMIZED?= x86
+
+.include <bsd.port.pre.mk>
+
+.if (${GENTOO_OPTIMIZED} == "i586" || ${GENTOO_OPTIMIZED} == "i686")
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages
+DISTNAME= stage3-${GENTOO_OPTIMIZED}-${PORTVERSION}
+.else
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages
+DISTNAME= stage3-x86-${PORTVERSION}
+.endif
+
+pre-fetch:
+ @${ECHO_MSG} "You can select your processor class for installing optimized"
+ @${ECHO_MSG} "Gentoo binaries with setting this knob"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "GENTOO_OPTIMIZED=[x86|i586|i686]."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "The default is x86 for 386/486 compatibility."
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${TAR} --exclude=./dev --exclude=./proc -xpy -C ${WRKSRC} \
+ -f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
+ @${ECHO_CMD} etc/resolv.conf > ${PLIST}
+ @${ECHO_CMD} lib/udev/devices/console >> ${PLIST}
+ @${ECHO_CMD} lib/udev/devices/null >> ${PLIST}
+ @${ECHO_CMD} lib/udev/devices/zero >> ${PLIST}
+ @cd ${WRKSRC} && ${FIND} * -type f -o -type l >> ${PLIST} \
+ && ${FIND} * -type d | ${SORT} -r | ${SED} -e 's:^:@dirrm :' \
+ >> ${PLIST}
+ @${RM} -fr ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${TAR} --exclude=./dev -xpy --exclude=./proc -C ${PREFIX} \
+ -f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
+ @${FIND} ${PREFIX} \! -path "/compat/linux/proc*" -type d -exec ${CHMOD} 755 \{\} \;
+ @${CP} -p /etc/resolv.conf ${PREFIX}/etc/
+ @${BRANDELF} -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/linux_base-gentoo-stage3/distinfo b/emulators/linux_base-gentoo-stage3/distinfo
new file mode 100644
index 000000000000..f09396738dbf
--- /dev/null
+++ b/emulators/linux_base-gentoo-stage3/distinfo
@@ -0,0 +1,9 @@
+MD5 (gentoo-linux/stage3-x86-2006.0.tar.bz2) = b0e1a162f59d172c7b5a3776355c3f42
+SHA256 (gentoo-linux/stage3-x86-2006.0.tar.bz2) = f0bab2b2babd0447cf2e744ecdf2645c9ac6ce3b1cf8a995b965c081cd3a2803
+SIZE (gentoo-linux/stage3-x86-2006.0.tar.bz2) = 103593867
+MD5 (gentoo-linux/stage3-i586-2006.0.tar.bz2) = aa3bd74cc41f6ac34bddb9cd5a5d6539
+SHA256 (gentoo-linux/stage3-i586-2006.0.tar.bz2) = 09be297139ff63b481e8b7735440fae6f6fb698dd5e86333024c6b8c9f50bcaa
+SIZE (gentoo-linux/stage3-i586-2006.0.tar.bz2) = 104713233
+MD5 (gentoo-linux/stage3-i686-2006.0.tar.bz2) = 42b5b865cfd199d4c607b95e5ce140fe
+SHA256 (gentoo-linux/stage3-i686-2006.0.tar.bz2) = 98f11e98e7aa13d8a8c88255587f79fe998f6623b39909c21d8a7764dca8abe6
+SIZE (gentoo-linux/stage3-i686-2006.0.tar.bz2) = 104949773
diff --git a/emulators/linux_base-gentoo-stage3/pkg-deinstall b/emulators/linux_base-gentoo-stage3/pkg-deinstall
new file mode 100644
index 000000000000..02474ddf3347
--- /dev/null
+++ b/emulators/linux_base-gentoo-stage3/pkg-deinstall
@@ -0,0 +1,36 @@
+#!/bin/sh
+# a deinstallation script for linux_base
+
+case "$2" in
+DEINSTALL)
+ if [ -n "`mount | grep ^linproc`" ] || \
+ [ -d /compat/linux/proc ]; then
+ echo ""
+ echo "You may need to do by hands:"
+ echo " o unmount linprocfs;"
+ echo " o delete ${PKG_PREFIX}/proc;"
+ echo " o remove the description of linprocfs from /etc/fstab."
+ echo ""
+ fi
+ ;;
+esac
+
+exit 0
+#!/bin/sh
+# a deinstallation script for linux_base
+
+case "$2" in
+DEINSTALL)
+ if [ -n "`mount | grep ^linproc`" ] || \
+ [ -d /compat/linux/proc ]; then
+ echo ""
+ echo "You may need to do by hands:"
+ echo " o unmount linprocfs;"
+ echo " o delete ${PKG_PREFIX}/proc;"
+ echo " o remove the description of linprocfs from /etc/fstab."
+ echo ""
+ fi
+ ;;
+esac
+
+exit 0
diff --git a/emulators/linux_base-gentoo-stage3/pkg-descr b/emulators/linux_base-gentoo-stage3/pkg-descr
new file mode 100644
index 000000000000..81dc425cf222
--- /dev/null
+++ b/emulators/linux_base-gentoo-stage3/pkg-descr
@@ -0,0 +1,3 @@
+This port installs the stage3 distribution of Gentoo Linux.
+
+WWW: http://www.gentoo.org/
diff --git a/emulators/linux_base-gentoo-stage3/pkg-install b/emulators/linux_base-gentoo-stage3/pkg-install
new file mode 100644
index 000000000000..4cd4941ac58b
--- /dev/null
+++ b/emulators/linux_base-gentoo-stage3/pkg-install
@@ -0,0 +1,43 @@
+#!/bin/sh
+# an installation script for linux_base
+
+case "$2" in
+PRE-INSTALL)
+ if [ -z "`kldstat -v | grep -E 'linux(aout|elf)'`" ]; then
+ echo 'Linux mode is not enabled.'
+ echo 'Loading linux kernel module now...'
+ if ! kldload linux; then
+ echo 'The linux kernel module could not be loaded.'
+ echo 'Please enable linux mode manually and retry.'
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ if [ -z "`grep ^linproc /etc/fstab`" ]; then
+ echo ''
+ echo '+++ Some programs may need the linprocfs, please add it to /etc/fstab! +++'
+ else
+ if [ -z "`mount | grep -w ^linprocfs`" ]; then
+ echo ''
+ echo '+++ Please mount linprocfs manually! +++'
+ fi
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/nsswitch.conf ]; then
+ cp ${PKG_PREFIX}/etc/nsswitch.conf.dist \
+ ${PKG_PREFIX}/etc/nsswitch.conf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/yp.conf ]; then
+ cp ${PKG_PREFIX}/etc/yp.conf.sample ${PKG_PREFIX}/etc/yp.conf
+ fi
+#
+# This is needed for updating to ensure that
+# already installed libraries get to ${PKG_PREFIX}/etc/ld.so.cache
+#
+ echo ''
+ echo 'Running linux ldconfig...'
+ ${PKG_PREFIX}/sbin/ldconfig -r ${PKG_PREFIX}
+ ;;
+esac
+
+exit 0
diff --git a/emulators/linux_base-gentoo-stage3/pkg-message b/emulators/linux_base-gentoo-stage3/pkg-message
new file mode 100644
index 000000000000..d7f5863ae088
--- /dev/null
+++ b/emulators/linux_base-gentoo-stage3/pkg-message
@@ -0,0 +1,16 @@
+* The port/package has attempted to enable Linux compatibility mode by loading
+* the linux.ko kernel module. You can load the module manually as root with the
+* command "kldload linux" or have it load automatically at boot time by adding
+* to /etc/rc.conf the line:
+*
+* linux_enable="YES"
+*
+* You may wish to enable emulation of the Linux proc filesystem. See the
+* linprocfs(5) man page.
+*
+* To download Portage, do "chroot /compat/linux emerge sync" as root. Then you
+* may want to do "chroot /compat/linux /usr/portage/scripts/bootstrap.sh" to
+* rebuild binutils, gcc, gettext, and glibc. See
+* <URL:http://www.gentoo.org/doc/en/gentoo-alpha-install.xml> or
+* <URL:http://www.gentoo.org/doc/en/gentoo-x86-install.xml> for more complete
+* instructions.
diff --git a/emulators/linux_dist-gentoo-stage3/Makefile b/emulators/linux_dist-gentoo-stage3/Makefile
new file mode 100644
index 000000000000..9bf60720b7dd
--- /dev/null
+++ b/emulators/linux_dist-gentoo-stage3/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: linux_base-gentoo-stage3
+# Date created: 11 May 2006
+# Whom: Gabor Kovesdan
+#
+# $FreeBSD$
+
+PORTNAME= linux_base-gentoo-stage3
+PORTVERSION= 2006.0
+CATEGORIES= emulators linux
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Files from Gentoo distribution, for Linux compatibility
+
+RESTRICTED= binaries licensed under GNU GPL without accompanying source
+
+CONFLICTS= linux_base-7* linux_base-8* linux_base-debian* \
+ linux_base-rh* linux_base-suse* linux_base-fc* \
+ linux_base-gentoo-stage[12]-*
+
+DIST_SUBDIR= gentoo-linux
+NO_BUILD= YES
+NO_FILTER_SHLIBS= YES
+NO_MTREE= YES
+ONLY_FOR_ARCHS= i386 amd64
+PLIST= ${WRKDIR}/pkg-plist
+PREFIX= ${LINUXBASE}
+USE_BZIP2= YES
+GENTOO_OPTIMIZED?= x86
+
+.include <bsd.port.pre.mk>
+
+.if (${GENTOO_OPTIMIZED} == "i586" || ${GENTOO_OPTIMIZED} == "i686")
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages
+DISTNAME= stage3-${GENTOO_OPTIMIZED}-${PORTVERSION}
+.else
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages
+DISTNAME= stage3-x86-${PORTVERSION}
+.endif
+
+pre-fetch:
+ @${ECHO_MSG} "You can select your processor class for installing optimized"
+ @${ECHO_MSG} "Gentoo binaries with setting this knob"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "GENTOO_OPTIMIZED=[x86|i586|i686]."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "The default is x86 for 386/486 compatibility."
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${TAR} --exclude=./dev --exclude=./proc -xpy -C ${WRKSRC} \
+ -f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
+ @${ECHO_CMD} etc/resolv.conf > ${PLIST}
+ @${ECHO_CMD} lib/udev/devices/console >> ${PLIST}
+ @${ECHO_CMD} lib/udev/devices/null >> ${PLIST}
+ @${ECHO_CMD} lib/udev/devices/zero >> ${PLIST}
+ @cd ${WRKSRC} && ${FIND} * -type f -o -type l >> ${PLIST} \
+ && ${FIND} * -type d | ${SORT} -r | ${SED} -e 's:^:@dirrm :' \
+ >> ${PLIST}
+ @${RM} -fr ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${TAR} --exclude=./dev -xpy --exclude=./proc -C ${PREFIX} \
+ -f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
+ @${FIND} ${PREFIX} \! -path "/compat/linux/proc*" -type d -exec ${CHMOD} 755 \{\} \;
+ @${CP} -p /etc/resolv.conf ${PREFIX}/etc/
+ @${BRANDELF} -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/linux_dist-gentoo-stage3/distinfo b/emulators/linux_dist-gentoo-stage3/distinfo
new file mode 100644
index 000000000000..f09396738dbf
--- /dev/null
+++ b/emulators/linux_dist-gentoo-stage3/distinfo
@@ -0,0 +1,9 @@
+MD5 (gentoo-linux/stage3-x86-2006.0.tar.bz2) = b0e1a162f59d172c7b5a3776355c3f42
+SHA256 (gentoo-linux/stage3-x86-2006.0.tar.bz2) = f0bab2b2babd0447cf2e744ecdf2645c9ac6ce3b1cf8a995b965c081cd3a2803
+SIZE (gentoo-linux/stage3-x86-2006.0.tar.bz2) = 103593867
+MD5 (gentoo-linux/stage3-i586-2006.0.tar.bz2) = aa3bd74cc41f6ac34bddb9cd5a5d6539
+SHA256 (gentoo-linux/stage3-i586-2006.0.tar.bz2) = 09be297139ff63b481e8b7735440fae6f6fb698dd5e86333024c6b8c9f50bcaa
+SIZE (gentoo-linux/stage3-i586-2006.0.tar.bz2) = 104713233
+MD5 (gentoo-linux/stage3-i686-2006.0.tar.bz2) = 42b5b865cfd199d4c607b95e5ce140fe
+SHA256 (gentoo-linux/stage3-i686-2006.0.tar.bz2) = 98f11e98e7aa13d8a8c88255587f79fe998f6623b39909c21d8a7764dca8abe6
+SIZE (gentoo-linux/stage3-i686-2006.0.tar.bz2) = 104949773
diff --git a/emulators/linux_dist-gentoo-stage3/pkg-deinstall b/emulators/linux_dist-gentoo-stage3/pkg-deinstall
new file mode 100644
index 000000000000..02474ddf3347
--- /dev/null
+++ b/emulators/linux_dist-gentoo-stage3/pkg-deinstall
@@ -0,0 +1,36 @@
+#!/bin/sh
+# a deinstallation script for linux_base
+
+case "$2" in
+DEINSTALL)
+ if [ -n "`mount | grep ^linproc`" ] || \
+ [ -d /compat/linux/proc ]; then
+ echo ""
+ echo "You may need to do by hands:"
+ echo " o unmount linprocfs;"
+ echo " o delete ${PKG_PREFIX}/proc;"
+ echo " o remove the description of linprocfs from /etc/fstab."
+ echo ""
+ fi
+ ;;
+esac
+
+exit 0
+#!/bin/sh
+# a deinstallation script for linux_base
+
+case "$2" in
+DEINSTALL)
+ if [ -n "`mount | grep ^linproc`" ] || \
+ [ -d /compat/linux/proc ]; then
+ echo ""
+ echo "You may need to do by hands:"
+ echo " o unmount linprocfs;"
+ echo " o delete ${PKG_PREFIX}/proc;"
+ echo " o remove the description of linprocfs from /etc/fstab."
+ echo ""
+ fi
+ ;;
+esac
+
+exit 0
diff --git a/emulators/linux_dist-gentoo-stage3/pkg-descr b/emulators/linux_dist-gentoo-stage3/pkg-descr
new file mode 100644
index 000000000000..81dc425cf222
--- /dev/null
+++ b/emulators/linux_dist-gentoo-stage3/pkg-descr
@@ -0,0 +1,3 @@
+This port installs the stage3 distribution of Gentoo Linux.
+
+WWW: http://www.gentoo.org/
diff --git a/emulators/linux_dist-gentoo-stage3/pkg-install b/emulators/linux_dist-gentoo-stage3/pkg-install
new file mode 100644
index 000000000000..4cd4941ac58b
--- /dev/null
+++ b/emulators/linux_dist-gentoo-stage3/pkg-install
@@ -0,0 +1,43 @@
+#!/bin/sh
+# an installation script for linux_base
+
+case "$2" in
+PRE-INSTALL)
+ if [ -z "`kldstat -v | grep -E 'linux(aout|elf)'`" ]; then
+ echo 'Linux mode is not enabled.'
+ echo 'Loading linux kernel module now...'
+ if ! kldload linux; then
+ echo 'The linux kernel module could not be loaded.'
+ echo 'Please enable linux mode manually and retry.'
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ if [ -z "`grep ^linproc /etc/fstab`" ]; then
+ echo ''
+ echo '+++ Some programs may need the linprocfs, please add it to /etc/fstab! +++'
+ else
+ if [ -z "`mount | grep -w ^linprocfs`" ]; then
+ echo ''
+ echo '+++ Please mount linprocfs manually! +++'
+ fi
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/nsswitch.conf ]; then
+ cp ${PKG_PREFIX}/etc/nsswitch.conf.dist \
+ ${PKG_PREFIX}/etc/nsswitch.conf
+ fi
+ if [ ! -f ${PKG_PREFIX}/etc/yp.conf ]; then
+ cp ${PKG_PREFIX}/etc/yp.conf.sample ${PKG_PREFIX}/etc/yp.conf
+ fi
+#
+# This is needed for updating to ensure that
+# already installed libraries get to ${PKG_PREFIX}/etc/ld.so.cache
+#
+ echo ''
+ echo 'Running linux ldconfig...'
+ ${PKG_PREFIX}/sbin/ldconfig -r ${PKG_PREFIX}
+ ;;
+esac
+
+exit 0
diff --git a/emulators/linux_dist-gentoo-stage3/pkg-message b/emulators/linux_dist-gentoo-stage3/pkg-message
new file mode 100644
index 000000000000..d7f5863ae088
--- /dev/null
+++ b/emulators/linux_dist-gentoo-stage3/pkg-message
@@ -0,0 +1,16 @@
+* The port/package has attempted to enable Linux compatibility mode by loading
+* the linux.ko kernel module. You can load the module manually as root with the
+* command "kldload linux" or have it load automatically at boot time by adding
+* to /etc/rc.conf the line:
+*
+* linux_enable="YES"
+*
+* You may wish to enable emulation of the Linux proc filesystem. See the
+* linprocfs(5) man page.
+*
+* To download Portage, do "chroot /compat/linux emerge sync" as root. Then you
+* may want to do "chroot /compat/linux /usr/portage/scripts/bootstrap.sh" to
+* rebuild binutils, gcc, gettext, and glibc. See
+* <URL:http://www.gentoo.org/doc/en/gentoo-alpha-install.xml> or
+* <URL:http://www.gentoo.org/doc/en/gentoo-x86-install.xml> for more complete
+* instructions.