aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-10-13 05:56:09 +0800
committerpawel <pawel@FreeBSD.org>2012-10-13 05:56:09 +0800
commit35288ef5e7c96ff0f18cfbfade5a2ee59d3c81f7 (patch)
treee55158288ededf6159d9b5ac545f5233f7eac3a6 /emulators
parent4af73d31376d802500121e31434d2ab30ab0aed2 (diff)
downloadfreebsd-ports-gnome-35288ef5e7c96ff0f18cfbfade5a2ee59d3c81f7.tar.gz
freebsd-ports-gnome-35288ef5e7c96ff0f18cfbfade5a2ee59d3c81f7.tar.zst
freebsd-ports-gnome-35288ef5e7c96ff0f18cfbfade5a2ee59d3c81f7.zip
Swine is a graphical wine frontend, that makes it easy to install and run
Windows software on Linux systems. Swine uses a modern QT4 interface to offer most of the Wine command-line tools to users. WWW: http://www.swine-tool.de/ PR: ports/172142 Submitted by: nemysis@gmx.ch Feature safe: yes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/swine/Makefile83
-rw-r--r--emulators/swine/distinfo2
-rw-r--r--emulators/swine/pkg-descr5
-rw-r--r--emulators/swine/pkg-message14
-rw-r--r--emulators/swine/pkg-plist84
6 files changed, 189 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index b8466c119f62..877389936280 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -157,6 +157,7 @@
SUBDIR += stella
SUBDIR += stonx
SUBDIR += svr4_base
+ SUBDIR += swine
SUBDIR += tiemu2
SUBDIR += tiemu3
SUBDIR += tilem
diff --git a/emulators/swine/Makefile b/emulators/swine/Makefile
new file mode 100644
index 000000000000..ea2aee5b96d1
--- /dev/null
+++ b/emulators/swine/Makefile
@@ -0,0 +1,83 @@
+# Created by: nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= swine
+PORTVERSION= 1.0.2
+CATEGORIES= emulators deskutils python
+MASTER_SITES= GH
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= QT4 Graphical Wine frontend
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= pyrcc4:${PORTSDIR}/textproc/py-qt4-xml
+RUN_DEPENDS= wine:${PORTSDIR}/emulators/wine-devel \
+ xterm:${PORTSDIR}/x11/xterm \
+ cabextract:${PORTSDIR}/archivers/cabextract \
+ icotool:${PORTSDIR}/graphics/icoutils \
+ ${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-core \
+ ${PYTHON_PKGNAMEPREFIX}qt4-gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui
+
+DATADIRLIB= ${PREFIX}/lib/${PORTNAME}
+
+USE_GITHUB= yes
+GH_ACCOUNT= dswd
+GH_PROJECT= Swine
+GH_TAGNAME= master
+GH_COMMIT= d14b9f0
+
+USE_PYTHON= yes
+USE_GMAKE= yes
+USE_QT4= linguist_build
+
+PORTDOCS= README
+
+.include "../../devel/py-sip/files/bsd.pyqt.mk"
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/version.sh
+
+pre-build:
+.if !exists(${LOCALBASE}/bin/wine) && ${ARCH} != "i386"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Depends on Wine Port which is only available for i386"
+ @${ECHO_MSG}
+ @${ECHO_MSG} " http://wiki.freebsd.org/Wine"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "FreeBSD/amd64 works with Wine 32bit binary from"
+ @${ECHO_MSG}
+ @${ECHO_MSG} " http://www.mediafire.com/wine_fbsd64"
+ @${ECHO_MSG}
+ exit 1
+.endif
+
+do-build:
+ @(cd ${WRKSRC} ; ${GMAKE})
+
+do-install:
+ ${MKDIR} ${DATADIRLIB}
+ ${INSTALL_DATA} ${WRKSRC}/resources.qrc ${DATADIRLIB}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIRLIB}
+ ${LN} -sf ${DATADIRLIB}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+ ${LN} -sf ${DATADIRLIB}/${PORTNAME}cli.py ${PREFIX}/bin/${PORTNAME}cli
+ ${LN} -sf ${DATADIRLIB}/${PORTNAME}run.py ${PREFIX}/bin/${PORTNAME}run
+ ${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "translations images" ${DATADIR})
+
+ ${LN} -sf ${DATADIR}/images/swine32.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/resources/*.desktop ${PREFIX}/share/applications/
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/emulators/swine/distinfo b/emulators/swine/distinfo
new file mode 100644
index 000000000000..bf69657a54c0
--- /dev/null
+++ b/emulators/swine/distinfo
@@ -0,0 +1,2 @@
+SHA256 (swine-1.0.2.tar.gz) = 938aa8f261d6f566da2fd5a75c19685a853d8dec3f1c258746cb4f2ca0b564fc
+SIZE (swine-1.0.2.tar.gz) = 203558
diff --git a/emulators/swine/pkg-descr b/emulators/swine/pkg-descr
new file mode 100644
index 000000000000..8f5bb14730c0
--- /dev/null
+++ b/emulators/swine/pkg-descr
@@ -0,0 +1,5 @@
+Swine is a graphical wine frontend, that makes it easy to install and run
+Windows software on Linux systems. Swine uses a modern QT4 interface to offer
+most of the Wine command-line tools to users.
+
+WWW: http://www.swine-tool.de/
diff --git a/emulators/swine/pkg-message b/emulators/swine/pkg-message
new file mode 100644
index 000000000000..ab648151e3b5
--- /dev/null
+++ b/emulators/swine/pkg-message
@@ -0,0 +1,14 @@
+################################################################################
+
+This programm will attempt to obtain some system information by accessing files
+in procfs. You must mount procfs filesystem for this to work correctly.
+This can be accomplished by adding the following line to your /etc/fstab file:
+
+# Device Mountpoint FStype Options Dump Pass#
+proc /proc procfs rw 0 0
+
+and then, as root, executing the command:
+
+mount /proc
+
+################################################################################
diff --git a/emulators/swine/pkg-plist b/emulators/swine/pkg-plist
new file mode 100644
index 000000000000..2bbbd54043f3
--- /dev/null
+++ b/emulators/swine/pkg-plist
@@ -0,0 +1,84 @@
+bin/swine
+bin/swinecli
+bin/swinerun
+lib/swine/AboutDialog.py
+lib/swine/IconDialog.py
+lib/swine/MainWindow.py
+lib/swine/ProgramDialog.py
+lib/swine/RunnerDialog.py
+lib/swine/Settings.py
+lib/swine/ShortcutImport.py
+lib/swine/SlotSettings.py
+lib/swine/config.py
+lib/swine/icolib.py
+lib/swine/resources.qrc
+lib/swine/resources_rc.py
+lib/swine/shortcutlib.py
+lib/swine/swine.py
+lib/swine/swinecli.py
+lib/swine/swinelib.py
+lib/swine/swinerun.py
+lib/swine/winetricks.py
+share/applications/swine-extensions.desktop
+share/applications/swine.desktop
+share/pixmaps/swine.png
+%%DATADIR%%/images/add.png
+%%DATADIR%%/images/application.png
+%%DATADIR%%/images/application_add.png
+%%DATADIR%%/images/application_delete.png
+%%DATADIR%%/images/application_edit.png
+%%DATADIR%%/images/application_form_magnify.png
+%%DATADIR%%/images/application_lightning.png
+%%DATADIR%%/images/application_xp_terminal.png
+%%DATADIR%%/images/arrow_divide.png
+%%DATADIR%%/images/arrow_refresh.png
+%%DATADIR%%/images/cog.png
+%%DATADIR%%/images/computer.png
+%%DATADIR%%/images/computer_edit.png
+%%DATADIR%%/images/cross.png
+%%DATADIR%%/images/document-open-folder.png
+%%DATADIR%%/images/document-open.png
+%%DATADIR%%/images/drive_add.png
+%%DATADIR%%/images/drive_cd.png
+%%DATADIR%%/images/drive_delete.png
+%%DATADIR%%/images/drive_magnify.png
+%%DATADIR%%/images/drive_rename.png
+%%DATADIR%%/images/film.png
+%%DATADIR%%/images/film_add.png
+%%DATADIR%%/images/find.png
+%%DATADIR%%/images/folder.png
+%%DATADIR%%/images/folder_explore.png
+%%DATADIR%%/images/folder_grey.png
+%%DATADIR%%/images/font.png
+%%DATADIR%%/images/font_add.png
+%%DATADIR%%/images/information.png
+%%DATADIR%%/images/lightning_add.png
+%%DATADIR%%/images/lightning_delete.png
+%%DATADIR%%/images/package_add.png
+%%DATADIR%%/images/package_go.png
+%%DATADIR%%/images/pencil.png
+%%DATADIR%%/images/pencil_add.png
+%%DATADIR%%/images/plugin.png
+%%DATADIR%%/images/plugin_add.png
+%%DATADIR%%/images/script_gear.png
+%%DATADIR%%/images/script_save.png
+%%DATADIR%%/images/shape_flip_vertical.png
+%%DATADIR%%/images/swine32.png
+%%DATADIR%%/images/textfield_rename.png
+%%DATADIR%%/images/wabi.png
+%%DATADIR%%/images/wine.png
+%%DATADIR%%/images/world.png
+%%DATADIR%%/images/world_add.png
+%%DATADIR%%/images/world_go.png
+%%DATADIR%%/images/wrench.png
+%%DATADIR%%/images/wrench_orange.png
+%%DATADIR%%/translations/de.qm
+%%DATADIR%%/translations/en.qm
+%%DATADIR%%/translations/es.qm
+%%DATADIR%%/translations/fr.qm
+%%DATADIR%%/translations/he.qm
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%
+@dirrmtry share/applications
+@dirrm lib/swine