aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-09-16 06:37:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-09-16 06:37:41 +0800
commit360cc69109e8d594bf4bde2283775c566c92adb0 (patch)
tree72e6f19d746135e8de609734add1f8ea621478ee /emulators
parent0a3bea238f8f5ddb26ac80b3cac614543df8a8aa (diff)
downloadfreebsd-ports-gnome-360cc69109e8d594bf4bde2283775c566c92adb0.tar.gz
freebsd-ports-gnome-360cc69109e8d594bf4bde2283775c566c92adb0.tar.zst
freebsd-ports-gnome-360cc69109e8d594bf4bde2283775c566c92adb0.zip
VisualBoyAdvance-M is an emulator of the Game Boy, Super Game Boy,
Game Boy Color, and Game Boy Advance. The -M fork is a collection of community patches to the original VisualBoyAdvance. It includes an option GTK frontend. WWW: http://vba-m.com/ PR: 144064 Submitted by: okeeblow <root@cooltrainer.org>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/visualboyadvance-m/Makefile67
-rw-r--r--emulators/visualboyadvance-m/distinfo3
-rw-r--r--emulators/visualboyadvance-m/files/patch-src-common-Patch.cpp11
-rw-r--r--emulators/visualboyadvance-m/files/patch-src-gtk-gvbam.desktop7
-rw-r--r--emulators/visualboyadvance-m/pkg-descr6
-rw-r--r--emulators/visualboyadvance-m/pkg-plist30
7 files changed, 125 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 0171890eaf25..20fd2252c5e2 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -176,6 +176,7 @@
SUBDIR += virtualbox-ose
SUBDIR += virtualbox-ose-additions
SUBDIR += virtualbox-ose-kmod
+ SUBDIR += visualboyadvance-m
SUBDIR += visualos
SUBDIR += vmips
SUBDIR += vmsbackup
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
new file mode 100644
index 000000000000..b5a7e12b23b7
--- /dev/null
+++ b/emulators/visualboyadvance-m/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: visualboyadvance-m
+# Date created: 2010-01-02
+# Whom: Nicole Reid <root@cooltrainer.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= visualboyadvance-m
+PORTVERSION= 1.8.0r${SVN_REV}
+CATEGORIES= emulators
+MASTER_SITES= http://update.cooltrainer.org/emulators/visualboyadvance-m/
+
+MAINTAINER= root@cooltrainer.org
+COMMENT= Game Boy Advance emulator with GTK frontend
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libsfml-system.so:${PORTSDIR}/devel/sfml
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+ cairomm-1.0.1:${PORTSDIR}/graphics/cairomm
+
+OPTIONS= GVBAM "Build gvbam (GTK2 frontend)" on \
+ ASM "Enable ASM core and filters (i386 only)" off
+
+USE_BZIP2= yes
+WANT_GNOME= yes
+USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*\.(c|cpp|h)
+USE_XORG= x11 xext
+USE_GL= gl glu
+USE_SDL= sdl
+USE_CMAKE= yes
+CMAKE_ARGS+= -DVERSION:STRING="${PORTVERSION}" -DSYSCONFDIR:STRING="${PREFIX}/etc"
+SVN_REV= 945
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ASM) && ${ARCH} == "i386"
+BUILD_DEPENDS+= as:${PORTSDIR}/devel/binutils
+CMAKE_ARGS+= -DUSE_ASM_CORE=yes -DUSE_ASM_SCALERS=yes
+.endif
+
+.if defined(WITH_GVBAM)
+PLIST_SUB+= GVBAM=""
+USE_GNOME= gtk20
+LIB_DEPENDS+= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ glibmm-2.4:${PORTSDIR}/devel/glibmm \
+ giomm-2.4:${PORTSDIR}/devel/glibmm \
+ glademm-2.4:${PORTSDIR}/devel/libglademm24 \
+ gdkglextmm-x11-1.2:${PORTSDIR}/x11-toolkits/gtkglextmm
+.else
+PLIST_SUB+= GVBAM="@comment "
+CMAKE_ARGS+= -DNO_GTK:BOOL=yes
+.endif
+
+post-install:
+ -@update-desktop-database
+
+maint-gen-distfile:
+ @if [ -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
+ ${ECHO_CMD} "ERROR: the distfile already exists."; \
+ ${FALSE}; \
+ fi
+ svn export -r${SVN_REV} \
+ https://vbam.svn.sourceforge.net/svnroot/vbam/trunk ${DISTNAME}
+ ${TAR} jcf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}
+ ${RM} -rf ${DISTNAME}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/visualboyadvance-m/distinfo b/emulators/visualboyadvance-m/distinfo
new file mode 100644
index 000000000000..b70d5d399908
--- /dev/null
+++ b/emulators/visualboyadvance-m/distinfo
@@ -0,0 +1,3 @@
+MD5 (visualboyadvance-m-1.8.0r945.tar.bz2) = 078a095b7f8e42b3bc2e676ebf4a4b98
+SHA256 (visualboyadvance-m-1.8.0r945.tar.bz2) = a0f54912f564a27415a40035b0b88d57a17702962d3841a10843a5d2d8e2c5ea
+SIZE (visualboyadvance-m-1.8.0r945.tar.bz2) = 739556
diff --git a/emulators/visualboyadvance-m/files/patch-src-common-Patch.cpp b/emulators/visualboyadvance-m/files/patch-src-common-Patch.cpp
new file mode 100644
index 000000000000..32436d31a30a
--- /dev/null
+++ b/emulators/visualboyadvance-m/files/patch-src-common-Patch.cpp
@@ -0,0 +1,11 @@
+--- src/common/Patch.cpp.orig 2010-01-02 21:18:59.624899346 -0500
++++ src/common/Patch.cpp 2010-01-02 21:18:45.448378670 -0500
+@@ -4,7 +4,7 @@
+ #include <zlib.h>
+
+ #include "Patch.h"
+-
++#include <sys/param.h>
+
+ #ifdef __GNUC__
+ #if defined(__APPLE__) || defined (BSD)
diff --git a/emulators/visualboyadvance-m/files/patch-src-gtk-gvbam.desktop b/emulators/visualboyadvance-m/files/patch-src-gtk-gvbam.desktop
new file mode 100644
index 000000000000..bb25d03f0b19
--- /dev/null
+++ b/emulators/visualboyadvance-m/files/patch-src-gtk-gvbam.desktop
@@ -0,0 +1,7 @@
+--- src/gtk/gvbam.desktop.orig 2010-01-03 11:21:23.810842812 -0500
++++ src/gtk/gvbam.desktop 2010-01-03 11:22:48.352184026 -0500
+@@ -8,3 +8,4 @@
+ Exec=gvbam
+ Icon=vbam
+ Categories=Application;Game;Emulator;GTK
++MimeType=application/x-gameboy-rom;application/x-gba-rom;
diff --git a/emulators/visualboyadvance-m/pkg-descr b/emulators/visualboyadvance-m/pkg-descr
new file mode 100644
index 000000000000..5af87a76237b
--- /dev/null
+++ b/emulators/visualboyadvance-m/pkg-descr
@@ -0,0 +1,6 @@
+VisualBoyAdvance-M is an emulator of the Game Boy, Super Game Boy,
+Game Boy Color, and Game Boy Advance. The -M fork is a collection
+of community patches to the original VisualBoyAdvance. It includes an
+option GTK frontend.
+
+WWW: http://vba-m.com/
diff --git a/emulators/visualboyadvance-m/pkg-plist b/emulators/visualboyadvance-m/pkg-plist
new file mode 100644
index 000000000000..a8294a336254
--- /dev/null
+++ b/emulators/visualboyadvance-m/pkg-plist
@@ -0,0 +1,30 @@
+bin/vbam
+%%GVBAM%%bin/gvbam
+%%GVBAM%%share/applications/gvbam.desktop
+%%GVBAM%%share/icons/hicolor/16x16/apps/vbam.png
+%%GVBAM%%share/icons/hicolor/22x22/apps/vbam.png
+%%GVBAM%%share/icons/hicolor/24x24/apps/vbam.png
+%%GVBAM%%share/icons/hicolor/32x32/apps/vbam.png
+%%GVBAM%%share/icons/hicolor/scalable/apps/vbam.svg
+%%GVBAM%%share/vbam/ui/sound.ui
+%%GVBAM%%share/vbam/ui/gameboyadvance.ui
+%%GVBAM%%share/vbam/ui/display.ui
+%%GVBAM%%share/vbam/ui/gameboy.ui
+%%GVBAM%%share/vbam/ui/vbam.glade
+%%GVBAM%%@dirrmtry share/icons/hicolor/16x16/apps/
+%%GVBAM%%@dirrmtry share/icons/hicolor/22x22/apps/
+%%GVBAM%%@dirrmtry share/icons/hicolor/24x24/apps/
+%%GVBAM%%@dirrmtry share/icons/hicolor/32x32/apps/
+%%GVBAM%%@dirrmtry share/icons/hicolor/scalable/apps/
+%%GVBAM%%@dirrmtry share/icons/hicolor/16x16/
+%%GVBAM%%@dirrmtry share/icons/hicolor/22x22/
+%%GVBAM%%@dirrmtry share/icons/hicolor/24x24/
+%%GVBAM%%@dirrmtry share/icons/hicolor/32x32/
+%%GVBAM%%@dirrmtry share/icons/hicolor/scalable/
+%%GVBAM%%@dirrmtry share/icons/hicolor/
+%%GVBAM%%@dirrmtry share/icons/
+%%GVBAM%%@dirrm share/vbam/ui
+%%GVBAM%%@dirrm share/vbam
+%%GVBAM%%@dirrmtry share/applications
+%%GVBAM%%@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+%%GVBAM%%@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true