aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-09-17 02:13:25 +0800
committernox <nox@FreeBSD.org>2011-09-17 02:13:25 +0800
commit400a915340fe9441114f791b0ff5134070dc286a (patch)
tree4e98dc108667855c024a1f184e4310775db0544b /emulators
parenta8669827e0e1c876fdda3ae08a013c02222ce855 (diff)
downloadfreebsd-ports-gnome-400a915340fe9441114f791b0ff5134070dc286a.tar.gz
freebsd-ports-gnome-400a915340fe9441114f791b0ff5134070dc286a.tar.zst
freebsd-ports-gnome-400a915340fe9441114f791b0ff5134070dc286a.zip
SeaBIOS is an open source implementation of a 16bit X86 BIOS. SeaBIOS
can run in an emulator or it can run natively on X86 hardware with the use of coreboot. SeaBIOS is the default BIOS for qemu and kvm. This is a git snapshot to be used with the emulators/qemu-devel port. (compared to the version shipped with qemu 0.15.0 this snapshot adds ahci boot disk support.) WWW: http://www.seabios.org/SeaBIOS
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/seabios-devel/Makefile48
-rw-r--r--emulators/seabios-devel/distinfo2
-rw-r--r--emulators/seabios-devel/pkg-descr11
4 files changed, 62 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 0d69001789fc..147246e2a2f6 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -135,6 +135,7 @@
SUBDIR += quasi88
SUBDIR += raine
SUBDIR += rtc
+ SUBDIR += seabios-devel
SUBDIR += sim6811
SUBDIR += simh
SUBDIR += ski
diff --git a/emulators/seabios-devel/Makefile b/emulators/seabios-devel/Makefile
new file mode 100644
index 000000000000..617a9158ea07
--- /dev/null
+++ b/emulators/seabios-devel/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: seabios-devel
+# Date created: Sat Sep 10 19:00:54 CEST 2011
+# Whom: Juergen Lock <nox@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= seabios-devel
+PORTVERSION= 0.6.3p20110903
+CATEGORIES= emulators
+MASTER_SITES= http://www.linuxtogo.org/~kevin/SeaBIOS/:release \
+ LOCAL/nox/
+DISTNAME= ${PORTNAME:S/-devel//}-${DISTVERSION:C/:(.)/\1/g}
+DIST_SUBDIR= qemu
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= SeaBIOS git snapshot (for emulators/qemu-devel)
+
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_PYTHON_BUILD= yes
+PATCH_STRIP= -p1
+ONLY_FOR_ARCHS= amd64 i386
+CONFLICTS_INSTALL= qemu-[0-9]*
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900033
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin LD=${LOCALBASE}/bin/ld
+.endif
+
+PLIST_FILES= share/qemu/${PORTNAME}.bin
+PLIST_DIRSTRY= share/qemu
+
+post-patch:
+ @${REINPLACE_CMD} s/elf32-i386/elf32-i386-freebsd/g \
+ ${WRKSRC}/tools/layoutrom.py \
+ ${WRKSRC}/vgasrc/vgalayout.lds.S
+ @${REINPLACE_CMD} s/elf_i386/elf_i386_fbsd/g \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/qemu
+ @${INSTALL_DATA} ${WRKSRC}/out/bios.bin ${PREFIX}/share/qemu/${PORTNAME}.bin
+
+.include <bsd.port.post.mk>
diff --git a/emulators/seabios-devel/distinfo b/emulators/seabios-devel/distinfo
new file mode 100644
index 000000000000..7ed3d801f721
--- /dev/null
+++ b/emulators/seabios-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qemu/seabios-0.6.3p20110903.tar.bz2) = c335e237d9776a40039112bf0dba1ddf42ac58e17491cd426e479de47317f9ba
+SIZE (qemu/seabios-0.6.3p20110903.tar.bz2) = 357836
diff --git a/emulators/seabios-devel/pkg-descr b/emulators/seabios-devel/pkg-descr
new file mode 100644
index 000000000000..e037fb434736
--- /dev/null
+++ b/emulators/seabios-devel/pkg-descr
@@ -0,0 +1,11 @@
+SeaBIOS is an open source implementation of a 16bit X86 BIOS. SeaBIOS
+can run in an emulator or it can run natively on X86 hardware with
+the use of coreboot.
+
+SeaBIOS is the default BIOS for qemu and kvm.
+
+This is a git snapshot to be used with the emulators/qemu-devel port.
+(compared to the version shipped with qemu 0.15.0 this snapshot adds
+ahci boot disk support.)
+
+WWW: http://www.seabios.org/SeaBIOS