aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-10-05 22:42:53 +0800
committerbapt <bapt@FreeBSD.org>2013-10-05 22:42:53 +0800
commit41ae9216dd170d1253d912849838303a39917dad (patch)
tree67a457a45662e87da936538e7cc50d8f147df556 /emulators
parent47b8c7d5ada938a21d928f4badc5291ba0fc02f3 (diff)
downloadfreebsd-ports-gnome-41ae9216dd170d1253d912849838303a39917dad.tar.gz
freebsd-ports-gnome-41ae9216dd170d1253d912849838303a39917dad.tar.zst
freebsd-ports-gnome-41ae9216dd170d1253d912849838303a39917dad.zip
Removed unmaintained (ports@) or gnome@ ports depending on gnome1
Approved by: gnome (implicit)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile2
-rw-r--r--emulators/gsnes9x/Makefile30
-rw-r--r--emulators/gsnes9x/distinfo2
-rw-r--r--emulators/gsnes9x/files/patch-aa46
-rw-r--r--emulators/gsnes9x/files/patch-ab38
-rw-r--r--emulators/gsnes9x/pkg-descr7
-rw-r--r--emulators/gsnes9x/pkg-plist35
-rw-r--r--emulators/visualos/Makefile29
-rw-r--r--emulators/visualos/distinfo2
-rw-r--r--emulators/visualos/files/patch-po::Makefile.in.in14
-rw-r--r--emulators/visualos/pkg-descr9
-rw-r--r--emulators/visualos/pkg-plist8
12 files changed, 0 insertions, 222 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 996bf06d849a..e83257d30e37 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -48,7 +48,6 @@
SUBDIR += gngeo
SUBDIR += gns3
SUBDIR += gnuboy
- SUBDIR += gsnes9x
SUBDIR += gxemul
SUBDIR += gxmame
SUBDIR += hatari
@@ -172,7 +171,6 @@
SUBDIR += virtualbox-ose-kmod-legacy
SUBDIR += virtualbox-ose-legacy
SUBDIR += visualboyadvance-m
- SUBDIR += visualos
SUBDIR += vmips
SUBDIR += vmsbackup
SUBDIR += vmw
diff --git a/emulators/gsnes9x/Makefile b/emulators/gsnes9x/Makefile
deleted file mode 100644
index 31c37fe2c6fb..000000000000
--- a/emulators/gsnes9x/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# Created by: Kelly Yancey <kbyanc@posi.net>
-# $FreeBSD$
-
-PORTNAME= gsnes9x
-PORTVERSION= 3.12
-PORTREVISION= 10
-CATEGORIES= emulators
-MASTER_SITES= SF/${PORTNAME}/GSnes9x/${PORTVERSION}
-DISTNAME= GSnes9x-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK front-end for the Snes9X SNES emulator
-
-RUN_DEPENDS= snes9x:${PORTSDIR}/emulators/snes9x
-
-USES= pathfix
-USE_GNOME= gnomeprefix gnomelibs
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
-
-NO_STAGE= yes
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|^SUBDIRS = intl|SUBDIRS =|g ; \
- s|@INTLLIBS@|-lintl|g ; \
- s|@INTLDEPS@||g'
-
-.include <bsd.port.mk>
diff --git a/emulators/gsnes9x/distinfo b/emulators/gsnes9x/distinfo
deleted file mode 100644
index 9b25f56403a4..000000000000
--- a/emulators/gsnes9x/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (GSnes9x-3.12.tar.gz) = 1914496f6f6efa7bb756f8dfdba6d573d85448125b12354e48de4a269c507fce
-SIZE (GSnes9x-3.12.tar.gz) = 659553
diff --git a/emulators/gsnes9x/files/patch-aa b/emulators/gsnes9x/files/patch-aa
deleted file mode 100644
index 07efe2dcc369..000000000000
--- a/emulators/gsnes9x/files/patch-aa
+++ /dev/null
@@ -1,46 +0,0 @@
---- src/util.c.orig Sun Jun 18 17:34:30 2000
-+++ src/util.c Sun Jun 18 18:06:56 2000
-@@ -79,7 +79,7 @@
- if (!names)
- return list;
-
-- getline (&str, &size, names);
-+ fgets (str, size, names);
- str[strlen (str)-1] = '\0'; /* Rip out the '\n'. */
-
- while (!feof (names)) {
-@@ -102,7 +102,7 @@
- if (rom_info)
- list = g_list_prepend (list, (gpointer)rom_info);
-
-- getline (&str, &size, names);
-+ fgets (str, size, names);
- str[strlen(str)-1] = '\0';
- }
-
-@@ -314,7 +314,7 @@
- if (!file)
- return list;
-
-- getline (&str, &size, file);
-+ fgets (str, size, file);
- str[strlen (str)-1] = '\0'; /* Rip out '\n' */
- if (!strcmp (str, ""))
- return list;
-@@ -322,13 +322,13 @@
- do {
- cheat_code = g_new (CheatCode, 1);
- cheat_code->code = g_strdup (str);
-- getline (&str, &size, file);
-+ fgets (str, size, file);
- str[strlen (str)-1] = '\0'; /* Rip out '\n' */
- cheat_code->name = g_strdup (str);
-- getline (&str, &size, file);
-+ fgets (str, size, file);
- str[strlen (str)-1] = '\0'; /* Rip out '\n' */
- cheat_code->descr = g_strdup (str);
-- getline (&str, &size, file);
-+ fgets (str, size, file);
-
- if (strcmp (str, cheat_code->descr))
- str[strlen (str)-1] = '\0'; /* Rip out '\n' */
diff --git a/emulators/gsnes9x/files/patch-ab b/emulators/gsnes9x/files/patch-ab
deleted file mode 100644
index 235c38fd8a70..000000000000
--- a/emulators/gsnes9x/files/patch-ab
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/confiles.c.orig Sun Jun 18 17:34:23 2000
-+++ src/confiles.c Sun Jun 18 18:06:27 2000
-@@ -81,7 +81,7 @@
- file = fopen (conf, "r");
- }
-
-- getline (&str, &size, file);
-+ fgets (str, size, file);
- str[strlen (str)-1] = '\0';
-
- while (!feof (file)) {
-@@ -142,7 +142,7 @@
- }
- }
-
-- getline (&str, &size, file);
-+ fgets (str, size, file);
- str[strlen (str)-1] = '\0';
-
- if (lval)
-@@ -179,7 +179,7 @@
- return NULL;
- }
-
-- getline (&str, &size, file);
-+ fgets (str, size, file);
- str[strlen (str)-1] = '\0';
-
- while (!feof (file)) {
-@@ -237,7 +237,7 @@
- }
- }
-
-- getline (&str, &size, file);
-+ fgets (str, size, file);
- str[strlen (str)-1] = '\0';
-
- if (lval)
diff --git a/emulators/gsnes9x/pkg-descr b/emulators/gsnes9x/pkg-descr
deleted file mode 100644
index ace3c6706d47..000000000000
--- a/emulators/gsnes9x/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-GSnes9x is a GNOME front-end for the Snes9X SNES emulator. It
-allows you to set and preserve the options for a particular ROM
-when running it, and to set global options for new ROMs being
-included. It also keeps a Cheat Codes database for each ROM, where
-you can save as many codes as you want.
-
-WWW: http://sourceforge.net/projects/gsnes9x
diff --git a/emulators/gsnes9x/pkg-plist b/emulators/gsnes9x/pkg-plist
deleted file mode 100644
index 68510a9501c5..000000000000
--- a/emulators/gsnes9x/pkg-plist
+++ /dev/null
@@ -1,35 +0,0 @@
-bin/GSnes9x
-share/gnome/apps/Games/gsnes9x.desktop
-share/gnome/help/GSnes9x/C/addrom.png
-share/gnome/help/GSnes9x/C/cheat.png
-share/gnome/help/GSnes9x/C/codes.png
-share/gnome/help/GSnes9x/C/format.png
-share/gnome/help/GSnes9x/C/help-2.html
-share/gnome/help/GSnes9x/C/index.html
-share/gnome/help/GSnes9x/C/info.png
-share/gnome/help/GSnes9x/C/joystick.png
-share/gnome/help/GSnes9x/C/main.png
-share/gnome/help/GSnes9x/C/pop.png
-share/gnome/help/GSnes9x/C/readme-snes9x.html
-share/gnome/help/GSnes9x/C/system.png
-share/gnome/help/GSnes9x/C/tooltips.png
-share/gnome/help/GSnes9x/C/topic.dat
-share/gnome/help/GSnes9x/es/addrom.png
-share/gnome/help/GSnes9x/es/cheat.png
-share/gnome/help/GSnes9x/es/codes.png
-share/gnome/help/GSnes9x/es/format.png
-share/gnome/help/GSnes9x/es/index.html
-share/gnome/help/GSnes9x/es/info.png
-share/gnome/help/GSnes9x/es/joystick.png
-share/gnome/help/GSnes9x/es/main.png
-share/gnome/help/GSnes9x/es/pop.png
-share/gnome/help/GSnes9x/es/system.png
-share/gnome/help/GSnes9x/es/tooltips.png
-share/gnome/help/GSnes9x/es/topic.dat
-share/locale/es/LC_MESSAGES/GSnes9x.mo
-share/locale/no/LC_MESSAGES/GSnes9x.mo
-share/pixmaps/gsnes9x-icon.png
-share/pixmaps/gsnesdefault.png
-@dirrm share/gnome/help/GSnes9x/es
-@dirrm share/gnome/help/GSnes9x/C
-@dirrm share/gnome/help/GSnes9x
diff --git a/emulators/visualos/Makefile b/emulators/visualos/Makefile
deleted file mode 100644
index 1d8cdd33ab1c..000000000000
--- a/emulators/visualos/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= VisualOS
-PORTVERSION= 1.0.5
-PORTREVISION= 9
-CATEGORIES= emulators gnome
-MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}/${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Visual simulator of an operating system to help understand an OSes
-
-LICENSE= GPLv2
-
-USES= pathfix
-USE_GNOME= gnomeprefix libglade
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-MAN1= VisualOS.1
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e '/^#define _/d' ${WRKSRC}/src/signals.c
-
-.include <bsd.port.mk>
diff --git a/emulators/visualos/distinfo b/emulators/visualos/distinfo
deleted file mode 100644
index d34995eebc96..000000000000
--- a/emulators/visualos/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (VisualOS-1.0.5.tar.gz) = 80b6d0c2999b18741bf3f9a4397e08a636fa4c6deb2313cb8959668e5b5f9ac3
-SIZE (VisualOS-1.0.5.tar.gz) = 1066835
diff --git a/emulators/visualos/files/patch-po::Makefile.in.in b/emulators/visualos/files/patch-po::Makefile.in.in
deleted file mode 100644
index f04809780e48..000000000000
--- a/emulators/visualos/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- po/Makefile.in.in 2002/06/10 09:43:52 1.1
-+++ po/Makefile.in.in 2002/06/10 09:44:05
-@@ -106,7 +106,7 @@
- @catalogs='$(CATALOGS)'; \
- for cat in $$catalogs; do \
- cat=`basename $$cat`; \
-- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
-+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
- dir=$(localedir)/$$lang/LC_MESSAGES; \
- $(mkinstalldirs) $(DESTDIR)$$dir; \
- if test -r $$cat; then \
diff --git a/emulators/visualos/pkg-descr b/emulators/visualos/pkg-descr
deleted file mode 100644
index 2fd86c3b40b4..000000000000
--- a/emulators/visualos/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-VisualOS is a "visual simulator of an operating system", that will help
-study and understand the way a real systems work.
-
-It allows the user to insert processes in the running system, assigning them
-properties (memory usage, processing bursts, IO accesses) and VisualOS will
-dynamically show different graphical representations of each subsystem. It is
-also possible to select the algorithm to be used in each case.
-
-WWW: http://sourceforge.net/projects/visualos/
diff --git a/emulators/visualos/pkg-plist b/emulators/visualos/pkg-plist
deleted file mode 100644
index ae5883b206c7..000000000000
--- a/emulators/visualos/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/VisualOS
-share/VisualOS/VisualOS.glade
-share/VisualOS/io_editor_disk.xpm
-share/locale/cs/LC_MESSAGES/VisualOS.mo
-share/locale/es/LC_MESSAGES/VisualOS.mo
-share/locale/fr/LC_MESSAGES/VisualOS.mo
-share/locale/it/LC_MESSAGES/VisualOS.mo
-@dirrm share/VisualOS