aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-12-28 07:08:02 +0800
committerrene <rene@FreeBSD.org>2013-12-28 07:08:02 +0800
commit4213047d41e57190106f14aa31fdb9fbaaeb5a17 (patch)
tree5f366851fc5f80e3ed9a5f2090efde3a47429ba7 /emulators
parent0ade769b5c4cfd8ad11a2468eba93a5f61c51b32 (diff)
downloadfreebsd-ports-gnome-4213047d41e57190106f14aa31fdb9fbaaeb5a17.tar.gz
freebsd-ports-gnome-4213047d41e57190106f14aa31fdb9fbaaeb5a17.tar.zst
freebsd-ports-gnome-4213047d41e57190106f14aa31fdb9fbaaeb5a17.zip
- Modernize dos2unix and gmake
- Undeprecate, futher fixes are in progress - Remove leading definite article from comment PR: ports/182097 Submitted by: Eugene Grosbein <egrosbein@rdtc.ru> Approved by: portmgr (blanket infrastructure)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fmsx/Makefile10
-rw-r--r--emulators/fmsx/files/patch-EMULib_LibUnix.c19
-rw-r--r--emulators/fmsx/files/patch-EMULib_Rules.gcc11
-rw-r--r--emulators/fmsx/files/patch-fMSX_Unix_Makefile13
4 files changed, 45 insertions, 8 deletions
diff --git a/emulators/fmsx/Makefile b/emulators/fmsx/Makefile
index 36cffe887209..76ad13d1564e 100644
--- a/emulators/fmsx/Makefile
+++ b/emulators/fmsx/Makefile
@@ -16,15 +16,13 @@ DIST_SUBDIR= fmsx351
EXTRACT_ONLY= fMSX351.zip
MAINTAINER= dk@farm.org
-COMMENT= The Portable MSX/MSX2/MSX2+ Emulator
-
-DEPRECATED= Broken for more than 6 month
-EXPIRATION_DATE= 2013-12-18
+COMMENT= Portable MSX/MSX2/MSX2+ Emulator
USE_XORG= xi x11
USE_ZIP= yes
-USE_GMAKE= yes
-USE_DOS2UNIX= EMULib/NetUnix.c EMULib/Rules.Unix
+USES= gmake dos2unix
+DOS2UNIX_FILES= EMULib/LibUnix.c EMULib/NetUnix.c EMULib/Rules.gcc \
+ EMULib/Rules.Unix
RESTRICTED= Legal status of distributed ROM images unclear
WRKSRC= ${WRKDIR}
diff --git a/emulators/fmsx/files/patch-EMULib_LibUnix.c b/emulators/fmsx/files/patch-EMULib_LibUnix.c
new file mode 100644
index 000000000000..a24960d1045c
--- /dev/null
+++ b/emulators/fmsx/files/patch-EMULib_LibUnix.c
@@ -0,0 +1,19 @@
+--- EMULib/LibUnix.c.orig 2013-12-20 21:09:39.000000000 +0100
++++ EMULib/LibUnix.c 2013-12-20 21:56:52.000000000 +0100
+@@ -142,7 +142,7 @@
+ else
+ #endif
+ XPutImage(Dsp,Wnd,DefaultGCOfScreen(Scr),VideoImg->XImg,VideoX,VideoY,(XSize-VideoW)>>1,(YSize-VideoH)>>1,VideoW,VideoH);
+- return;
++ return(1);
+ }
+
+ /* Scale video buffer into OutImg */
+@@ -159,6 +159,7 @@
+ else
+ #endif
+ XPutImage(Dsp,Wnd,DefaultGCOfScreen(Scr),OutImg.XImg,0,0,0,0,XSize,YSize);
++ return(1);
+ }
+
+ /** GetJoystick() ********************************************/
diff --git a/emulators/fmsx/files/patch-EMULib_Rules.gcc b/emulators/fmsx/files/patch-EMULib_Rules.gcc
new file mode 100644
index 000000000000..3bdd04f2c516
--- /dev/null
+++ b/emulators/fmsx/files/patch-EMULib_Rules.gcc
@@ -0,0 +1,11 @@
+--- EMULib/Rules.gcc.orig 2013-12-20 20:52:16.000000000 +0100
++++ EMULib/Rules.gcc 2013-12-20 20:52:22.000000000 +0100
+@@ -6,7 +6,7 @@
+ LIBGBZ = $(BASEDIR)/GBZ80
+ PRIVATE = $(BASEDIR)/Private
+
+-CC = gcc
++CC ?= gcc
+ CPP = cpp
+ CFLAGS = -O3 -pthread -I.. -I$(EMULIB)
+ DEFINES = -DZLIB
diff --git a/emulators/fmsx/files/patch-fMSX_Unix_Makefile b/emulators/fmsx/files/patch-fMSX_Unix_Makefile
index 553a2a65e892..faf02eb955d4 100644
--- a/emulators/fmsx/files/patch-fMSX_Unix_Makefile
+++ b/emulators/fmsx/files/patch-fMSX_Unix_Makefile
@@ -1,5 +1,14 @@
---- fMSX/Unix/Makefile.orig 2008-01-28 19:29:59.000000000 +0000
-+++ fMSX/Unix/Makefile 2008-05-26 05:52:08.000000000 +0000
+--- fMSX/Unix/Makefile.orig 2008-01-28 20:29:59.000000000 +0100
++++ fMSX/Unix/Makefile 2013-12-20 20:16:13.000000000 +0100
+@@ -1,7 +1,7 @@
+ include ../../EMULib/Rules.Unix
+
+ DEFINES+= -DFMSX -DLSB_FIRST -DBPP16 -DCONDEBUG -DDEBUG
+-CFLAGS += -I$(LIBZ80)
++CFLAGS += -I$(LIBZ80) -Wno-pointer-to-int-cast -Wno-int-to-pointer-cast
+ OBJECTS+= $(EMUUNIX) $(FLOPPY) $(FDIDISK) \
+ $(Z80) $(I8255) $(YM2413) $(AY8910) $(SCC) $(WD1793) \
+ ../fMSX.o ../MSX.o ../V9938.o ../I8251.o ../Patch.o \
@@ -10,7 +10,7 @@
all: fmsx