aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-09-27 18:14:26 +0800
committerRene Ladan <rene@FreeBSD.org>2013-09-27 18:14:26 +0800
commit44df6d755999c705c5a750621e9eff4ccf1cf3b4 (patch)
tree9297377d35deaffef2a06de27c38640e012ef719 /emulators
parenteeefd7a196bebf40aa58b6cc79c5872ea29ecb1d (diff)
downloadfreebsd-ports-gnome-44df6d755999c705c5a750621e9eff4ccf1cf3b4.tar.gz
freebsd-ports-gnome-44df6d755999c705c5a750621e9eff4ccf1cf3b4.tar.zst
freebsd-ports-gnome-44df6d755999c705c5a750621e9eff4ccf1cf3b4.zip
Add staging support
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fuse-utils/Makefile12
-rw-r--r--emulators/fuse-utils/pkg-plist16
2 files changed, 19 insertions, 9 deletions
diff --git a/emulators/fuse-utils/Makefile b/emulators/fuse-utils/Makefile
index 94a18954325e..282ee9a708d1 100644
--- a/emulators/fuse-utils/Makefile
+++ b/emulators/fuse-utils/Makefile
@@ -19,23 +19,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libspectrum-prefix=${LOCALBASE} \
--with-local-prefix=${LOCALBASE}
-MAN1= createhdf.1 fmfconv.1 fuse-utils.1 listbasic.1 raw2hdf.1 rzxcheck.1 \
- rzxdump.1 rzxtool.1 scl2trd.1 snap2tzx.1 snapconv.1 tapeconv.1 \
- tzxlist.1 profile2map.1
-
OPTIONS_DEFINE= AUDIOTOOLS DOCS
OPTIONS_DEFAULT= AUDIOTOOLS
AUDIOTOOLS_DESC= Build audio <-> tape utilities
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAUDIOTOOLS}
CONFIGURE_ARGS+=--with-audiofile
LIB_DEPENDS+= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
PLIST_SUB= AUDIOTOOLS=""
-MAN1+= audio2tape.1 tape2wav.1
.else
CONFIGURE_ARGS+=--without-audiofile
PLIST_SUB= AUDIOTOOLS="@comment "
@@ -49,10 +43,10 @@ PLIST_SUB= AUDIOTOOLS="@comment "
CONFIGURE_ARGS+=--without-ffmpeg
#.endif
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog README ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/emulators/fuse-utils/pkg-plist b/emulators/fuse-utils/pkg-plist
index ff86106edc17..6b08eea7ae93 100644
--- a/emulators/fuse-utils/pkg-plist
+++ b/emulators/fuse-utils/pkg-plist
@@ -13,6 +13,22 @@ bin/snapconv
%%AUDIOTOOLS%%bin/tape2wav
bin/tapeconv
bin/tzxlist
+man/man1/createhdf.1.gz
+man/man1/fmfconv.1.gz
+man/man1/fuse-utils.1.gz
+man/man1/listbasic.1.gz
+man/man1/raw2hdf.1.gz
+man/man1/rzxcheck.1.gz
+man/man1/rzxdump.1.gz
+man/man1/rzxtool.1.gz
+man/man1/scl2trd.1.gz
+man/man1/snap2tzx.1.gz
+man/man1/snapconv.1.gz
+man/man1/tapeconv.1.gz
+man/man1/tzxlist.1.gz
+man/man1/profile2map.1.gz
+%%AUDIOTOOLS%%man/man1/audio2tape.1.gz
+%%AUDIOTOOLS%%man/man1/tape2wav.1.gz
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README