aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2016-12-21 13:53:30 +0800
committerlwhsu <lwhsu@FreeBSD.org>2016-12-21 13:53:30 +0800
commit498f5d399fb8deabada3c40ca77009a14ccf6fe8 (patch)
tree66e052231f240f1f6f36cca4f3426ff258fa3460 /emulators
parentf26d8b663f75478b5c0b6f25ec265cec1f9bd047 (diff)
downloadfreebsd-ports-gnome-498f5d399fb8deabada3c40ca77009a14ccf6fe8.tar.gz
freebsd-ports-gnome-498f5d399fb8deabada3c40ca77009a14ccf6fe8.tar.zst
freebsd-ports-gnome-498f5d399fb8deabada3c40ca77009a14ccf6fe8.zip
Add emulators/qemu-riscv, QEMU with RISC-V (RV64G, RV32G) emulation support
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/qemu-riscv/Makefile59
-rw-r--r--emulators/qemu-riscv/distinfo3
-rw-r--r--emulators/qemu-riscv/pkg-descr3
4 files changed, 66 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index b515063708db..b247af95df34 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -124,6 +124,7 @@
SUBDIR += qemu-cheri128m
SUBDIR += qemu-devel
SUBDIR += qemu-launcher
+ SUBDIR += qemu-riscv
SUBDIR += qemu-sbruno
SUBDIR += qemu-user-static
SUBDIR += qemu-utils
diff --git a/emulators/qemu-riscv/Makefile b/emulators/qemu-riscv/Makefile
new file mode 100644
index 000000000000..053a68685236
--- /dev/null
+++ b/emulators/qemu-riscv/Makefile
@@ -0,0 +1,59 @@
+# $FreeBSD$
+
+PORTNAME= qemu
+PORTVERSION= 2.7.50
+PORTREVISION= 20161221
+CATEGORIES= emulators
+PKGNAMESUFFIX?= -riscv
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= QEMU with RISC-V (RV64G, RV32G) emulation support
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= riscv
+GH_PROJECT= riscv-qemu
+GH_TAGNAME= 21e3a7c
+
+HAS_CONFIGURE= yes
+USES= gmake libtool makeinfo pkgconfig python:2,build
+USE_XORG= pixman
+USE_GNOME+= glib20
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
+
+CONFIGURE_ARGS+=--target-list=riscv64-softmmu,riscv32-softmmu \
+ --cc=${CC} \
+ --disable-curl \
+ --disable-docs \
+ --disable-gtk \
+ --disable-gcrypt \
+ --disable-kvm \
+ --disable-libssh2 \
+ --disable-linux-aio \
+ --disable-linux-user \
+ --disable-vnc \
+ --disable-sdl \
+ --disable-nettle \
+ --disable-gnutls \
+ --disable-vte \
+ --disable-xen \
+ --extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\" \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" \
+ --localstatedir=/var \
+ --python=${PYTHON_CMD}
+
+PLIST_FILES= bin/qemu-system-riscv32 \
+ bin/qemu-system-riscv64
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1100000
+IGNORE= does not build
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/riscv32-softmmu/qemu-system-riscv32 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/riscv64-softmmu/qemu-system-riscv64 ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/emulators/qemu-riscv/distinfo b/emulators/qemu-riscv/distinfo
new file mode 100644
index 000000000000..1da74681003e
--- /dev/null
+++ b/emulators/qemu-riscv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1482292185
+SHA256 (riscv-riscv-qemu-2.7.50-21e3a7c_GH0.tar.gz) = b4de04be3c7b5386281b382d79bdbc81752fe950ccd3c373529c1c47d0396161
+SIZE (riscv-riscv-qemu-2.7.50-21e3a7c_GH0.tar.gz) = 12931938
diff --git a/emulators/qemu-riscv/pkg-descr b/emulators/qemu-riscv/pkg-descr
new file mode 100644
index 000000000000..2a94ac607893
--- /dev/null
+++ b/emulators/qemu-riscv/pkg-descr
@@ -0,0 +1,3 @@
+QEMU with RISC-V (RV64G, RV32G) emulation support
+
+WWW: https://github.com/riscv/riscv-qemu