aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-08-24 05:49:57 +0800
committergerald <gerald@FreeBSD.org>2017-08-24 05:49:57 +0800
commit4b17ac82a55bc0afacfa9d16b9a31eca0bd86291 (patch)
treef58444a2ba1a3efc2c7f9bd30f852751e619d615 /emulators
parent3af5f0b9df012501cb7fb6b5d46256b22bb66077 (diff)
downloadfreebsd-ports-gnome-4b17ac82a55bc0afacfa9d16b9a31eca0bd86291.tar.gz
freebsd-ports-gnome-4b17ac82a55bc0afacfa9d16b9a31eca0bd86291.tar.zst
freebsd-ports-gnome-4b17ac82a55bc0afacfa9d16b9a31eca0bd86291.zip
Update to Wine 2.15. This includes the following changes:
- Support for AES encryption. - Improved Bezier support in Direct2D. - Chunked transfer improvements in WinInet. - Various bug fixes. Move USES a bit up in the Makefile to respect desired order.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile4
-rw-r--r--emulators/wine-devel/distinfo10
-rw-r--r--emulators/wine-devel/pkg-plist6
3 files changed, 13 insertions, 7 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index a03fb1edca60..c46e74fec0ae 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wine
-DISTVERSION= 2.14
+DISTVERSION= 2.15
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -38,11 +38,11 @@ CONFIGURE_ARGS+=--verbose --disable-tests \
--without-tiff
CONFIGURE_ENV= CPPBIN="${CPP}" FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
+USES= bison compiler:c11 desktop-file-utils gmake shebangfix tar:xz
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
.endif
ONLY_FOR_ARCHS= amd64 i386
-USES= bison compiler:c11 desktop-file-utils gmake shebangfix tar:xz
SHEBANG_FILES= tools/make_requests tools/winemaker/winemaker \
tools/winedump/function_grep.pl
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index d99e978aed67..acf2c7ce42e2 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1502172149
-SHA256 (wine-2.14.tar.xz) = 03f934d95181f728600ca04d395f10e821ee38cfa31655e872e4d27d2a8795c6
-SIZE (wine-2.14.tar.xz) = 19447812
-SHA256 (v2.14.tar.gz) = cd4c8e400a808cbfa5c5cf088ea874c761d09db897f25bc33eab840101020b19
-SIZE (v2.14.tar.gz) = 10179829
+TIMESTAMP = 1503499243
+SHA256 (wine-2.15.tar.xz) = d82d500cbf81fb08c711d3619bd52373138a05574d044f089af89707274868b3
+SIZE (wine-2.15.tar.xz) = 19463720
+SHA256 (v2.15.tar.gz) = f2b5c43fbc185a6fd6399f4c351b83a172737977b2ebb1cbdeddd1838d044bc2
+SIZE (v2.15.tar.gz) = 10190900
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index b883d5a3f7e0..6aff51ca4005 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -395,6 +395,8 @@ include/wine/windows/icftypes.idl
include/wine/windows/icm.h
include/wine/windows/icmpapi.h
include/wine/windows/idispids.h
+include/wine/windows/ieautomation.h
+include/wine/windows/ieautomation.idl
include/wine/windows/iextag.h
include/wine/windows/iextag.idl
include/wine/windows/ifdef.h
@@ -599,6 +601,7 @@ include/wine/windows/opnrst.idl
include/wine/windows/optary.h
include/wine/windows/optary.idl
include/wine/windows/patchapi.h
+%%STAGING%%include/wine/windows/pathcch.h
include/wine/windows/pdh.h
include/wine/windows/pdhmsg.h
include/wine/windows/perhist.h
@@ -1715,6 +1718,7 @@ lib/wine/fakedlls/iccvid.dll
lib/wine/fakedlls/icinfo.exe
lib/wine/fakedlls/icmp.dll
lib/wine/fakedlls/ieframe.dll
+lib/wine/fakedlls/ieproxy.dll
%%STAGING%%lib/wine/fakedlls/iertutil.dll
lib/wine/fakedlls/iexplore.exe
%%WINE32%%lib/wine/fakedlls/ifsmgr.vxd
@@ -2189,6 +2193,7 @@ lib/wine/iccvid.dll.so
lib/wine/icinfo.exe.so
lib/wine/icmp.dll.so
lib/wine/ieframe.dll.so
+lib/wine/ieproxy.dll.so
%%STAGING%%lib/wine/iertutil.dll.so
lib/wine/iexplore.exe.so
%%WINE32%%lib/wine/ifsmgr.vxd.so
@@ -2289,6 +2294,7 @@ lib/wine/libiphlpapi.def
lib/wine/libjsproxy.def
%%WINE32%%lib/wine/libkernel.def
lib/wine/libkernel32.def
+%%STAGING%%lib/wine/libkernelbase.def
lib/wine/libloadperf.def
lib/wine/liblz32.def
lib/wine/libmapi32.def