aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2004-12-31 04:01:00 +0800
committertrevor <trevor@FreeBSD.org>2004-12-31 04:01:00 +0800
commit50271cea2fc30c2680867aee4eb799457cff0401 (patch)
tree15ae341a7f2fce6e8f1020cc9f734de0003a34aa /emulators
parent70ac31847d6e87399f7bda8c470d2f7df0398b05 (diff)
downloadfreebsd-ports-gnome-50271cea2fc30c2680867aee4eb799457cff0401.tar.gz
freebsd-ports-gnome-50271cea2fc30c2680867aee4eb799457cff0401.tar.zst
freebsd-ports-gnome-50271cea2fc30c2680867aee4eb799457cff0401.zip
Rename pre-install target to do-extract, so packing list will be
available after "make all". Submitted by: obrien
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-gentoo-stage1/Makefile4
-rw-r--r--emulators/linux_dist-gentoo-stage1/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/emulators/linux_base-gentoo-stage1/Makefile b/emulators/linux_base-gentoo-stage1/Makefile
index 010c69c5dca4..01f74dc36c80 100644
--- a/emulators/linux_base-gentoo-stage1/Makefile
+++ b/emulators/linux_base-gentoo-stage1/Makefile
@@ -43,7 +43,7 @@ MASTER_SITE_SUBDIR= releases/x86/2004.3/stages/x86
DISTNAME= stage1-x86-2004.3
.endif
-pre-install:
+do-extract:
@${MKDIR} ${WRKSRC}
@${TAR} --exclude=./dev -xp -C ${WRKSRC} \
-f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
@@ -51,7 +51,7 @@ pre-install:
@cd ${WRKSRC} && ${FIND} * -type f -o -type l >> ${PLIST} \
&& ${FIND} * -type d | ${SORT} -r | ${SED} -e 's:^:@dirrm :' \
>> ${PLIST}
- @${RM} -r ${WRKSRC}
+ @${RM} -fr ${WRKSRC}
do-install:
- ${MKDIR} ${PREFIX}
diff --git a/emulators/linux_dist-gentoo-stage1/Makefile b/emulators/linux_dist-gentoo-stage1/Makefile
index 010c69c5dca4..01f74dc36c80 100644
--- a/emulators/linux_dist-gentoo-stage1/Makefile
+++ b/emulators/linux_dist-gentoo-stage1/Makefile
@@ -43,7 +43,7 @@ MASTER_SITE_SUBDIR= releases/x86/2004.3/stages/x86
DISTNAME= stage1-x86-2004.3
.endif
-pre-install:
+do-extract:
@${MKDIR} ${WRKSRC}
@${TAR} --exclude=./dev -xp -C ${WRKSRC} \
-f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
@@ -51,7 +51,7 @@ pre-install:
@cd ${WRKSRC} && ${FIND} * -type f -o -type l >> ${PLIST} \
&& ${FIND} * -type d | ${SORT} -r | ${SED} -e 's:^:@dirrm :' \
>> ${PLIST}
- @${RM} -r ${WRKSRC}
+ @${RM} -fr ${WRKSRC}
do-install:
- ${MKDIR} ${PREFIX}