aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-03 03:51:23 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-03 03:51:23 +0800
commit533cbc94d8036a5a409c650df216cff1d4817813 (patch)
treeb183d02ece363a552d85b6836277e6240d1540a7 /emulators
parent15b12adb92c7fe8bec92937ddfce99750daadf04 (diff)
downloadfreebsd-ports-gnome-533cbc94d8036a5a409c650df216cff1d4817813.tar.gz
freebsd-ports-gnome-533cbc94d8036a5a409c650df216cff1d4817813.tar.zst
freebsd-ports-gnome-533cbc94d8036a5a409c650df216cff1d4817813.zip
Fix build with scons 3.1.1
PR: 240584 Exp-run by: antoine
Diffstat (limited to 'emulators')
-rw-r--r--emulators/nonpareil/Makefile2
-rw-r--r--emulators/nonpareil/files/patch-SConstruct68
-rw-r--r--emulators/nonpareil/files/patch-src_SConscript8
-rw-r--r--emulators/nonpareil/files/patch-src_printer.c6
-rw-r--r--emulators/nonpareil/files/patch-src_proc.c7
-rw-r--r--emulators/nonpareil/files/patch-src_util.c8
-rw-r--r--emulators/nonpareil/files/patch-src_util.h6
7 files changed, 86 insertions, 19 deletions
diff --git a/emulators/nonpareil/Makefile b/emulators/nonpareil/Makefile
index 25e217c152dc..20b4a1fc24f9 100644
--- a/emulators/nonpareil/Makefile
+++ b/emulators/nonpareil/Makefile
@@ -28,7 +28,7 @@ post-patch:
's|%%CFLAGS%%|${CFLAGS}| ; \
s|%%CC%%|${CC}|' ${WRKSRC}/src/SConscript
@${REINPLACE_CMD} -E \
- "s|('/usr/local')|\1,PathOption.PathAccept|" ${WRKSRC}/SConstruct
+ "s|('/usr/local')|\1,PathVariable.PathAccept|" ${WRKSRC}/SConstruct
@${REINPLACE_CMD} -e \
's|<stdint.h>|<inttypes.h>|g' ${WRKSRC}/src/*.[cly]
diff --git a/emulators/nonpareil/files/patch-SConstruct b/emulators/nonpareil/files/patch-SConstruct
new file mode 100644
index 000000000000..cb66299991c6
--- /dev/null
+++ b/emulators/nonpareil/files/patch-SConstruct
@@ -0,0 +1,68 @@
+--- SConstruct.orig 2008-08-24 00:37:34 UTC
++++ SConstruct
+@@ -24,28 +24,28 @@ release = '0.79' # should get from a fi
+ conf_file = 'nonpareil.conf'
+
+ #-----------------------------------------------------------------------------
+-# Options
++# Variables
+ #-----------------------------------------------------------------------------
+
+-opts = Options (conf_file)
++opts = Variables (conf_file)
+
+-opts.AddOptions (EnumOption ('host',
++opts.AddVariables (EnumVariable ('host',
+ help = 'host build platform',
+ allowed_values = ('posix', 'win32'),
+ default = 'posix',
+ ignorecase = 1),
+
+- EnumOption ('target',
++ EnumVariable ('target',
+ help = 'execution target platform',
+ allowed_values = ('posix', 'win32'),
+ default = 'posix',
+ ignorecase = 1),
+
+- PathOption ('prefix',
++ PathVariable ('prefix',
+ 'installation path prefix',
+ '/usr/local'),
+
+- # Don't use PathOption for other paths, because we don't
++ # Don't use PathVariable for other paths, because we don't
+ # require the directories to preexist.
+ ('bindir',
+ 'path for executable files (default is $prefix/bin)',
+@@ -59,25 +59,25 @@ opts.AddOptions (EnumOption ('host',
+ 'installation virtual root directory (for packaging)',
+ ''),
+
+- BoolOption ('debug',
++ BoolVariable ('debug',
+ help = 'compile for debugging',
+ default = 1),
+
+ # Feature switches:
+
+- BoolOption ('has_debugger_gui',
++ BoolVariable ('has_debugger_gui',
+ help = 'enable debugger GUI interface',
+ default = 0),
+
+- BoolOption ('has_debugger_cli',
++ BoolVariable ('has_debugger_cli',
+ help = 'enable debugger command-line interface',
+ default = 0),
+
+- BoolOption ('use_tcl',
++ BoolVariable ('use_tcl',
+ help = 'use Tcl as debug command interpreter (only when debugger CLI is enabled)',
+ default = 1), # only if has_debugger_cli
+
+- BoolOption ('use_readline',
++ BoolVariable ('use_readline',
+ help = 'use Readline library for command editing and history (only when debugger CLI is enabled)',
+ default = 1)) # only if has_debugger_cli
+
diff --git a/emulators/nonpareil/files/patch-src_SConscript b/emulators/nonpareil/files/patch-src_SConscript
index ff15c02c1e78..1db69d1ac677 100644
--- a/emulators/nonpareil/files/patch-src_SConscript
+++ b/emulators/nonpareil/files/patch-src_SConscript
@@ -1,6 +1,6 @@
---- src/SConscript.orig 2008-08-24 09:37:18.000000000 +0900
-+++ src/SConscript 2011-03-20 05:12:10.000000000 +0900
-@@ -41,16 +41,11 @@
+--- src/SConscript.orig 2008-08-24 00:37:18 UTC
++++ src/SConscript
+@@ -41,16 +41,11 @@ sdl_pkg_config_cmd = 'sdl-config --cflag
build_env.Append (CPPPATH = ['.'])
build_env.Append (CPPPATH = ['#/build/common']) # generated includes
@@ -19,7 +19,7 @@
build_env.Append (CCFLAGS = ['-mms-bitfields'])
build_env.Append (CPPPATH = ['/usr/local/gtkwin/include']) # libpng
build_env.Append (CPPPATH = ['/usr/local/gtkwin/SDL-1.2.8/include'])
-@@ -286,7 +281,7 @@
+@@ -286,7 +281,7 @@ if (not ming) or (cross and not build_ta
csim_env = nonpareil_env.Copy ()
if not ming:
diff --git a/emulators/nonpareil/files/patch-src_printer.c b/emulators/nonpareil/files/patch-src_printer.c
index e0a435bd1d81..8fd36a9f860b 100644
--- a/emulators/nonpareil/files/patch-src_printer.c
+++ b/emulators/nonpareil/files/patch-src_printer.c
@@ -1,6 +1,6 @@
---- src/printer.c.orig 2012-05-09 13:00:47.000000000 +0200
-+++ src/printer.c 2012-05-09 13:01:08.000000000 +0200
-@@ -29,6 +29,7 @@
+--- src/printer.c.orig 2008-08-24 00:37:18 UTC
++++ src/printer.c
+@@ -29,6 +29,7 @@ MA 02111, USA.
#include <gtk/gtk.h>
#include <png.h>
diff --git a/emulators/nonpareil/files/patch-src_proc.c b/emulators/nonpareil/files/patch-src_proc.c
index 406d465a57b2..7e5dcc549165 100644
--- a/emulators/nonpareil/files/patch-src_proc.c
+++ b/emulators/nonpareil/files/patch-src_proc.c
@@ -1,7 +1,6 @@
-diff -urN src.orig/proc.c src/proc.c
---- src.orig/proc.c Tue Jul 25 21:29:20 2006
-+++ src/proc.c Tue Jul 25 21:30:08 2006
-@@ -352,7 +352,13 @@
+--- src/proc.c.orig 2008-08-24 00:37:18 UTC
++++ src/proc.c
+@@ -352,7 +352,13 @@ bool sim_read_object_file (sim_t *sim, c
// Microsoft freopen() isn't compliant with the C standard, which allows
// NULL for the filename if you're reopening an existing file handle.
#else
diff --git a/emulators/nonpareil/files/patch-src_util.c b/emulators/nonpareil/files/patch-src_util.c
index dc4fe477d15a..b2de6dbf3909 100644
--- a/emulators/nonpareil/files/patch-src_util.c
+++ b/emulators/nonpareil/files/patch-src_util.c
@@ -1,6 +1,6 @@
---- src.orig/util.c Mon Jul 24 14:32:21 2006
-+++ src/util.c Mon Jul 24 14:34:48 2006
-@@ -130,6 +130,7 @@
+--- src/util.c.orig 2008-08-24 00:37:18 UTC
++++ src/util.c
+@@ -130,6 +130,7 @@ void realloc_strcpy (char **dest, char *
}
@@ -8,7 +8,7 @@
// strlcpy will copy as much of src into dest as it can, up to one less than
// the maximum length of dest specified by the argument l. Unlike strncpy(),
// strlcpy() will always leave dest NULL-terminated on return.
-@@ -139,6 +140,7 @@
+@@ -139,6 +140,7 @@ char *strlcpy (char *dest, const char *s
dest [l - 1] = '\0';
return dest;
}
diff --git a/emulators/nonpareil/files/patch-src_util.h b/emulators/nonpareil/files/patch-src_util.h
index 3156b3df66bd..547729926f27 100644
--- a/emulators/nonpareil/files/patch-src_util.h
+++ b/emulators/nonpareil/files/patch-src_util.h
@@ -1,6 +1,6 @@
---- src.orig/util.h Mon Jul 24 14:32:21 2006
-+++ src/util.h Mon Jul 24 14:33:52 2006
-@@ -56,7 +56,7 @@
+--- src/util.h.orig 2008-08-24 00:37:18 UTC
++++ src/util.h
+@@ -56,7 +56,7 @@ void realloc_strcpy (char **dest, char *
// strlcpy will copy as much of src into dest as it can, up to one less than
// the maximum length of dest specified by the argument l. Unlike strncpy(),
// strlcpy() will always leave dest NULL-terminated on return.