aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2016-05-11 01:05:33 +0800
committerse <se@FreeBSD.org>2016-05-11 01:05:33 +0800
commit587d65e54c5c2f7e237660db4c948f199af6d4f6 (patch)
treeaf36dee9d97c05df8f510707c58168fa742e8481 /emulators
parent94d8e29d5d1e1c140e0350df978cd543cc2f65e3 (diff)
downloadfreebsd-ports-gnome-587d65e54c5c2f7e237660db4c948f199af6d4f6.tar.gz
freebsd-ports-gnome-587d65e54c5c2f7e237660db4c948f199af6d4f6.tar.zst
freebsd-ports-gnome-587d65e54c5c2f7e237660db4c948f199af6d4f6.zip
Fix problem with desktop shortcuts reported by iluxa (at) ex.ua.
Upgrade to latest stable version 4.2.10 on that occasion. PR: 209418 Reported by: iluxa (at) ex.ua Approved by: antoine (mentor, implicit)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/playonbsd/Makefile2
-rw-r--r--emulators/playonbsd/distinfo4
-rw-r--r--emulators/playonbsd/files/patch-lib_scripts.lib17
-rw-r--r--emulators/playonbsd/files/patch-lib_setupwindow.lib2
-rw-r--r--emulators/playonbsd/files/patch-lib_variables4
-rw-r--r--emulators/playonbsd/files/patch-lib_wine.lib10
-rw-r--r--emulators/playonbsd/files/patch-playonfreebsd11
-rw-r--r--emulators/playonbsd/files/patch-python_mainwindow.py2
8 files changed, 35 insertions, 17 deletions
diff --git a/emulators/playonbsd/Makefile b/emulators/playonbsd/Makefile
index fe257b5e89c2..bb1a7fd8d81f 100644
--- a/emulators/playonbsd/Makefile
+++ b/emulators/playonbsd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= playonbsd
-PORTVERSION= 4.2.8
+PORTVERSION= 4.2.10
CATEGORIES= emulators games
MAINTAINER= se@FreeBSD.org
diff --git a/emulators/playonbsd/distinfo b/emulators/playonbsd/distinfo
index 98dcc024eec5..3cc5463bf5e2 100644
--- a/emulators/playonbsd/distinfo
+++ b/emulators/playonbsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PlayOnLinux-POL-POM-4-4.2.8_GH0.tar.gz) = 746cd72267c42b9c910c2977c5de92ec3e591b72dec382c5a706e353238cd6a3
-SIZE (PlayOnLinux-POL-POM-4-4.2.8_GH0.tar.gz) = 3168626
+SHA256 (PlayOnLinux-POL-POM-4-4.2.10_GH0.tar.gz) = e4fca669624ad1926884bc42910b752979172bce3b89a4196c691791e8bff6f9
+SIZE (PlayOnLinux-POL-POM-4-4.2.10_GH0.tar.gz) = 3203954
diff --git a/emulators/playonbsd/files/patch-lib_scripts.lib b/emulators/playonbsd/files/patch-lib_scripts.lib
index e04969c38347..a4bba860cc2d 100644
--- a/emulators/playonbsd/files/patch-lib_scripts.lib
+++ b/emulators/playonbsd/files/patch-lib_scripts.lib
@@ -1,15 +1,22 @@
---- lib/scripts.lib.orig 2015-05-12 22:33:57 UTC
+--- lib/scripts.lib.orig 2016-01-03 22:16:17 UTC
+++ lib/scripts.lib
-@@ -382,7 +382,7 @@ POL_Shortcut()
+@@ -382,10 +382,14 @@ POL_Shortcut()
# Menus
if [ ! "$(POL_Config_Read NO_MENU_ICON)" = "TRUE" ]; then
# Do nothing on Mac OS
- if [ -n "$Categories" -a "$POL_OS" = "Linux" ] || [ -n "$Categories" -a "$POL_OS" = "BSD" ]; then
-+ if [ -n "$Categories" -a "$POL_OS" = "Linux" ] || [ -n "$Categories" -a "$POL_OS" = "FreeBSD" ]; then
++ if [ -n "$Categories" -a "$POL_OS" = "Linux" ]
LOCALAPPS="$HOME/.local/share/applications"
make_desktop_shortcut "$iconPath" "$ICON_FILENAME" "$LOCALAPPS" "$PLAYONLINUX/playonlinux --run \"$ICON_FILENAME\"" "$binary_name" "$Categories" "playonlinux-"
fi
-@@ -992,9 +992,8 @@ POL_Shortcut_AddProfileLink()
++ if [ -n "$Categories" -a "$POL_OS" = "FreeBSD" ]; then
++ LOCALAPPS="$HOME/.local/share/applications"
++ make_desktop_shortcut "$iconPath" "$ICON_FILENAME" "$LOCALAPPS" "$PLAYONLINUX/playonbsd --run \"$ICON_FILENAME\"" "$binary_name" "$Categories" "playonlinux-"
++ fi
+ fi
+
+ # Desktop
+@@ -1002,9 +1006,8 @@ POL_Shortcut_AddProfileLink()
}
POL_LoadVar_Distro ()
{
@@ -21,7 +28,7 @@
main_kernel="$(uname -r | cut -d '.' -f 1)"
second_kernel="$(uname -r | cut -d '.' -f 2)"
-@@ -1005,7 +1004,14 @@ POL_LoadVar_Distro ()
+@@ -1015,7 +1018,14 @@ POL_LoadVar_Distro ()
[ "$main_kernel" = "12" ] && MacOS="Mountain Lion"
export DISTRO="$MacOS 10.$(( main_kernel - 4)).$second_kernel ($(uname -r))"
diff --git a/emulators/playonbsd/files/patch-lib_setupwindow.lib b/emulators/playonbsd/files/patch-lib_setupwindow.lib
index da42117bbd10..5f0c2201de77 100644
--- a/emulators/playonbsd/files/patch-lib_setupwindow.lib
+++ b/emulators/playonbsd/files/patch-lib_setupwindow.lib
@@ -1,4 +1,4 @@
---- lib/setupwindow.lib.orig 2015-05-12 22:33:57 UTC
+--- lib/setupwindow.lib.orig 2016-01-03 22:16:17 UTC
+++ lib/setupwindow.lib
@@ -36,7 +36,7 @@ ncs()
}
diff --git a/emulators/playonbsd/files/patch-lib_variables b/emulators/playonbsd/files/patch-lib_variables
index bd63ff658b2b..ed7b5d114ca4 100644
--- a/emulators/playonbsd/files/patch-lib_variables
+++ b/emulators/playonbsd/files/patch-lib_variables
@@ -1,6 +1,6 @@
---- lib/variables.orig 2015-05-12 22:33:57 UTC
+--- lib/variables.orig 2016-01-03 22:16:17 UTC
+++ lib/variables
-@@ -65,8 +65,11 @@ else
+@@ -69,8 +69,11 @@ else
eval_gettext() { printf "$@"; }
fi
diff --git a/emulators/playonbsd/files/patch-lib_wine.lib b/emulators/playonbsd/files/patch-lib_wine.lib
index 455fa07bd00f..4e93cce1d5ab 100644
--- a/emulators/playonbsd/files/patch-lib_wine.lib
+++ b/emulators/playonbsd/files/patch-lib_wine.lib
@@ -1,11 +1,11 @@
---- lib/wine.lib.orig 2015-05-12 22:33:57 UTC
+--- lib/wine.lib.orig 2016-01-03 22:16:17 UTC
+++ lib/wine.lib
-@@ -31,7 +31,7 @@ POL_Wine_GetRegValue()
-
+@@ -32,7 +32,7 @@ POL_Wine_GetRegValue()
[ -z "$WINEPREFIX" ] && POL_Debug_Fatal "WINEPREFIX not set"
local value
-- [ -e "$WINEPREFIX/user.reg" ] && value="$(grep "$1" "$WINEPREFIX/user.reg" | head -n 1 | tr -d '"' | cut -d= -f2)"
-+ [ -e "$WINEPREFIX/user.reg" ] && value="$(grep "$1" "$WINEPREFIX/user.reg" | head -n 1 | tr -d \" | cut -d= -f2)"
+ # tr -d '\0' is a workaround for Wine bug #37575
+- [ -e "$WINEPREFIX/user.reg" ] && value="$(grep "^\"$1\"=" "$WINEPREFIX/user.reg" | head -n 1 | tr -d '"' | cut -d= -f2- | tr -d '\0')"
++ [ -e "$WINEPREFIX/user.reg" ] && value="$(grep "^\"$1\"=" "$WINEPREFIX/user.reg" | head -n 1 | tr -d \" | cut -d= -f2- | tr -d '\0')"
POL_Debug_Message "Getting registry value $1. Return: $value"
echo -n "${value:-default}"
}
diff --git a/emulators/playonbsd/files/patch-playonfreebsd b/emulators/playonbsd/files/patch-playonfreebsd
new file mode 100644
index 000000000000..2c5d8059a221
--- /dev/null
+++ b/emulators/playonbsd/files/patch-playonfreebsd
@@ -0,0 +1,11 @@
+--- playonfreebsd.orig 2016-01-03 22:16:17 UTC
++++ playonfreebsd
+@@ -111,7 +111,7 @@ if [ "$1" = "--run" ]; then
+ # cp "$HOME/.PlayOnLinux/shortcuts/$NAME" "$POL_USER_ROOT/tmp/debug_$NAME" && \
+ # sed -e 's/^export WINEDEBUG="\(.*\)"/export WINEDEBUG="-all"/' "$POL_USER_ROOT/tmp/debug_$NAME" > "$HOME/.PlayOnLinux/shortcuts/$NAME"
+ #fi
+- exec bash playonlinux-bash "$HOME/.PlayOnLinux/shortcuts/$NAME" "$@"
++ exec bash playonlinux-bash "$HOME/.PlayOnBSD/shortcuts/$NAME" "$@"
+ fi
+ else
+ cd "$POLDIR/python"
diff --git a/emulators/playonbsd/files/patch-python_mainwindow.py b/emulators/playonbsd/files/patch-python_mainwindow.py
index 26b5c75f84e6..086c162e37ec 100644
--- a/emulators/playonbsd/files/patch-python_mainwindow.py
+++ b/emulators/playonbsd/files/patch-python_mainwindow.py
@@ -1,4 +1,4 @@
---- python/mainwindow.py.orig 2015-05-12 22:33:57 UTC
+--- python/mainwindow.py.orig 2016-01-03 22:16:17 UTC
+++ python/mainwindow.py
@@ -63,8 +63,8 @@ class POLWeb(threading.Thread):
def LastVersion(self):