aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-07-10 22:40:02 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2019-07-10 22:40:02 +0800
commit7003875294fc8b811ffe452c376f66a855494f60 (patch)
tree9754e52797ffd2ab1caf7b83b3fa360ba5db8a85 /emulators
parentb3ec6fb0fe1868f49bc3ae82909a818a4d043678 (diff)
downloadfreebsd-ports-gnome-7003875294fc8b811ffe452c376f66a855494f60.tar.gz
freebsd-ports-gnome-7003875294fc8b811ffe452c376f66a855494f60.tar.zst
freebsd-ports-gnome-7003875294fc8b811ffe452c376f66a855494f60.zip
On amd64 adding DEFAULT_VERSIONS+=linux=c6 to /etc/make.conf made Linux
infrastructure ports (linux_base-c6 and linux-c6*) install i386 CentOS 6 packages. Using c6_64 instead of c6 made them install mixed amd64/i386 CentOS 6 packages and allowed Linux application ports to install amd64 binaries when available. The i386-only configuration was only useful for users of x11/nvidia-driver* which didn't provide Linux amd64 emulation until recently. With x11/nvidia-driver* now supporting Linux amd64 there's no longer a need for i386-only Linux on amd64. Let DEFAULT_VERSIONS+=linux=c6 make Linux infrastructure ports install mixed amd64/i386 CentOS 6 packages, like c6_64 before, and remove support for c6_64 as a value. Replace LINUX_ARCH with ARCH everywhere because they are always the same now.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux-c7/Makefile6
-rw-r--r--emulators/linux_base-c6/Makefile10
-rw-r--r--emulators/linux_base-c7/Makefile14
3 files changed, 15 insertions, 15 deletions
diff --git a/emulators/linux-c7/Makefile b/emulators/linux-c7/Makefile
index fbcac1c6059f..d785691af64c 100644
--- a/emulators/linux-c7/Makefile
+++ b/emulators/linux-c7/Makefile
@@ -69,9 +69,9 @@ RUN_DEPENDS= linux-c7-libasyncns>0:dns/linux-c7-libasyncns \
USES= linux:c7 metaport
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
RUN_DEPENDS+= linux-c7-sdl_image>0:graphics/linux-c7-sdl_image \
linux-c7-openal-soft>0:audio/linux-c7-openal-soft \
linux-c7-sdl20>0:devel/linux-c7-sdl20 \
@@ -80,4 +80,4 @@ RUN_DEPENDS+= linux-c7-sdl_image>0:graphics/linux-c7-sdl_image \
linux-c7-qtwebkit>0:www/linux-c7-qtwebkit
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index 1c3db80ff1d4..9da76b6ee37a 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -121,9 +121,9 @@ REMOVE_DIRS= boot home media mnt proc root sys tmp var/log var/run var/tmp
REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/gshadow etc/motd \
etc/passwd etc/printcap etc/protocols etc/services etc/shadow
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
SYSCTLMIB= kern.features.linux64
.else
SYSCTLMIB= compat.linux.osrelease
@@ -135,7 +135,7 @@ post-patch:
@${FIND} ${WRKSRC}/lib -type d -empty -delete
@${FIND} ${WRKSRC}/usr -type d -empty -delete
@${BRANDELF} -t Linux ${WRKSRC}/lib/ld-2.12.so
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
@${FIND} ${WRKSRC}/lib64 -type d -empty -delete
@${BRANDELF} -t Linux ${WRKSRC}/lib64/ld-2.12.so
.endif
@@ -155,8 +155,8 @@ post-install:
${LN} -sf usr/bin ${STAGEDIR}${PREFIX}
${LN} -sf usr/lib ${STAGEDIR}${PREFIX}
${LN} -sf usr/sbin ${STAGEDIR}${PREFIX}
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
${LN} -sf usr/lib64 ${STAGEDIR}${PREFIX}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/linux_base-c7/Makefile b/emulators/linux_base-c7/Makefile
index 2dd4f3f4f626..e1deeae7145f 100644
--- a/emulators/linux_base-c7/Makefile
+++ b/emulators/linux_base-c7/Makefile
@@ -131,9 +131,9 @@ REMOVE_DIRS= boot home media mnt proc root run sys tmp var/log var/tmp
REMOVE_FILES= bin/su etc/exports etc/group etc/gshadow etc/motd \
etc/passwd etc/printcap etc/protocols etc/services etc/shadow
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
SYSCTLMIB= kern.features.linux64
.else
SYSCTLMIB= compat.linux.osrelease
@@ -148,11 +148,11 @@ post-extract:
${FIND} ${d} | ${CPIO} -dumpl --quiet usr && ${RM} -r ${d}; fi)
.endfor
@(cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
- ${DISTDIR}/${DIST_SUBDIR}/filesystem-3.2-25.el7${EXTRACT_SUFX_${LINUX_ARCH:S/x86_64/amd64/}} \
+ ${DISTDIR}/${DIST_SUBDIR}/filesystem-3.2-25.el7${EXTRACT_SUFX_${ARCH}} \
${EXTRACT_AFTER_ARGS})
-.if ${LINUX_ARCH} == i386
+.if ${ARCH} == i386
@${CHMOD} u+w ${WRKSRC}/usr/lib/pm-utils
-.elif ${LINUX_ARCH} == x86_64
+.elif ${ARCH} == amd64
@${CHMOD} u+w ${WRKSRC}/usr/lib64/pm-utils
.endif
@@ -161,7 +161,7 @@ post-patch:
@${RM} ${REMOVE_FILES:S|^|${WRKSRC}/|}
@${FIND} ${WRKSRC}/usr -type d -empty -not -path '*/lib*/gio/*' -delete
@${BRANDELF} -t Linux ${WRKSRC}/usr/lib/ld-2.17.so
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
@${BRANDELF} -t Linux ${WRKSRC}/usr/lib64/ld-2.17.so
.endif
@@ -177,4 +177,4 @@ post-install:
${LN} -sf /var/run ${STAGEDIR}${PREFIX}/run
${LN} -sf /var/tmp ${STAGEDIR}${PREFIX}/usr/tmp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>