aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-20 20:02:07 +0800
committerMark Linimon <linimon@FreeBSD.org>2017-05-20 20:02:07 +0800
commit73a2d70934144e0597ca6a667908f5304f959009 (patch)
treef214fd97b3e397fb90830db2b455ad9033c3e640 /emulators
parentbf55d31cb050e24a148fe16f79ccba943b19fd34 (diff)
downloadfreebsd-ports-gnome-73a2d70934144e0597ca6a667908f5304f959009.tar.gz
freebsd-ports-gnome-73a2d70934144e0597ca6a667908f5304f959009.tar.zst
freebsd-ports-gnome-73a2d70934144e0597ca6a667908f5304f959009.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 76201440119b..359b079d5729 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -22,6 +22,8 @@ USE_GNOME+= cairo glib20
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
.endif
+BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
+
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
STATIC_LINK DOCS NCURSES
@@ -107,11 +109,11 @@ MAKE_ARGS+= ARCH=ppc64
CONFIGURE_ARGS+= --sparc_cpu=v9
.endif
-# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
-.if (${OSVERSION} < 1100000)
-PLIST_SUB+= LINUXBOOT_DMA="@comment "
-.else
-PLIST_SUB+= LINUXBOOT_DMA=""
+# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
+.if (${OSVERSION} < 1100000)
+PLIST_SUB+= LINUXBOOT_DMA="@comment "
+.else
+PLIST_SUB+= LINUXBOOT_DMA=""
.endif
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)