aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2015-06-15 11:27:50 +0800
committeracm <acm@FreeBSD.org>2015-06-15 11:27:50 +0800
commit775a73d30fb112896fd6381da166c4297092e740 (patch)
tree25f9a540fe48200a7600516791c27a73122a1033 /emulators
parent0850c76d8ab2cbed04b96b377f2dc137cc6f0605 (diff)
downloadfreebsd-ports-gnome-775a73d30fb112896fd6381da166c4297092e740.tar.gz
freebsd-ports-gnome-775a73d30fb112896fd6381da166c4297092e740.tar.zst
freebsd-ports-gnome-775a73d30fb112896fd6381da166c4297092e740.zip
- Update to 2.5
- Take maintainership
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-audio-sdl/Makefile4
-rw-r--r--emulators/mupen64plus-core/Makefile13
-rw-r--r--emulators/mupen64plus-core/Makefile.common3
-rw-r--r--emulators/mupen64plus-core/distinfo12
-rw-r--r--emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile19
-rw-r--r--emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h15
-rw-r--r--emulators/mupen64plus-core/pkg-plist1
-rw-r--r--emulators/mupen64plus-input-sdl/Makefile2
-rw-r--r--emulators/mupen64plus-plugins/Makefile15
-rw-r--r--emulators/mupen64plus-rsp-z64/Makefile2
-rw-r--r--emulators/mupen64plus-ui-console/Makefile2
-rw-r--r--emulators/mupen64plus-video-arachnoid/Makefile2
-rw-r--r--emulators/mupen64plus-video-glide64/Makefile6
-rw-r--r--emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Main.cpp16
-rw-r--r--emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Util.h30
-rw-r--r--emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_rdp.cpp24
-rw-r--r--emulators/mupen64plus-video-rice/Makefile2
-rw-r--r--emulators/mupen64plus-video-z64/Makefile6
-rw-r--r--emulators/mupen64plus/Makefile6
20 files changed, 53 insertions, 128 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 5f2ed68de7d7..48917f75dda0 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -89,6 +89,7 @@
SUBDIR += mupen64plus-core
SUBDIR += mupen64plus-input-sdl
SUBDIR += mupen64plus-plugins
+ SUBDIR += mupen64plus-rsp-cxd4
SUBDIR += mupen64plus-rsp-hle
SUBDIR += mupen64plus-rsp-z64
SUBDIR += mupen64plus-ui-console
diff --git a/emulators/mupen64plus-audio-sdl/Makefile b/emulators/mupen64plus-audio-sdl/Makefile
index 5d3b07306ff9..1f8268e085fe 100644
--- a/emulators/mupen64plus-audio-sdl/Makefile
+++ b/emulators/mupen64plus-audio-sdl/Makefile
@@ -1,12 +1,12 @@
# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 0
PKGNAMESUFFIX= -audio-sdl
COMMENT= Mupen64plus audio sdl plugin
-USE_SDL= sdl
+USE_SDL= sdl2
MASTERDIR= ${.CURDIR}/../mupen64plus-core
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 7a3c3d6ee5f0..c80d606cb20a 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -2,23 +2,22 @@
# $FreeBSD$
PORTNAME= mupen64plus
-PORTVERSION?= 2.0
-PORTREVISION?= 4
+PORTVERSION?= 2.5
+PORTREVISION?= 0
CATEGORIES= emulators
-MASTER_SITES= GOOGLE_CODE \
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/releases/download/${PORTVERSION}/ \
LOCAL/acm/${PORTNAME} \
- GOOGLE_CODE:plugin \
- http://cdn.bitbucket.org/wahrhaft/${PORTNAME}${PKGNAMESUFFIX}/downloads/:plugin
+ LOCAL/acm/${PORTNAME}/:plugin
PKGNAMESUFFIX?= -core
DIST_SUBDIR= ${PORTNAME}
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER?= acm@FreeBSD.org
COMMENT?= Fork of Mupen64 Nintendo 64 emulator
#PROJECTHOST= bsdistfiles
USES= gmake pkgconfig
USE_GL?= yes
-USE_SDL?= yes
+USE_SDL?= sdl2
USE_LDCONFIG?= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index 7505cfe3b129..ed965629d338 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -1,6 +1,7 @@
USES+= dos2unix
DOS2UNIX_GLOB= *.c *.cpp *.h *.H *.ini *.conf
+DISTINFO_FILE= ${.CURDIR}/distinfo
DISTNAME= ${PORTNAME}-bundle-src-${PORTVERSION}
PATCHDIR= ${.CURDIR}/files
BUILD_WRKSRC?= ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
@@ -27,7 +28,7 @@ LIB_DEPENDS+= libboost_thread.so:${PORTSDIR}/devel/boost-libs
.if ${PKGNAMESUFFIX} != "-core"
post-patch:
@cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} -e 's|gcc|${CC}|g' -e \
- 's|g++|${CXX}|g' Makefile
+ 's|g++|${CXX}|g' -e 's|sdl-config|${SDL2_CONFIG}|g' Makefile
. if ${PKGNAMESUFFIX} == "-video-glide64mk2"
@cd ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/src && \
${REINPLACE_CMD} -e 's|#include <thread>||g' \
diff --git a/emulators/mupen64plus-core/distinfo b/emulators/mupen64plus-core/distinfo
index 561a6295b563..2b6363b93c3a 100644
--- a/emulators/mupen64plus-core/distinfo
+++ b/emulators/mupen64plus-core/distinfo
@@ -1,10 +1,2 @@
-SHA256 (mupen64plus/mupen64plus-bundle-src-2.0.tar.gz) = 2a269ca77797d7eb3759cbbfecbdc1d985e773e5be155d469c13f034e37e7e4d
-SIZE (mupen64plus/mupen64plus-bundle-src-2.0.tar.gz) = 2352981
-SHA256 (mupen64plus/mupen64plus-video-arachnoid-src-2.0.0.tar.gz) = 562cc896bc60e98c4e45a0716d3224830f42541ef526c8437699df103a88d75a
-SIZE (mupen64plus/mupen64plus-video-arachnoid-src-2.0.0.tar.gz) = 126329
-SHA256 (mupen64plus/mupen64plus-video-glide64-src-2.0.0.tar.gz) = 5359dd1d69c24183bde519285625ac8cb7f4ac5d2069ccacc7bbb95a855c25f3
-SIZE (mupen64plus/mupen64plus-video-glide64-src-2.0.0.tar.gz) = 334935
-SHA256 (mupen64plus/mupen64plus-video-z64-src-2.0.0.tar.gz) = dec06a0afb8b403754faa26da36c6ada77f7918124516c6f449a9d90d3c4861f
-SIZE (mupen64plus/mupen64plus-video-z64-src-2.0.0.tar.gz) = 65723
-SHA256 (mupen64plus/mupen64plus-rsp-z64-src-2.0.0.tar.gz) = df69eb722fae9a4edd7b764e9c9a459f6a6d3482225d469871c393c695f86e9b
-SIZE (mupen64plus/mupen64plus-rsp-z64-src-2.0.0.tar.gz) = 44341
+SHA256 (mupen64plus/mupen64plus-bundle-src-2.5.tar.gz) = 9c75b9d826f2d24666175f723a97369b3a6ee159b307f7cc876bbb4facdbba66
+SIZE (mupen64plus/mupen64plus-bundle-src-2.5.tar.gz) = 2178979
diff --git a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
index 946ffe2d5b98..04a8ee08832f 100644
--- a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
+++ b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
@@ -1,6 +1,6 @@
---- source/mupen64plus-core/projects/unix/Makefile 2013-09-30 20:56:00.000000000 -0500
-+++ source/mupen64plus-core/projects/unix/Makefile 2013-09-30 20:59:47.000000000 -0500
-@@ -206,6 +206,10 @@
+--- source/mupen64plus-core/projects/unix/Makefile 2015-04-26 17:42:49.000000000 -0500
++++ source/mupen64plus-core/projects/unix/Makefile 2015-06-12 17:54:03.000000000 -0500
+@@ -227,6 +227,10 @@
ZLIB_LDLIBS += -lz
endif
@@ -11,3 +11,16 @@
ifeq ($(origin ZLIB_CFLAGS) $(origin ZLIB_LDLIBS), undefined undefined)
ifeq ($(shell $(PKG_CONFIG) --modversion zlib 2>/dev/null),)
$(error No zlib development libraries found!)
+@@ -247,6 +251,12 @@
+ CFLAGS += $(LIBPNG_CFLAGS)
+ LDLIBS += $(LIBPNG_LDLIBS)
+
++ifeq ($(OS), FREEBSD)
++ SDL_CFLAGS += $(shell $(SDL2_CONFIG) --cflags)
++ SDL_LDLIBS += $(shell $(SDL2_CONFIG) --libs)
++endif
++
++
+ # test for presence of SDL
+ ifeq ($(origin SDL_CFLAGS) $(origin SDL_LDLIBS), undefined undefined)
+ SDL_CONFIG = $(CROSS_COMPILE)sdl2-config
diff --git a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h
deleted file mode 100644
index 801d20e1a864..000000000000
--- a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_src_main_zip_ioapi.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- source/mupen64plus-core/src/main/zip/ioapi.h 2011-12-17 21:07:15.000000000 -0500
-+++ source/mupen64plus-core/src/main/zip/ioapi.h 2011-12-17 21:08:43.000000000 -0500
-@@ -61,6 +61,12 @@
- #endif
- #endif
-
-+#if defined(__FreeBSD__)
-+#define fopen64 fopen
-+#define ftello64 ftello
-+#define fseeko64 fseeko
-+#endif
-+
- /*
- #ifndef ZPOS64_T
- #ifdef _WIN32
diff --git a/emulators/mupen64plus-core/pkg-plist b/emulators/mupen64plus-core/pkg-plist
index 125e587a4905..cb40d8835b38 100644
--- a/emulators/mupen64plus-core/pkg-plist
+++ b/emulators/mupen64plus-core/pkg-plist
@@ -8,7 +8,6 @@ include/mupen64plus/m64p_vidext.h
lib/libmupen64plus.so.2
lib/libmupen64plus.so.2.0.0
%%DATADIR%%/font.ttf
-%%DATADIR%%/mupen64plus.cht
%%DATADIR%%/mupen64plus.ini
%%DATADIR%%/mupencheat.txt
%%PORTDOCS%%%%DOCSDIR%%/RELEASE
diff --git a/emulators/mupen64plus-input-sdl/Makefile b/emulators/mupen64plus-input-sdl/Makefile
index f3ef064d5636..85151265dd93 100644
--- a/emulators/mupen64plus-input-sdl/Makefile
+++ b/emulators/mupen64plus-input-sdl/Makefile
@@ -1,7 +1,7 @@
# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 0
PKGNAMESUFFIX= -input-sdl
COMMENT= Input plugin for Mupen64plus
diff --git a/emulators/mupen64plus-plugins/Makefile b/emulators/mupen64plus-plugins/Makefile
index 529eb19771ee..03eb9bab48eb 100644
--- a/emulators/mupen64plus-plugins/Makefile
+++ b/emulators/mupen64plus-plugins/Makefile
@@ -2,24 +2,25 @@
# $FreeBSD$
PORTNAME= mupen64plus
-PORTVERSION= 2.0
-PORTREVISION= 1
+PORTVERSION= 2.5
+PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= # empty
PKGNAMESUFFIX= -plugins
DISTFILES= # empty
EXTRACT_ONLY= # empty
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER?= acm@FreeBSD.org
COMMENT= Third party plugins for Mupen64plus
-OPTIONS_DEFINE= VIDEO_ARACHNOID VIDEO_GLIDE64 VIDEO_Z64 RSP_Z64
+OPTIONS_DEFINE= VIDEO_ARACHNOID VIDEO_GLIDE64 VIDEO_Z64 RSP_Z64 RSP_CXD4
VIDEO_ARACHNOID_DESC= Arachnoid video plugin
VIDEO_GLIDE64_DESC= Glide64 video plugin
VIDEO_Z64_DESC= z64 video plugin
RSP_Z64_DESC= z64 RSP plugin
+RSP_CXD4_DESC= cxd4 RSP plugin
-OPTIONS_DEFAULT= VIDEO_ARACHNOID VIDEO_GLIDE64 VIDEO_Z64 RSP_Z64
+OPTIONS_DEFAULT= VIDEO_ARACHNOID VIDEO_GLIDE64 VIDEO_Z64 RSP_Z64 RSP_CXD4
.include <bsd.port.pre.mk>
@@ -41,6 +42,10 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-z64.so:${PORTSDIR}/
RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-rsp-z64.so:${PORTSDIR}/emulators/mupen64plus-rsp-z64
.endif
+.if ${PORT_OPTIONS:MRSP_CXD4}
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-rsp-cxd4.so:${PORTSDIR}/emulators/mupen64plus-rsp-cxd4
+.endif
+
NO_MTREE= yes
NO_BUILD= yes
diff --git a/emulators/mupen64plus-rsp-z64/Makefile b/emulators/mupen64plus-rsp-z64/Makefile
index 9fd57a344d9a..a792399c323c 100644
--- a/emulators/mupen64plus-rsp-z64/Makefile
+++ b/emulators/mupen64plus-rsp-z64/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -rsp-z64
-DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}.0${EXTRACT_SUFX}:plugin
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
COMMENT= Low-level RSP processor plugin for the Mupen64Plus
diff --git a/emulators/mupen64plus-ui-console/Makefile b/emulators/mupen64plus-ui-console/Makefile
index a0d308542a85..7f75c42d391f 100644
--- a/emulators/mupen64plus-ui-console/Makefile
+++ b/emulators/mupen64plus-ui-console/Makefile
@@ -1,7 +1,7 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 0
PKGNAMESUFFIX= -ui-console
COMMENT= UI for Mupen64plus
diff --git a/emulators/mupen64plus-video-arachnoid/Makefile b/emulators/mupen64plus-video-arachnoid/Makefile
index 77bd9b9acce5..af4fc8a943b2 100644
--- a/emulators/mupen64plus-video-arachnoid/Makefile
+++ b/emulators/mupen64plus-video-arachnoid/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -video-arachnoid
-DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}.0${EXTRACT_SUFX}:plugin
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
COMMENT= The arachnoid video plugin for Mupen64plus
diff --git a/emulators/mupen64plus-video-glide64/Makefile b/emulators/mupen64plus-video-glide64/Makefile
index 44cb42257d1d..1902f86a098a 100644
--- a/emulators/mupen64plus-video-glide64/Makefile
+++ b/emulators/mupen64plus-video-glide64/Makefile
@@ -1,16 +1,16 @@
# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 0
PKGNAMESUFFIX= -video-glide64
-DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}.0${EXTRACT_SUFX}:plugin
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
COMMENT= Glide64 video plugin for Mupen64Plus
LIB_DEPENDS= libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core
USE_GL= gl
-USE_SDL= yes
+USE_SDL= sdl2
MASTERDIR= ${.CURDIR}/../mupen64plus-core
diff --git a/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Main.cpp b/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Main.cpp
deleted file mode 100644
index 858f6bcaa23d..000000000000
--- a/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Main.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- mupen64plus-video-glide64/src/Main.cpp 2013-10-04 03:40:24.000000000 -0500
-+++ mupen64plus-video-glide64/src/Main.cpp 2013-10-04 03:41:24.000000000 -0500
-@@ -634,11 +634,8 @@
- for (i=0; i<0x200; i++)
- {
- // cur = ~*(data++), byteswapped
--#if !defined(__GNUC__)
-- cur = _byteswap_ulong(~*(data++));
--#else
-- cur = __builtin_bswap32(~*(data++));
--#endif
-+
-+ cur = bswap32(~*(data++));
-
- for (b=0x80000000; b!=0; b>>=1)
- {
diff --git a/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Util.h b/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Util.h
deleted file mode 100644
index b906e205286b..000000000000
--- a/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_Util.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- mupen64plus-video-glide64/src/Util.h 2013-10-04 03:39:06.000000000 -0500
-+++ mupen64plus-video-glide64/src/Util.h 2013-10-04 03:43:01.000000000 -0500
-@@ -37,6 +37,8 @@
- #ifndef Util_H
- #define Util_H
-
-+#include <stdint.h>
-+
- #include "winlnxdefs.h"
- #include "rdp.h"
-
-@@ -91,5 +93,17 @@
- lx = lc; \
- }
-
--#endif // ifndef Util_H
-+#if defined(_MSC_VER) && (defined(_M_IX86) || defined(_M_X64))
-+ #include <stdlib.h>
-+ #define bswap32(x) _byteswap_ulong(x)
-+#else
-+static inline uint32_t bswap32(uint32_t val)
-+{
-+ return (((val & 0xff000000) >> 24) |
-+ ((val & 0x00ff0000) >> 8) |
-+ ((val & 0x0000ff00) << 8) |
-+ ((val & 0x000000ff) << 24));
-+}
-+#endif
-
-+#endif // ifndef Util_H
diff --git a/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_rdp.cpp b/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_rdp.cpp
deleted file mode 100644
index 542674074d4e..000000000000
--- a/emulators/mupen64plus-video-glide64/files/patch-mupen64plus-video-glide64-src_rdp.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- mupen64plus-video-glide64/src/rdp.cpp 2013-10-04 03:41:54.000000000 -0500
-+++ mupen64plus-video-glide64/src/rdp.cpp 2013-10-04 03:43:26.000000000 -0500
-@@ -67,21 +67,6 @@
-
- int drawFlag = 1; // draw flag for rendering callback
-
--#if defined(__GNUC__)
-- #define bswap32(x) __builtin_bswap32(x)
--#elif defined(_MSC_VER) && (defined(_M_IX86) || defined(_M_X64))
-- #include <stdlib.h>
-- #define bswap32(x) _byteswap_ulong(x)
--#else
--static inline uint32_t bswap32(uint32_t val)
--{
-- return (((val & 0xff000000) >> 24) |
-- ((val & 0x00ff0000) >> 8) |
-- ((val & 0x0000ff00) << 8) |
-- ((val & 0x000000ff) << 24));
--}
--#endif
--
- // global strings
- const char *ACmp[4] = { "NONE", "THRESHOLD", "UNKNOWN", "DITHER" };
-
diff --git a/emulators/mupen64plus-video-rice/Makefile b/emulators/mupen64plus-video-rice/Makefile
index 74521239ea9b..b433e8e080cb 100644
--- a/emulators/mupen64plus-video-rice/Makefile
+++ b/emulators/mupen64plus-video-rice/Makefile
@@ -1,7 +1,7 @@
# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 4
+PORTREVISION= 0
PKGNAMESUFFIX= -video-rice
COMMENT= The rice graphics plugin for Mupen64plus
diff --git a/emulators/mupen64plus-video-z64/Makefile b/emulators/mupen64plus-video-z64/Makefile
index e02396a5b165..45e2274abb16 100644
--- a/emulators/mupen64plus-video-z64/Makefile
+++ b/emulators/mupen64plus-video-z64/Makefile
@@ -1,16 +1,16 @@
# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 0
PKGNAMESUFFIX= -video-z64
-DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}.0${EXTRACT_SUFX}:plugin
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
COMMENT= Low-level RDP plugin for the Mupen64Plus
LIB_DEPENDS= libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core
USE_GL= gl glu glew
-USE_SDL= yes
+USE_SDL= sdl2
MASTERDIR= ${.CURDIR}/../mupen64plus-core
diff --git a/emulators/mupen64plus/Makefile b/emulators/mupen64plus/Makefile
index 03c501716824..ddb7789af138 100644
--- a/emulators/mupen64plus/Makefile
+++ b/emulators/mupen64plus/Makefile
@@ -2,14 +2,14 @@
# $FreeBSD$
PORTNAME= mupen64plus
-PORTVERSION= 2.0
-PORTREVISION= 1
+PORTVERSION= 2.5
+PORTREVISION?= 0
CATEGORIES= emulators
MASTER_SITES= # empty
DISTFILES= # empty
EXTRACT_ONLY= # empty
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER?= acm@FreeBSD.org
COMMENT= Fork of Mupen64 Nintendo 64 emulator with plugins (meta port)
# Mupen64 Emulator core and ui-console