aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
committermat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
commit79c3ac81e82fba101ce34956c5de634b8ed032d0 (patch)
treeaa20f69168c1d6c9e0dbf200cc417eb6ea9147ca /emulators
parent89ac30bfd79e5d0fe14f37fae8ce263170a2af2d (diff)
downloadfreebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.gz
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.zst
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.zip
Remove all := from BUILD_DEPENDS, here are never needed.
While there, cleanup, and sort depends. When build and run dependencies are the same, there are three ways to avoid duplicating the list while not adding the framework added BUILD_DEPENDS to the RUN_DEPENDS. In order of preference, they are: 1) use RUN_DEPENDS to set BUILD_DEPENDS: BUILD_DEPENDS= ${RUN_DEPENDS} RUN_DEPENDS= foo:bar/baz 2) create another variable and use it: MY_DEPENDS= foo:bar/baz BUILD_DEPENDS= ${MY_DEPENDS} RUN_DEPENDS= ${MY_DEPENDS} 3) use BUILD_DEPENDS to set RUN_DEPENDS and force evaluation: BUILD_DEPENDS= foo:bar/baz RUN_DEPENDS:= ${BUILD_DEPENDS} Sponsored by: Absolight
Diffstat (limited to 'emulators')
-rw-r--r--emulators/p5-Acme-6502/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/emulators/p5-Acme-6502/Makefile b/emulators/p5-Acme-6502/Makefile
index d2a9bc8cf0ce..84302411bc61 100644
--- a/emulators/p5-Acme-6502/Makefile
+++ b/emulators/p5-Acme-6502/Makefile
@@ -14,8 +14,8 @@ COMMENT= Pure Perl 65C02 simulator
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Term-ReadKey>=2.30:devel/p5-Term-ReadKey
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= modbuild