aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2011-08-07 20:58:59 +0800
committerarved <arved@FreeBSD.org>2011-08-07 20:58:59 +0800
commit8600fffeb39ed7d8ab8e08f0e57ce1a8bc4d76ff (patch)
tree23b9300ee45ab0fde71e7310424d5b38cd98b870 /emulators
parentf15638e87d0b2588f9e92494ee1e0f4fc1e6bbe0 (diff)
downloadfreebsd-ports-gnome-8600fffeb39ed7d8ab8e08f0e57ce1a8bc4d76ff.tar.gz
freebsd-ports-gnome-8600fffeb39ed7d8ab8e08f0e57ce1a8bc4d76ff.tar.zst
freebsd-ports-gnome-8600fffeb39ed7d8ab8e08f0e57ce1a8bc4d76ff.zip
Add dependency on alsa-lib. Port picks it up with configure if installed
Fix mispelled option MISALIGNED PR: 159340 Submitted by: Joel Ray Holveck <joelh@piquan.org>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 3d937f904641..262789e02fdb 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bochs
PORTVERSION= 2.4.6
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -14,6 +15,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
+LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib
+
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
@@ -68,7 +71,7 @@ OPTIONS= A20_PIN "Enable support for A20 pin" on \
X86_64 "Enable AMD x86-64 support" off \
XPM "Enable XPM library support" off
-CFLAGS+= -fno-exceptions -fomit-frame-pointer
+CFLAGS+= -fno-exceptions -fomit-frame-pointer ${CPPFLAGS}
CXXFLAGS+= -fno-rtti
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -211,7 +214,7 @@ CONFIGURE_ARGS+=--enable-long-phy-address
CONFIGURE_ARGS+=--disable-long-phy-address
.endif
-.if defined(WITH_MISALIGNDSSE)
+.if defined(WITH_MISALIGNEDSSE)
CONFIGURE_ARGS+=--enable-misaligned-sse
.else
CONFIGURE_ARGS+=--disable-misaligned-sse