aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2018-09-26 03:33:09 +0800
committermartymac <martymac@FreeBSD.org>2018-09-26 03:33:09 +0800
commit880f1266487d30cab275d92f38940b1273ba7b53 (patch)
tree165cf8790b0a8ef8a6803b035e4d0736766276a3 /emulators
parent93a84aa756e191c4b3299da77665a906bd7af51b (diff)
downloadfreebsd-ports-gnome-880f1266487d30cab275d92f38940b1273ba7b53.tar.gz
freebsd-ports-gnome-880f1266487d30cab275d92f38940b1273ba7b53.tar.zst
freebsd-ports-gnome-880f1266487d30cab275d92f38940b1273ba7b53.zip
Fix build error on archs where 'unsigned long' is 32bit (tested on i386):
Source/Core/Core/NetPlayClient.cpp:1218:12: error: invalid operands to binary expression ('sf::Packet' and 'unsigned long') Ask lzo/lzodefs.h to prefer 'unsigned int' for type lzo_uint32_t (lzo_uint32e_t) over 'unsigned long int' because SFML's Packet& operator >>() cannot handle 'unsigned long int' as argument (see SFML/Network/Packet.hpp). It can accept a Uint32 reference, which is defined as an 'unsigned int' reference via SFML/Config.hpp. Also, set forgotten requirement for c++17-lang.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 18a40fe5b973..a6021eab16df 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -42,7 +42,7 @@ LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libcurl.so:ftp/curl \
libhidapi.so:comms/hidapi
-USES= cmake compiler:c++11-lib desktop-file-utils iconv pkgconfig \
+USES= cmake compiler:c++17-lang desktop-file-utils iconv pkgconfig \
qmake qt:5
USE_GITHUB= yes
@@ -64,6 +64,9 @@ CMAKE_ARGS+= -DTRY_X11:BOOL=ON \
-DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib"
MAKE_ENV+= DESTDIR="${STAGEDIR}"
+# XXX Fix build on archs where 'unsigned long' is 32bit
+CXXFLAGS+= -DLZO_CFG_PREFER_TYPEOF_ACC_INT32E_T=LZO_TYPEOF_INT
+
# XXX Bypass git check (and set a dummy -unused- revision)
CMAKE_ARGS+= -DDOLPHIN_WC_BRANCH:STRING="stable" \
-DDOLPHIN_WC_REVISION:STRING="1"