aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2009-06-02 03:02:37 +0800
committerJuergen Lock <nox@FreeBSD.org>2009-06-02 03:02:37 +0800
commit952f424c6378b6eb44dfcfbb7250f7ca9b5b6cb1 (patch)
treea4bb4738b926af0eeac4725981fd868dd04e80c4 /emulators
parent94b185d6e2718b29b505aaed2b60355d367aa67f (diff)
downloadfreebsd-ports-gnome-952f424c6378b6eb44dfcfbb7250f7ca9b5b6cb1.tar.gz
freebsd-ports-gnome-952f424c6378b6eb44dfcfbb7250f7ca9b5b6cb1.tar.zst
freebsd-ports-gnome-952f424c6378b6eb44dfcfbb7250f7ca9b5b6cb1.zip
- (Attempt to) fix build on head by entirely disabling the usb host code
which is still not ported to the new usb stack yet. (qemu could really use some help here, the author of the old usb host code is busy with other stuff now...) - No PORTREVISION bump since this is a build fix.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile9
-rw-r--r--emulators/qemu/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index b5797246050a..9b6aced13ecc 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -124,6 +124,15 @@ post-patch:
-e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
${WRKSRC}/texi2pod.pl
+.if ${OSVERSION} >= 800091
+# XXX need to disable usb host code on head while it's not ported to the
+# new usb stack yet
+post-configure:
+ @${REINPLACE_CMD} -E \
+ -e "s|^(HOST_USB=)bsd|\1stub|" \
+ ${WRKSRC}/config-host.mak
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 6c538c1b798a..6a302490c036 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -125,6 +125,15 @@ post-patch:
-e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
${WRKSRC}/texi2pod.pl
+.if ${OSVERSION} >= 800091
+# XXX need to disable usb host code on head while it's not ported to the
+# new usb stack yet
+post-configure:
+ @${REINPLACE_CMD} -E \
+ -e "s|^(HOST_USB=)bsd|\1stub|" \
+ ${WRKSRC}/config-host.mak
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc