aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2004-10-28 23:42:48 +0800
committernork <nork@FreeBSD.org>2004-10-28 23:42:48 +0800
commit95985e6979ed670fc8b37200c32cb2ff9bab92ac (patch)
treed97ae438d937770e2b4ea0a55f42986ccee4f589 /emulators
parent8a1c8e62b7de6db94975f067967f37066267f320 (diff)
downloadfreebsd-ports-gnome-95985e6979ed670fc8b37200c32cb2ff9bab92ac.tar.gz
freebsd-ports-gnome-95985e6979ed670fc8b37200c32cb2ff9bab92ac.tar.zst
freebsd-ports-gnome-95985e6979ed670fc8b37200c32cb2ff9bab92ac.zip
Fix build error on 4-stable.
Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer) Pointed out by: pointy via kris
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile1
-rw-r--r--emulators/qemu-devel/files/patch-exec.c10
-rw-r--r--emulators/qemu-devel/files/patch-target-sparc::op_helper.c8
-rw-r--r--emulators/qemu/Makefile1
-rw-r--r--emulators/qemu/files/patch-exec.c10
-rw-r--r--emulators/qemu/files/patch-target-sparc::op_helper.c8
6 files changed, 38 insertions, 0 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 01e62cf09648..68d83f91cf91 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.6.0s.20041020
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://www.fuqn.ca/distfiles/ \
http://dad-answers.com/qemu/
diff --git a/emulators/qemu-devel/files/patch-exec.c b/emulators/qemu-devel/files/patch-exec.c
new file mode 100644
index 000000000000..f6978d7cc830
--- /dev/null
+++ b/emulators/qemu-devel/files/patch-exec.c
@@ -0,0 +1,10 @@
+--- qemu/exec.c.orig Mon Oct 11 00:14:19 2004
++++ qemu/exec.c Thu Oct 28 23:28:25 2004
+@@ -21,6 +21,7 @@
+ #ifdef _WIN32
+ #include <windows.h>
+ #else
++#include <sys/types.h>
+ #include <sys/mman.h>
+ #endif
+ #include <stdlib.h>
diff --git a/emulators/qemu-devel/files/patch-target-sparc::op_helper.c b/emulators/qemu-devel/files/patch-target-sparc::op_helper.c
new file mode 100644
index 000000000000..e621a1337ad1
--- /dev/null
+++ b/emulators/qemu-devel/files/patch-target-sparc::op_helper.c
@@ -0,0 +1,8 @@
+--- qemu/target-sparc/op_helper.c.orig Mon Oct 11 02:46:24 2004
++++ qemu/target-sparc/op_helper.c Thu Oct 28 23:28:57 2004
+@@ -1,5 +1,4 @@
+ #include <math.h>
+-#include <fenv.h>
+ #include "exec.h"
+
+ #ifdef USE_INT_TO_FLOAT_HELPERS
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 01e62cf09648..68d83f91cf91 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.6.0s.20041020
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://www.fuqn.ca/distfiles/ \
http://dad-answers.com/qemu/
diff --git a/emulators/qemu/files/patch-exec.c b/emulators/qemu/files/patch-exec.c
new file mode 100644
index 000000000000..f6978d7cc830
--- /dev/null
+++ b/emulators/qemu/files/patch-exec.c
@@ -0,0 +1,10 @@
+--- qemu/exec.c.orig Mon Oct 11 00:14:19 2004
++++ qemu/exec.c Thu Oct 28 23:28:25 2004
+@@ -21,6 +21,7 @@
+ #ifdef _WIN32
+ #include <windows.h>
+ #else
++#include <sys/types.h>
+ #include <sys/mman.h>
+ #endif
+ #include <stdlib.h>
diff --git a/emulators/qemu/files/patch-target-sparc::op_helper.c b/emulators/qemu/files/patch-target-sparc::op_helper.c
new file mode 100644
index 000000000000..e621a1337ad1
--- /dev/null
+++ b/emulators/qemu/files/patch-target-sparc::op_helper.c
@@ -0,0 +1,8 @@
+--- qemu/target-sparc/op_helper.c.orig Mon Oct 11 02:46:24 2004
++++ qemu/target-sparc/op_helper.c Thu Oct 28 23:28:57 2004
+@@ -1,5 +1,4 @@
+ #include <math.h>
+-#include <fenv.h>
+ #include "exec.h"
+
+ #ifdef USE_INT_TO_FLOAT_HELPERS