aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorGleb Smirnoff <glebius@FreeBSD.org>2014-10-03 02:17:48 +0800
committerGleb Smirnoff <glebius@FreeBSD.org>2014-10-03 02:17:48 +0800
commit9a01829b2af6837f0399f8439780125b8abbeb6c (patch)
treeb7364f842a6191402efee696a9b07ea3fd7b41fc /emulators
parent19ba1cd55e3de5d092d06409259cac4f8b92ea28 (diff)
downloadfreebsd-ports-gnome-9a01829b2af6837f0399f8439780125b8abbeb6c.tar.gz
freebsd-ports-gnome-9a01829b2af6837f0399f8439780125b8abbeb6c.tar.zst
freebsd-ports-gnome-9a01829b2af6837f0399f8439780125b8abbeb6c.zip
Update for recent ifnet(9) changes in head.
Approved by: bapt (blanket)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/open-vm-tools/files/patch-modules__freebsd__vmxnet__if_vxn.c33
2 files changed, 30 insertions, 5 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index d24f1bd3c9b6..356320ca40bc 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= open-vm-tools
PORTVERSION= ${BUILD_VER}
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/stable-9.4.x
diff --git a/emulators/open-vm-tools/files/patch-modules__freebsd__vmxnet__if_vxn.c b/emulators/open-vm-tools/files/patch-modules__freebsd__vmxnet__if_vxn.c
index bfc3eb81d128..0a0ac1e83306 100644
--- a/emulators/open-vm-tools/files/patch-modules__freebsd__vmxnet__if_vxn.c
+++ b/emulators/open-vm-tools/files/patch-modules__freebsd__vmxnet__if_vxn.c
@@ -1,5 +1,5 @@
---- ./modules/freebsd/vmxnet/if_vxn.c.orig 2013-09-23 15:51:10.000000000 +0000
-+++ ./modules/freebsd/vmxnet/if_vxn.c 2014-04-23 15:36:44.347844739 +0000
+--- modules/freebsd/vmxnet/if_vxn.c.orig 2013-09-23 19:51:10.000000000 +0400
++++ modules/freebsd/vmxnet/if_vxn.c 2014-10-02 22:13:31.000000000 +0400
@@ -76,6 +76,10 @@
#include <pci/pcivar.h>
#endif
@@ -28,7 +28,19 @@
if (!(m_new->m_flags & M_EXT)) {
m_freem(m_new);
printf("vxn%d: no memory for tx list\n", VXN_IF_UNIT(ifp));
-@@ -1266,9 +1270,9 @@
+@@ -1067,7 +1071,11 @@
+ VMXNET_INC(dd->txDriverNext, dd->txRingLength);
+ dd->txNumDeferred++;
+ sc->vxn_tx_pending++;
++#if __FreeBSD_version >= 1100036
++ if_inc_counter(ifp, IFCOUNTER_OPACKETS, 1);
++#else
+ ifp->if_opackets++;
++#endif
+ }
+
+ /*
+@@ -1266,9 +1274,9 @@
/*
* Allocate a new mbuf cluster to replace the current one
*/
@@ -40,7 +52,20 @@
if (m_new->m_flags & M_EXT) {
m_adj(m_new, ETHER_ALIGN);
} else {
-@@ -1401,10 +1405,10 @@
+@@ -1286,8 +1294,11 @@
+
+ sc->vxn_rx_buffptr[dd->rxDriverNext] = m_new;
+ rre->paddr = (uint32)vtophys(mtod(m_new, caddr_t));
+-
++#if __FreeBSD_version >= 1100036
++ if_inc_counter(ifp, IFCOUNTER_IPACKETS, 1);
++#else
+ ifp->if_ipackets++;
++#endif
+ m->m_pkthdr.rcvif = ifp;
+ m->m_pkthdr.len = m->m_len = pkt_len;
+
+@@ -1401,10 +1412,10 @@
* Allocate an mbuf and initialize it to contain a packet header and
* internal data.
*/