aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-03-11 02:47:41 +0800
committeradamw <adamw@FreeBSD.org>2005-03-11 02:47:41 +0800
commita0095fd530dd3953808c3dfe127ec11af22351e8 (patch)
treecbcad2a86342a85cff7b2fe7aaf4ecb95908b946 /emulators
parent98393df639c69d997720d88342ce5d89d9337973 (diff)
downloadfreebsd-ports-gnome-a0095fd530dd3953808c3dfe127ec11af22351e8.tar.gz
freebsd-ports-gnome-a0095fd530dd3953808c3dfe127ec11af22351e8.tar.zst
freebsd-ports-gnome-a0095fd530dd3953808c3dfe127ec11af22351e8.zip
Apply a simple fix to remove the dependency upon gcc 3.3
Diffstat (limited to 'emulators')
-rw-r--r--emulators/snes9express/Makefile1
-rw-r--r--emulators/snes9express/files/patch-frend.cc10
2 files changed, 10 insertions, 1 deletions
diff --git a/emulators/snes9express/Makefile b/emulators/snes9express/Makefile
index 5e3be8099a49..39a03fdcaba2 100644
--- a/emulators/snes9express/Makefile
+++ b/emulators/snes9express/Makefile
@@ -17,7 +17,6 @@ COMMENT= GTK interface for snes9x
RUN_DEPENDS= snes9x:${PORTSDIR}/emulators/snes9x
-USE_GCC= 3.3
USE_GETTEXT= yes
USE_GNOME= gtk20
USE_REINPLACE= yes
diff --git a/emulators/snes9express/files/patch-frend.cc b/emulators/snes9express/files/patch-frend.cc
new file mode 100644
index 000000000000..2e33ce31cf0b
--- /dev/null
+++ b/emulators/snes9express/files/patch-frend.cc
@@ -0,0 +1,10 @@
+--- frend.cc.orig Thu Mar 10 13:43:06 2005
++++ frend.cc Thu Mar 10 13:44:15 2005
+@@ -18,6 +18,7 @@
+ #include "frend.h"
+ #include <unistd.h>
+ #include <sys/stat.h>
++#include <sys/errno.h>
+ #include <cstdlib>
+ #include <climits>
+ #include <sstream>