aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2004-08-11 09:30:57 +0800
committerjeh <jeh@FreeBSD.org>2004-08-11 09:30:57 +0800
commita13d0e0369cb8862fe0711070eff862ea5180376 (patch)
tree188619288aa98e22e648b60fafd2dfcec6ea2144 /emulators
parentc09d20d00f3c087f7c016439cc2ee6edf8f0c22b (diff)
downloadfreebsd-ports-gnome-a13d0e0369cb8862fe0711070eff862ea5180376.tar.gz
freebsd-ports-gnome-a13d0e0369cb8862fe0711070eff862ea5180376.tar.zst
freebsd-ports-gnome-a13d0e0369cb8862fe0711070eff862ea5180376.zip
* Remove the last of the delecrations that were also in <stdio.h>
* Bump PORTREVISION
Diffstat (limited to 'emulators')
-rw-r--r--emulators/sim6811/Makefile2
-rw-r--r--emulators/sim6811/files/patch-ac18
2 files changed, 11 insertions, 9 deletions
diff --git a/emulators/sim6811/Makefile b/emulators/sim6811/Makefile
index 99464ad655c2..45b5d70b60ce 100644
--- a/emulators/sim6811/Makefile
+++ b/emulators/sim6811/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sim6811
PORTVERSION= 1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= ftp://crl.nmsu.edu/pub/non-lexical/6811/
DISTNAME= sim
diff --git a/emulators/sim6811/files/patch-ac b/emulators/sim6811/files/patch-ac
index 53ec9652e011..4553b0f45d3c 100644
--- a/emulators/sim6811/files/patch-ac
+++ b/emulators/sim6811/files/patch-ac
@@ -1,18 +1,20 @@
---- main.c.orig Tue Mar 22 14:16:59 1994
-+++ main.c Thu Oct 16 10:06:27 2003
-@@ -70,11 +70,8 @@
+--- main.c.orig Tue Mar 22 17:16:59 1994
++++ main.c Tue Aug 10 21:28:07 2004
+@@ -70,13 +70,6 @@
#include <ctype.h>
#include "sim.h"
-extern int printf();
-extern int fprintf();
- extern int fclose();
- extern int fscanf();
+-extern int fclose();
+-extern int fscanf();
-extern int sscanf();
- extern int fflush();
-
+-extern int fflush();
+-
/* how to handle all other op codes */
-@@ -323,19 +320,7 @@
+ void bad_op(m6811 state)
+ {
+@@ -323,19 +316,7 @@
case '?': /* help */
(void) fgets(line, sizeof(line), stdin);