aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-12-15 03:26:50 +0800
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-12-15 03:26:50 +0800
commita2fc57960bdbea48c2f7514de486dece28ed38e6 (patch)
tree1c562a25e67c6bafa324c1f036a7a85da97243ab /emulators
parent7b4558c9ea82e2709a04a55b7568153992c7c938 (diff)
downloadfreebsd-ports-gnome-a2fc57960bdbea48c2f7514de486dece28ed38e6.tar.gz
freebsd-ports-gnome-a2fc57960bdbea48c2f7514de486dece28ed38e6.tar.zst
freebsd-ports-gnome-a2fc57960bdbea48c2f7514de486dece28ed38e6.zip
On amd64 we want to use FALLBACK_ELF_MIB as kern.elf32.fallback_brand,
vs. kern.fallback_elf_brand.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-8/Makefile4
-rw-r--r--emulators/linux_base-rh-9/Makefile4
-rw-r--r--emulators/linux_base-suse-9.1/Makefile4
-rw-r--r--emulators/linux_base-suse-9.2/Makefile4
-rw-r--r--emulators/linux_base-suse-9.3/Makefile4
-rw-r--r--emulators/linux_base/Makefile5
6 files changed, 24 insertions, 1 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 9df18ac40bd9..12a4272d2ca5 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -102,7 +102,11 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/protocols
BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
+.if (${ARCH} == "amd64")
+FALLBACK_ELF_MIB= kern.elf32.fallback_brand
+.else
FALLBACK_ELF_MIB= kern.fallback_elf_brand
+.endif
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
diff --git a/emulators/linux_base-rh-9/Makefile b/emulators/linux_base-rh-9/Makefile
index 9df18ac40bd9..12a4272d2ca5 100644
--- a/emulators/linux_base-rh-9/Makefile
+++ b/emulators/linux_base-rh-9/Makefile
@@ -102,7 +102,11 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/protocols
BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
+.if (${ARCH} == "amd64")
+FALLBACK_ELF_MIB= kern.elf32.fallback_brand
+.else
FALLBACK_ELF_MIB= kern.fallback_elf_brand
+.endif
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
diff --git a/emulators/linux_base-suse-9.1/Makefile b/emulators/linux_base-suse-9.1/Makefile
index 9df18ac40bd9..12a4272d2ca5 100644
--- a/emulators/linux_base-suse-9.1/Makefile
+++ b/emulators/linux_base-suse-9.1/Makefile
@@ -102,7 +102,11 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/protocols
BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
+.if (${ARCH} == "amd64")
+FALLBACK_ELF_MIB= kern.elf32.fallback_brand
+.else
FALLBACK_ELF_MIB= kern.fallback_elf_brand
+.endif
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
index 9df18ac40bd9..12a4272d2ca5 100644
--- a/emulators/linux_base-suse-9.2/Makefile
+++ b/emulators/linux_base-suse-9.2/Makefile
@@ -102,7 +102,11 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/protocols
BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
+.if (${ARCH} == "amd64")
+FALLBACK_ELF_MIB= kern.elf32.fallback_brand
+.else
FALLBACK_ELF_MIB= kern.fallback_elf_brand
+.endif
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
diff --git a/emulators/linux_base-suse-9.3/Makefile b/emulators/linux_base-suse-9.3/Makefile
index 9df18ac40bd9..12a4272d2ca5 100644
--- a/emulators/linux_base-suse-9.3/Makefile
+++ b/emulators/linux_base-suse-9.3/Makefile
@@ -102,7 +102,11 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/protocols
BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
+.if (${ARCH} == "amd64")
+FALLBACK_ELF_MIB= kern.elf32.fallback_brand
+.else
FALLBACK_ELF_MIB= kern.fallback_elf_brand
+.endif
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
diff --git a/emulators/linux_base/Makefile b/emulators/linux_base/Makefile
index 5409c7991357..0b0f8e27e5c1 100644
--- a/emulators/linux_base/Makefile
+++ b/emulators/linux_base/Makefile
@@ -117,8 +117,11 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/motd etc/passwd etc/printcap etc/services \
etc/protocols
BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
-
+.if (${ARCH} == "amd64")
+FALLBACK_ELF_MIB= kern.elf32.fallback_brand
+.else
FALLBACK_ELF_MIB= kern.fallback_elf_brand
+.endif
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}