aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-02 03:24:00 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-02 03:24:00 +0800
commita6bef84e481b1eb09039107aaf3b73f07b7743b5 (patch)
treee590a1fe25ef8fd6c3924c68296537c795f3af31 /emulators
parentfa54b0591d877b49d3bd8fc7d1218980e4d979a5 (diff)
downloadfreebsd-ports-gnome-a6bef84e481b1eb09039107aaf3b73f07b7743b5.tar.gz
freebsd-ports-gnome-a6bef84e481b1eb09039107aaf3b73f07b7743b5.tar.zst
freebsd-ports-gnome-a6bef84e481b1eb09039107aaf3b73f07b7743b5.zip
Provide error messages for some ports failing on aarch64, and, in a
few cases, other tier-2 archs. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/catapult/Makefile3
-rw-r--r--emulators/dtcyber/Makefile1
-rw-r--r--emulators/pearpc/Makefile2
-rw-r--r--emulators/x49gp/Makefile2
4 files changed, 6 insertions, 2 deletions
diff --git a/emulators/catapult/Makefile b/emulators/catapult/Makefile
index 8d1c4dead7fe..7ee2a0064bc6 100644
--- a/emulators/catapult/Makefile
+++ b/emulators/catapult/Makefile
@@ -36,6 +36,9 @@ MAKE_ARGS= INSTALL_BASE="${PREFIX}" \
MAKE_JOBS_UNSAFE= yes
+BROKEN_aarch64= fails to link: fails to detect libxml2 even though it is installed
+BROKEN_armv6= fails to link: fails to detect libxml2 even though it is installed
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
diff --git a/emulators/dtcyber/Makefile b/emulators/dtcyber/Makefile
index 33a90cb98f79..1c6c0ea8a675 100644
--- a/emulators/dtcyber/Makefile
+++ b/emulators/dtcyber/Makefile
@@ -24,6 +24,7 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/dtcyber %%EXAMPLESDIR%%/cyber.ini %%EXAMPLESDIR%%/cos.tap
BROKEN_aarch64= Fails to compile: error: Unable to determine size of basic data types
+BROKEN_armv6= Fails to compile: error: Unable to determine size of basic data types
BROKEN_mips64= Fails to compile: error: Unable to determine size of basic data types
do-install:
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 58435a01e975..041cb3396381 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -16,8 +16,6 @@ USES= tar:bzip2
USE_XORG= x11
GNU_CONFIGURE= yes
-BROKEN_ia64= internal compiler error on ia64
-
PORTEXAMPLES= ppccfg.example
PLIST_FILES= bin/ppc man/man1/ppc.1.gz %%DATADIR%%/video.x
diff --git a/emulators/x49gp/Makefile b/emulators/x49gp/Makefile
index f2268a376ba2..7153c50faa24 100644
--- a/emulators/x49gp/Makefile
+++ b/emulators/x49gp/Makefile
@@ -14,6 +14,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= shaun@FreeBSD.org
COMMENT= HP 49g+/50g graphics calculator emulator
+BROKEN_aarch64= does not build on arm: unsupported CPU = unknown
+BROKEN_armv6= does not build on arm: unsupported CPU = unknown
BROKEN_i386= does not build on i386 (error: frame pointer required, but reserved)
WRKSRC= ${WRKDIR}/x49gp/x49gp-code