aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-11-27 03:59:55 +0800
committernemysis <nemysis@FreeBSD.org>2013-11-27 03:59:55 +0800
commitc94fb7823ea697152e0cfa1c7ab6fcf90942e2c4 (patch)
treef5b10ae4c6eab5f036441ea2f69977d90dacc57b /emulators
parent78b3519d8f7ed7c88309dcf3a03eb2f0490170a6 (diff)
downloadfreebsd-ports-gnome-c94fb7823ea697152e0cfa1c7ab6fcf90942e2c4.tar.gz
freebsd-ports-gnome-c94fb7823ea697152e0cfa1c7ab6fcf90942e2c4.tar.zst
freebsd-ports-gnome-c94fb7823ea697152e0cfa1c7ab6fcf90942e2c4.zip
- Update to 1.0.4
- Change Makefile header - Remove master sites, use GitHub=yes - Change maintainer email to @FreeBSD.org - USES gmake instead of USE_GMAKE - Support STAGEDIR - Add DOCS Option - Change REINPLACE_CMD - Change pkg-message Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/swine/Makefile56
-rw-r--r--emulators/swine/distinfo4
-rw-r--r--emulators/swine/pkg-message16
-rw-r--r--emulators/swine/pkg-plist4
4 files changed, 44 insertions, 36 deletions
diff --git a/emulators/swine/Makefile b/emulators/swine/Makefile
index 2d113f191130..6d2700226d89 100644
--- a/emulators/swine/Makefile
+++ b/emulators/swine/Makefile
@@ -1,13 +1,11 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= swine
-PORTVERSION= 1.0.3
-PORTREVISION= 3
+PORTVERSION= 1.0.4
CATEGORIES= emulators deskutils python
-MASTER_SITES= https://github.com/downloads/dswd/Swine/
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Qt4 graphical Wine frontend
LICENSE= GPLv2
@@ -20,16 +18,22 @@ RUN_DEPENDS= xterm:${PORTSDIR}/x11/xterm \
DATADIRLIB= ${PREFIX}/lib/${PORTNAME}
-FETCH_ARGS?= -Fpr
+USE_GITHUB= yes
+GH_ACCOUNT= dswd
+GH_PROJECT= Swine
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 1770c40
+
+USES= gmake
USE_PYTHON= yes
NO_BUILD= yes
-USE_GMAKE= yes
USE_QT4= linguist_build
ONLY_FOR_ARCHS= i386 amd64
PORTDOCS= README
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
@@ -38,28 +42,18 @@ RUN_DEPENDS+= wine:${PORTSDIR}/emulators/wine-devel
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/version.sh
- @${REINPLACE_CMD} -e 's|/usr/share/swine/images/swine32.png|${PREFIX}/share/pixmaps/swine.png|' ${WRKSRC}/resources/swine.desktop
- @${FIND} ${WRKSRC} -name "*.bak" -delete
-
-do-install:
- ${MKDIR} ${DATADIRLIB}
- ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIRLIB}
- ${LN} -sf ${DATADIRLIB}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
- ${LN} -sf ${DATADIRLIB}/${PORTNAME}cli.py ${PREFIX}/bin/${PORTNAME}cli
- ${LN} -sf ${DATADIRLIB}/${PORTNAME}run.py ${PREFIX}/bin/${PORTNAME}run
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "translations images" ${DATADIR})
-
- ${LN} -sf ${DATADIR}/images/swine32.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
- ${INSTALL_DATA} ${WRKSRC}/resources/*.desktop ${PREFIX}/share/applications/
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}| ; \
+ s|swine32.png|*|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/share/swine/images/swine32.png|swine|' \
+ -e 's|^Categories=.*|Categories=Wine;System;Emulator;Utility;Game;|' \
+ ${WRKSRC}/resources/swine.desktop
+
+post-install:
+ ${LN} -sf ${DATADIR}/images/swine32.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/emulators/swine/distinfo b/emulators/swine/distinfo
index 447418ce2678..f943cb000775 100644
--- a/emulators/swine/distinfo
+++ b/emulators/swine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (swine-1.0.3.tar.gz) = e474a5657b8b7822d5417237044201d72bda41b3402bc5556e497df8eabd9de0
-SIZE (swine-1.0.3.tar.gz) = 172820
+SHA256 (swine-1.0.4.tar.gz) = 3b3efd55af2aff561224e004de845705c2d23a0aa39ed9dda447ae90000eef06
+SIZE (swine-1.0.4.tar.gz) = 214039
diff --git a/emulators/swine/pkg-message b/emulators/swine/pkg-message
index bc05af93637f..3faa9a68e250 100644
--- a/emulators/swine/pkg-message
+++ b/emulators/swine/pkg-message
@@ -1,12 +1,19 @@
################################################################################
-FreeBSD/amd64 users:
-You need to manually install Wine 32bit binary from:
-http://www.mediafire.com/wine_fbsd64
+Swine has been installed.
+
For more info about running wine on FreeBSD please see:
+
http://wiki.freebsd.org/Wine
+
+FreeBSD/amd64 users:
+You need to manually install Wine 32bit binary from:
+
+https://wiki.freebsd.org/i386-Wine
+
+
This program will attempt to obtain some system information by accessing files
in procfs. You must mount procfs filesystem for this to work correctly.
This can be accomplished by adding the following line to your /etc/fstab file:
@@ -18,4 +25,7 @@ and then, as root, executing the command:
mount /proc
+Also you need passwordless sudo for mdconfig, mount_cd9660, umount commands for
+work with ISO images.
+
################################################################################
diff --git a/emulators/swine/pkg-plist b/emulators/swine/pkg-plist
index 2d9db08cc63a..c281be640226 100644
--- a/emulators/swine/pkg-plist
+++ b/emulators/swine/pkg-plist
@@ -74,8 +74,12 @@ share/pixmaps/swine.png
%%DATADIR%%/translations/de.qm
%%DATADIR%%/translations/en.qm
%%DATADIR%%/translations/es.qm
+%%DATADIR%%/translations/fi.qm
%%DATADIR%%/translations/fr.qm
%%DATADIR%%/translations/he.qm
+%%DATADIR%%/translations/pl.qm
+%%DATADIR%%/translations/tr.qm
+%%DATADIR%%/translations/vi.qm
@dirrm %%DATADIR%%/translations
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%