aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2012-08-04 15:53:34 +0800
committerdecke <decke@FreeBSD.org>2012-08-04 15:53:34 +0800
commitca798084bc643338ec44be605451568cf767359a (patch)
treeba9ddfe5c2926d2ca8bba00c446b9b41120ee693 /emulators
parentaeb095b0b29df8be5090803925ca48f0fdb22a9f (diff)
downloadfreebsd-ports-gnome-ca798084bc643338ec44be605451568cf767359a.tar.gz
freebsd-ports-gnome-ca798084bc643338ec44be605451568cf767359a.tar.zst
freebsd-ports-gnome-ca798084bc643338ec44be605451568cf767359a.zip
- Convert to optionsng
Submitted by: bapt
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose-kmod-legacy/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/virtualbox-ose-kmod-legacy/Makefile b/emulators/virtualbox-ose-kmod-legacy/Makefile
index 9c1ab3d3243f..83f48a4eb182 100644
--- a/emulators/virtualbox-ose-kmod-legacy/Makefile
+++ b/emulators/virtualbox-ose-kmod-legacy/Makefile
@@ -40,8 +40,8 @@ CONFLICTS= bcc-[0-9]*
CONFLICTS_BUILD= kBuild-devel-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-kmod-[3,4]* virtualbox-ose-kmod-devel-[3,4]*
-OPTIONS= DEBUG "Build with debugging symbols" off \
- VIMAGE "VIMAGE virtual networking support" off
+OPTIONS_DEFINE= DEBUG VIMAGE
+VIMAGE_DESC= VIMAGE virtual networking support
.include <bsd.port.options.mk>
@@ -56,7 +56,7 @@ KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS= HostDrivers-src vboxdrv-mod VBoxNetFlt-src VBoxNetAdp-src
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
KMK_FLAGS+= BUILD_TYPE=debug
KMK_BUILDTYPE= debug
.endif
@@ -73,7 +73,7 @@ IGNORE= requires kernel sources
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800500 && defined(WITH_VIMAGE)
+.if ${OSVERSION} < 800500 && !empty(PORT_OPTIONS:MVIMAGE)
IGNORE= newer kernel is required to build with VIMAGE
.endif
@@ -82,7 +82,7 @@ post-patch:
@${ECHO} 'VBOX_WITH_NETFLT = 1' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_WITH_NETADP = 1' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_WITH_ADDITIONS =' >> ${WRKSRC}/LocalConfig.kmk
-.if defined(WITH_VIMAGE)
+.if ${PORT_OPTIONS:MVIMAGE}
@${ECHO} 'VBOX_WITH_NETFLT_VIMAGE = 1' >> ${WRKSRC}/LocalConfig.kmk
.endif
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \