aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-07-25 17:38:45 +0800
committerpav <pav@FreeBSD.org>2008-07-25 17:38:45 +0800
commite3db8ee84c8bacf91265d9a1d659ed398630c37d (patch)
tree79ed9e5984a819f5a0bcea9bdfc3968804a6c2bf /emulators
parent5bb45c428bbe01f1d4ca25e7ee7e6bc6d5cdc9a3 (diff)
downloadfreebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.tar.gz
freebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.tar.zst
freebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.zip
- Remove duplicates from MAKE_ENV after inclusion of CC and CXX in default MAKE_ENV
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64-base/Makefile2
-rw-r--r--emulators/mupen64plus-base/Makefile2
-rw-r--r--emulators/mupen64plus-core/Makefile2
-rw-r--r--emulators/qemu-devel/Makefile2
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/raine/Makefile1
6 files changed, 5 insertions, 6 deletions
diff --git a/emulators/mupen64-base/Makefile b/emulators/mupen64-base/Makefile
index fb779e108dfd..84ca0bb925e7 100644
--- a/emulators/mupen64-base/Makefile
+++ b/emulators/mupen64-base/Makefile
@@ -25,7 +25,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
ONLY_FOR_ARCHS= i386
-MAKE_ENV+= CXX="${CXX}" PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
MUPEN64VERSION= 0.5
FIXFILES?= r4300/r4300.c memory/dma.c r4300/recomp.c r4300/x86/assemble.c
diff --git a/emulators/mupen64plus-base/Makefile b/emulators/mupen64plus-base/Makefile
index 4b28fd8a3eb6..4c269a65a719 100644
--- a/emulators/mupen64plus-base/Makefile
+++ b/emulators/mupen64plus-base/Makefile
@@ -23,7 +23,7 @@ USE_SDL?= #
USE_GMAKE= yes
ONLY_FOR_ARCHS= i386 amd64
-MAKE_ENV+= CXX="${CXX}" PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
FIXFILES?= r4300/r4300.c r4300/recomp.c memory/dma.c r4300/x86/assemble.c \
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 4b28fd8a3eb6..4c269a65a719 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -23,7 +23,7 @@ USE_SDL?= #
USE_GMAKE= yes
ONLY_FOR_ARCHS= i386 amd64
-MAKE_ENV+= CXX="${CXX}" PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
FIXFILES?= r4300/r4300.c r4300/recomp.c memory/dma.c r4300/x86/assemble.c \
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index b884c690f544..da497ceb3f47 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -26,7 +26,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
PATCH_STRIP= -lp1
-MAKE_ENV+= BSD_MAKE="${MAKE}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV+= BSD_MAKE="${MAKE}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= amd64 i386
CONFLICTS= qemu-[0-9]*
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 260d519d345b..9a9a35992272 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -25,7 +25,7 @@ USE_PERL5= yes
USE_GCC= 3.4
PATCH_STRIP= -lp1
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
-MAKE_ENV+= BSD_MAKE="${MAKE}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV+= BSD_MAKE="${MAKE}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= amd64 i386
CONFLICTS= qemu-devel-[0-9]*
diff --git a/emulators/raine/Makefile b/emulators/raine/Makefile
index 10980f0bd070..e2b2b09c383f 100644
--- a/emulators/raine/Makefile
+++ b/emulators/raine/Makefile
@@ -27,7 +27,6 @@ USE_GMAKE= yes
USE_SDL= sdl
USE_GNOME= gnomehier
MAKEFILE= makefile
-MAKE_ENV= PREFIX=${PREFIX}
ONLY_FOR_ARCHS= i386