aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-10-23 02:56:05 +0800
committernox <nox@FreeBSD.org>2011-10-23 02:56:05 +0800
commite41f0c743caad57fae5b95f308ec675c8fcc059a (patch)
treef0e356d383c4809b9f2961960fe0520151887c80 /emulators
parenta3798f0de542c93b0da931876b464696b62c809b (diff)
downloadfreebsd-ports-gnome-e41f0c743caad57fae5b95f308ec675c8fcc059a.tar.gz
freebsd-ports-gnome-e41f0c743caad57fae5b95f308ec675c8fcc059a.tar.zst
freebsd-ports-gnome-e41f0c743caad57fae5b95f308ec675c8fcc059a.zip
- Respect CC (sgabios) [1]
- Respect STRIP [2] - Respect NOPORTDOCS, even if it's empty [3] - Trim deps for -nographic [4] PR: ports/161855 [1], ports/161856 [2], ports/161857 [3], ports/161858 [4] Submitted by: Nali Toja <nalitoja@gmail.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile40
-rw-r--r--emulators/qemu-devel/pkg-plist2
2 files changed, 33 insertions, 9 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 5e1fd643e7bb..e938f08c1ef1 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -25,8 +25,6 @@ COMMENT= QEMU CPU Emulator - development version
HAS_CONFIGURE= yes
USE_GMAKE= yes
-USE_PYTHON= yes
-USE_GNOME= glib20
USE_PERL5_BUILD= yes
PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}"
@@ -41,6 +39,9 @@ OPTIONS= SAMBA "samba dependency (for -smb)" Off \
OPENGL "OpenGL dependency" On \
GNUTLS "gnutls dependency (vnc encryption)" On \
SASL "cyrus-sasl dependency (vnc encryption)" On \
+ JPEG "jpeg dependency (vnc lossy compression)" On \
+ PNG "png dependency (vnc compression)" On \
+ GA "glib20 dependency (guest agent)" On \
CURL "libcurl dependency (remote images)" On \
CDROM_DMA "IDE CDROM DMA" On \
PCAP "pcap dependency (networking with bpf)" On \
@@ -50,12 +51,10 @@ OPTIONS= SAMBA "samba dependency (for -smb)" Off \
ADD_AUDIO "Emulate more audio hardware (experimental!)" Off \
ALL_TARGETS "Also build bsd-user targets (for testing)" Off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CONFIGURE_ARGS+= --extra-ldflags=-L${LOCALBASE}/lib
PORTDOCS= docs qemu-doc.html qemu-tech.html
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
.if defined(WITHOUT_ALL_TARGETS)
CONFIGURE_ARGS+= --disable-bsd-user
@@ -105,6 +104,27 @@ CONFIGURE_ARGS+= --disable-vnc-sasl
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
.endif
+.if defined(WITHOUT_JPEG)
+CONFIGURE_ARGS+= --disable-vnc-jpeg
+.else
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+.endif
+
+.if defined(WITHOUT_PNG)
+CONFIGURE_ARGS+= --disable-vnc-png
+.else
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+.endif
+
+.if defined(WITHOUT_GA)
+CONFIGURE_ARGS+= --disable-guest-agent --python="${NONEXISTENT}"
+PLIST_SUB+= GA="@comment "
+.else
+USE_PYTHON_BUILD= yes
+USE_GNOME+= glib20
+PLIST_SUB+= GA=""
+.endif
+
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+= --disable-curl
.else
@@ -140,11 +160,15 @@ RUN_DEPENDS+= ${LOCALBASE}/share/qemu/seabios-devel.bin:${PORTSDIR}/emulators/se
.endif
.if defined(NOPORTDOCS)
-MAKE_ARGS+= NOPORTDOCS=${NOPORTDOCS}
+MAKE_ARGS+= NOPORTDOCS=1
.else
BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
.endif
+.if !defined(STRIP) || ${STRIP} == ""
+CONFIGURE_ARGS+=--disable-strip
+.endif
+
.if ${ARCH} == "amd64"
MAKE_ARGS+= ARCH=x86_64
.endif
@@ -193,7 +217,7 @@ post-configure:
.endif
post-build:
- @(cd ${WRKDIR}/sgabios-read-only && ${GMAKE})
+ @${MAKE_ENV} ${GMAKE} -C${WRKDIR}/sgabios-read-only
post-install:
.if !defined(NOPORTDOCS)
@@ -210,4 +234,4 @@ post-install:
fi
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index c6c1ffff3129..cc95be7ebf97 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -1,5 +1,5 @@
bin/qemu
-bin/qemu-ga
+%%GA%%bin/qemu-ga
bin/qemu-img
bin/qemu-io
bin/qemu-nbd