aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2008-03-29 23:02:25 +0800
committerbsam <bsam@FreeBSD.org>2008-03-29 23:02:25 +0800
commite6e98206bde22b1aa17860e5610497aef31e985b (patch)
tree53644d7fbc453185ff45bdfbe51c85e60363d8c2 /emulators
parent53497f74edb39047258f58826a42a50e9edd1670 (diff)
downloadfreebsd-ports-gnome-e6e98206bde22b1aa17860e5610497aef31e985b.tar.gz
freebsd-ports-gnome-e6e98206bde22b1aa17860e5610497aef31e985b.tar.zst
freebsd-ports-gnome-e6e98206bde22b1aa17860e5610497aef31e985b.zip
. add a script LINUXBASE/usr/bin/lp which let some linux applications [1]
(most notable acroread) to print with default settings; . add linux_base-f7 to CONFLICTS; . bump PORTREVISION. Suggested by: olli, scf [1] Reviewed by: netchild [1]
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-c6/Makefile7
-rw-r--r--emulators/linux_base-c6/files/lp2
-rw-r--r--emulators/linux_base-c6/pkg-plist1
-rw-r--r--emulators/linux_base-f10/Makefile7
-rw-r--r--emulators/linux_base-f10/files/lp2
-rw-r--r--emulators/linux_base-f10/pkg-plist1
-rw-r--r--emulators/linux_base-f8/Makefile7
-rw-r--r--emulators/linux_base-f8/files/lp2
-rw-r--r--emulators/linux_base-f8/pkg-plist1
-rw-r--r--emulators/linux_base-f9/Makefile7
-rw-r--r--emulators/linux_base-f9/files/lp2
-rw-r--r--emulators/linux_base-f9/linux_base-f8/Makefile7
-rw-r--r--emulators/linux_base-f9/linux_base-f8/files/lp2
-rw-r--r--emulators/linux_base-f9/linux_base-f8/pkg-plist1
-rw-r--r--emulators/linux_base-f9/pkg-plist1
15 files changed, 45 insertions, 5 deletions
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index b0955b238e41..e2d51ccfa4d8 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= f8
PORTVERSION= 8
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
MASTER_SITE_SUBDIR= ../releases/${PORTVERSION}/Everything/${LINUX_RPM_ARCH}/os/Packages \
@@ -96,7 +97,7 @@ SRC_DISTFILES+= acl-2.2.39-13.fc8.src.rpm \
ALWAYS_KEEP_DISTFILES= yes
.endif
-CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6
+CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6 linux_base-f7
ONLY_FOR_ARCHS= i386 amd64
LINUX_RPM_ARCH= i386
USE_LINUX_PREFIX= yes
@@ -204,6 +205,10 @@ do-install:
@${LN} -sf /var/tmp ${PREFIX}/usr/tmp
@${CHOWN} root:wheel ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
@${CHMOD} 755 ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
+#
+# Let some linux applications (e.g. print/acroread7) print with default settings
+#
+ @${INSTALL_SCRIPT} ${FILESDIR}/lp ${PREFIX}/usr/bin
post-install:
#
diff --git a/emulators/linux_base-c6/files/lp b/emulators/linux_base-c6/files/lp
new file mode 100644
index 000000000000..d1e0b5509eed
--- /dev/null
+++ b/emulators/linux_base-c6/files/lp
@@ -0,0 +1,2 @@
+#!/bin/sh -
+exec /usr/bin/lpr "$@"
diff --git a/emulators/linux_base-c6/pkg-plist b/emulators/linux_base-c6/pkg-plist
index db12f6fa5495..bf8ab8a8eb87 100644
--- a/emulators/linux_base-c6/pkg-plist
+++ b/emulators/linux_base-c6/pkg-plist
@@ -298,6 +298,7 @@ usr/bin/lddlibc4
usr/bin/locale
usr/bin/localedef
usr/bin/logname
+usr/bin/lp
usr/bin/lsattr
usr/bin/md5sum
usr/bin/mkfifo
diff --git a/emulators/linux_base-f10/Makefile b/emulators/linux_base-f10/Makefile
index b0955b238e41..e2d51ccfa4d8 100644
--- a/emulators/linux_base-f10/Makefile
+++ b/emulators/linux_base-f10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= f8
PORTVERSION= 8
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
MASTER_SITE_SUBDIR= ../releases/${PORTVERSION}/Everything/${LINUX_RPM_ARCH}/os/Packages \
@@ -96,7 +97,7 @@ SRC_DISTFILES+= acl-2.2.39-13.fc8.src.rpm \
ALWAYS_KEEP_DISTFILES= yes
.endif
-CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6
+CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6 linux_base-f7
ONLY_FOR_ARCHS= i386 amd64
LINUX_RPM_ARCH= i386
USE_LINUX_PREFIX= yes
@@ -204,6 +205,10 @@ do-install:
@${LN} -sf /var/tmp ${PREFIX}/usr/tmp
@${CHOWN} root:wheel ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
@${CHMOD} 755 ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
+#
+# Let some linux applications (e.g. print/acroread7) print with default settings
+#
+ @${INSTALL_SCRIPT} ${FILESDIR}/lp ${PREFIX}/usr/bin
post-install:
#
diff --git a/emulators/linux_base-f10/files/lp b/emulators/linux_base-f10/files/lp
new file mode 100644
index 000000000000..d1e0b5509eed
--- /dev/null
+++ b/emulators/linux_base-f10/files/lp
@@ -0,0 +1,2 @@
+#!/bin/sh -
+exec /usr/bin/lpr "$@"
diff --git a/emulators/linux_base-f10/pkg-plist b/emulators/linux_base-f10/pkg-plist
index db12f6fa5495..bf8ab8a8eb87 100644
--- a/emulators/linux_base-f10/pkg-plist
+++ b/emulators/linux_base-f10/pkg-plist
@@ -298,6 +298,7 @@ usr/bin/lddlibc4
usr/bin/locale
usr/bin/localedef
usr/bin/logname
+usr/bin/lp
usr/bin/lsattr
usr/bin/md5sum
usr/bin/mkfifo
diff --git a/emulators/linux_base-f8/Makefile b/emulators/linux_base-f8/Makefile
index b0955b238e41..e2d51ccfa4d8 100644
--- a/emulators/linux_base-f8/Makefile
+++ b/emulators/linux_base-f8/Makefile
@@ -7,6 +7,7 @@
PORTNAME= f8
PORTVERSION= 8
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
MASTER_SITE_SUBDIR= ../releases/${PORTVERSION}/Everything/${LINUX_RPM_ARCH}/os/Packages \
@@ -96,7 +97,7 @@ SRC_DISTFILES+= acl-2.2.39-13.fc8.src.rpm \
ALWAYS_KEEP_DISTFILES= yes
.endif
-CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6
+CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6 linux_base-f7
ONLY_FOR_ARCHS= i386 amd64
LINUX_RPM_ARCH= i386
USE_LINUX_PREFIX= yes
@@ -204,6 +205,10 @@ do-install:
@${LN} -sf /var/tmp ${PREFIX}/usr/tmp
@${CHOWN} root:wheel ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
@${CHMOD} 755 ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
+#
+# Let some linux applications (e.g. print/acroread7) print with default settings
+#
+ @${INSTALL_SCRIPT} ${FILESDIR}/lp ${PREFIX}/usr/bin
post-install:
#
diff --git a/emulators/linux_base-f8/files/lp b/emulators/linux_base-f8/files/lp
new file mode 100644
index 000000000000..d1e0b5509eed
--- /dev/null
+++ b/emulators/linux_base-f8/files/lp
@@ -0,0 +1,2 @@
+#!/bin/sh -
+exec /usr/bin/lpr "$@"
diff --git a/emulators/linux_base-f8/pkg-plist b/emulators/linux_base-f8/pkg-plist
index db12f6fa5495..bf8ab8a8eb87 100644
--- a/emulators/linux_base-f8/pkg-plist
+++ b/emulators/linux_base-f8/pkg-plist
@@ -298,6 +298,7 @@ usr/bin/lddlibc4
usr/bin/locale
usr/bin/localedef
usr/bin/logname
+usr/bin/lp
usr/bin/lsattr
usr/bin/md5sum
usr/bin/mkfifo
diff --git a/emulators/linux_base-f9/Makefile b/emulators/linux_base-f9/Makefile
index b0955b238e41..e2d51ccfa4d8 100644
--- a/emulators/linux_base-f9/Makefile
+++ b/emulators/linux_base-f9/Makefile
@@ -7,6 +7,7 @@
PORTNAME= f8
PORTVERSION= 8
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
MASTER_SITE_SUBDIR= ../releases/${PORTVERSION}/Everything/${LINUX_RPM_ARCH}/os/Packages \
@@ -96,7 +97,7 @@ SRC_DISTFILES+= acl-2.2.39-13.fc8.src.rpm \
ALWAYS_KEEP_DISTFILES= yes
.endif
-CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6
+CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6 linux_base-f7
ONLY_FOR_ARCHS= i386 amd64
LINUX_RPM_ARCH= i386
USE_LINUX_PREFIX= yes
@@ -204,6 +205,10 @@ do-install:
@${LN} -sf /var/tmp ${PREFIX}/usr/tmp
@${CHOWN} root:wheel ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
@${CHMOD} 755 ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
+#
+# Let some linux applications (e.g. print/acroread7) print with default settings
+#
+ @${INSTALL_SCRIPT} ${FILESDIR}/lp ${PREFIX}/usr/bin
post-install:
#
diff --git a/emulators/linux_base-f9/files/lp b/emulators/linux_base-f9/files/lp
new file mode 100644
index 000000000000..d1e0b5509eed
--- /dev/null
+++ b/emulators/linux_base-f9/files/lp
@@ -0,0 +1,2 @@
+#!/bin/sh -
+exec /usr/bin/lpr "$@"
diff --git a/emulators/linux_base-f9/linux_base-f8/Makefile b/emulators/linux_base-f9/linux_base-f8/Makefile
index b0955b238e41..e2d51ccfa4d8 100644
--- a/emulators/linux_base-f9/linux_base-f8/Makefile
+++ b/emulators/linux_base-f9/linux_base-f8/Makefile
@@ -7,6 +7,7 @@
PORTNAME= f8
PORTVERSION= 8
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
MASTER_SITE_SUBDIR= ../releases/${PORTVERSION}/Everything/${LINUX_RPM_ARCH}/os/Packages \
@@ -96,7 +97,7 @@ SRC_DISTFILES+= acl-2.2.39-13.fc8.src.rpm \
ALWAYS_KEEP_DISTFILES= yes
.endif
-CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6
+CONFLICTS= linux_base-gentoo* linux_base-fc4 linux_base-fc6 linux_base-f7
ONLY_FOR_ARCHS= i386 amd64
LINUX_RPM_ARCH= i386
USE_LINUX_PREFIX= yes
@@ -204,6 +205,10 @@ do-install:
@${LN} -sf /var/tmp ${PREFIX}/usr/tmp
@${CHOWN} root:wheel ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
@${CHMOD} 755 ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
+#
+# Let some linux applications (e.g. print/acroread7) print with default settings
+#
+ @${INSTALL_SCRIPT} ${FILESDIR}/lp ${PREFIX}/usr/bin
post-install:
#
diff --git a/emulators/linux_base-f9/linux_base-f8/files/lp b/emulators/linux_base-f9/linux_base-f8/files/lp
new file mode 100644
index 000000000000..d1e0b5509eed
--- /dev/null
+++ b/emulators/linux_base-f9/linux_base-f8/files/lp
@@ -0,0 +1,2 @@
+#!/bin/sh -
+exec /usr/bin/lpr "$@"
diff --git a/emulators/linux_base-f9/linux_base-f8/pkg-plist b/emulators/linux_base-f9/linux_base-f8/pkg-plist
index db12f6fa5495..bf8ab8a8eb87 100644
--- a/emulators/linux_base-f9/linux_base-f8/pkg-plist
+++ b/emulators/linux_base-f9/linux_base-f8/pkg-plist
@@ -298,6 +298,7 @@ usr/bin/lddlibc4
usr/bin/locale
usr/bin/localedef
usr/bin/logname
+usr/bin/lp
usr/bin/lsattr
usr/bin/md5sum
usr/bin/mkfifo
diff --git a/emulators/linux_base-f9/pkg-plist b/emulators/linux_base-f9/pkg-plist
index db12f6fa5495..bf8ab8a8eb87 100644
--- a/emulators/linux_base-f9/pkg-plist
+++ b/emulators/linux_base-f9/pkg-plist
@@ -298,6 +298,7 @@ usr/bin/lddlibc4
usr/bin/locale
usr/bin/localedef
usr/bin/logname
+usr/bin/lp
usr/bin/lsattr
usr/bin/md5sum
usr/bin/mkfifo