aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2017-02-26 21:51:27 +0800
committervanilla <vanilla@FreeBSD.org>2017-02-26 21:51:27 +0800
commiteae5568f3ea28bc02e0b7650f22af2c54481e856 (patch)
tree094202761c7202a6d4862f6b0bab909e2f04ad39 /emulators
parent994cedfb9d7912090474ccf613ae8f6c94b06b78 (diff)
downloadfreebsd-ports-gnome-eae5568f3ea28bc02e0b7650f22af2c54481e856.tar.gz
freebsd-ports-gnome-eae5568f3ea28bc02e0b7650f22af2c54481e856.tar.zst
freebsd-ports-gnome-eae5568f3ea28bc02e0b7650f22af2c54481e856.zip
Update to 2.2.3.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fceux/Makefile9
-rw-r--r--emulators/fceux/distinfo5
-rw-r--r--emulators/fceux/files/patch-fceux-server_server.cpp2
-rw-r--r--emulators/fceux/files/patch-src_boards_mapinc.h8
-rw-r--r--emulators/fceux/files/patch-src_cheat.cpp2
-rw-r--r--emulators/fceux/pkg-plist7
6 files changed, 26 insertions, 7 deletions
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index 72b40e0497ad..ede41f815d2d 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= fceux
-PORTVERSION= 2.2.2
+PORTVERSION= 2.2.3
DISTVERSIONSUFFIX= .src
-PORTREVISION= 5
+PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= SF/fceultra/Source%20Code/${PORTVERSION}%20src/
@@ -19,6 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= compiler:c++0x desktop-file-utils dos2unix pkgconfig scons
USE_SDL= sdl
+USE_XORG= x11
LDFLAGS+= -L${LOCALBASE}/lib
@@ -62,8 +63,8 @@ post-patch:
@${REINPLACE_CMD} -e \
'/PUBLIC/s|^|#| ; \
/CheckLib/s|lua5.1|lua-${LUA_VER}| ; \
- /LINKFLAGS/s|"-ldl",|| ; \
/LINKFLAGS/s|lua5.1|lua-${LUA_VER}| ; \
+ s|"-ldl"|| ; \
s|/usr/include/lua5.1|${LUA_INCDIR}| ; \
s|-O2||' ${WRKSRC}/SConstruct
@${REINPLACE_CMD} -e \
@@ -88,6 +89,8 @@ do-install:
${STAGEDIR}${DESKTOPDIR})
(cd ${WRKSRC} && ${INSTALL_DATA} *.png \
${STAGEDIR}${PREFIX}/share/pixmaps)
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in TODO-PROJECT Videolog.txt cheat.html faq fcs.txt fm2.txt \
protocol.txt snes9x-lua.html
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index cc4fc4b51ca2..ce0d7bfe13c3 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fceux-2.2.2.src.tar.gz) = 804d11bdb4a195f3a580ce5d2d01be877582763378637e16186a22459f5fe5e1
-SIZE (fceux-2.2.2.src.tar.gz) = 9249858
+TIMESTAMP = 1488101003
+SHA256 (fceux-2.2.3.src.tar.gz) = 4be6dda9a347f941809a3c4a90d21815b502384adfdd596adaa7b2daf088823e
+SIZE (fceux-2.2.3.src.tar.gz) = 9292792
diff --git a/emulators/fceux/files/patch-fceux-server_server.cpp b/emulators/fceux/files/patch-fceux-server_server.cpp
index 817c3c6a6e82..843c76927a89 100644
--- a/emulators/fceux/files/patch-fceux-server_server.cpp
+++ b/emulators/fceux/files/patch-fceux-server_server.cpp
@@ -1,4 +1,4 @@
---- fceux-server/server.cpp.orig 2012-11-02 13:41:36 UTC
+--- fceux-server/server.cpp.orig 2017-02-26 13:33:11 UTC
+++ fceux-server/server.cpp
@@ -114,7 +114,7 @@ int LoadConfigFile(char *fn)
if(fp=fopen(fn,"rb"))
diff --git a/emulators/fceux/files/patch-src_boards_mapinc.h b/emulators/fceux/files/patch-src_boards_mapinc.h
new file mode 100644
index 000000000000..dc59f0c4b9fb
--- /dev/null
+++ b/emulators/fceux/files/patch-src_boards_mapinc.h
@@ -0,0 +1,8 @@
+--- src/boards/mapinc.h.orig 2017-02-26 13:37:11 UTC
++++ src/boards/mapinc.h
+@@ -9,4 +9,5 @@
+ #include "../cheat.h"
+ #include "../unif.h"
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
diff --git a/emulators/fceux/files/patch-src_cheat.cpp b/emulators/fceux/files/patch-src_cheat.cpp
index 2d990ab77084..e9e5393a17ae 100644
--- a/emulators/fceux/files/patch-src_cheat.cpp
+++ b/emulators/fceux/files/patch-src_cheat.cpp
@@ -1,4 +1,4 @@
---- src/cheat.cpp.orig 2013-04-13 02:52:13 UTC
+--- src/cheat.cpp.orig 2017-02-26 13:33:11 UTC
+++ src/cheat.cpp
@@ -216,7 +216,7 @@ void FCEU_LoadGameCheats(FILE *override)
}
diff --git a/emulators/fceux/pkg-plist b/emulators/fceux/pkg-plist
index cdab78227b88..e15fb8a55a27 100644
--- a/emulators/fceux/pkg-plist
+++ b/emulators/fceux/pkg-plist
@@ -93,6 +93,13 @@ share/applications/fceux.desktop
%%DATADIR%%/palettes/FCEU-13-default_nitsuja.pal
%%DATADIR%%/palettes/FCEU-15-nitsuja_new.pal
%%DATADIR%%/palettes/FCEUX.pal
+%%DATADIR%%/palettes/RP2C03.pal
+%%DATADIR%%/palettes/RP2C04_0001.pal
+%%DATADIR%%/palettes/RP2C04_0002.pal
+%%DATADIR%%/palettes/RP2C04_0003.pal
+%%DATADIR%%/palettes/RP2C04_0004.pal
+%%DATADIR%%/palettes/SONY_CXA2025AS_US.pal
+%%DATADIR%%/palettes/Unsaturated-V6.pal
%%DATADIR%%/palettes/nestopia_rgb.pal
%%DATADIR%%/palettes/nestopia_yuv.pal
%%DATADIR%%/tools/taseditor_patterns.txt