aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-01-04 03:21:55 +0800
committergerald <gerald@FreeBSD.org>2009-01-04 03:21:55 +0800
commitf87752059c2bb37c2f33bfbed8b247e8392688b0 (patch)
treebd7789d01d6aa08cae1387c040cec4e3236342ca /emulators
parent384db5ece1acb838b3093e27436c1357f75a6323 (diff)
downloadfreebsd-ports-gnome-f87752059c2bb37c2f33bfbed8b247e8392688b0.tar.gz
freebsd-ports-gnome-f87752059c2bb37c2f33bfbed8b247e8392688b0.tar.zst
freebsd-ports-gnome-f87752059c2bb37c2f33bfbed8b247e8392688b0.zip
Add option LIBXSLT, off by default, to control the use of libxslt (which
is only used by msxml3.dll right now). PR: 119155
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile10
-rw-r--r--emulators/wine/Makefile10
2 files changed, 18 insertions, 2 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index ed69b092d42b..9d8fadc7f70f 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -43,7 +43,8 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
- HAL "Use HAL (Hardware Abstraction Layer)" Off
+ HAL "Use HAL (Hardware Abstraction Layer)" Off \
+ LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
.include <bsd.port.pre.mk>
@@ -61,6 +62,13 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --without-hal
.endif
+.ifdef WITH_LIBXSLT
+CONFIGURE_ARGS+= --with-xslt
+LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
+.else
+CONFIGURE_ARGS+= --without-xslt
+.endif
+
.if ${OSVERSION} < 602000
IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index ed69b092d42b..9d8fadc7f70f 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -43,7 +43,8 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
- HAL "Use HAL (Hardware Abstraction Layer)" Off
+ HAL "Use HAL (Hardware Abstraction Layer)" Off \
+ LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
.include <bsd.port.pre.mk>
@@ -61,6 +62,13 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --without-hal
.endif
+.ifdef WITH_LIBXSLT
+CONFIGURE_ARGS+= --with-xslt
+LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
+.else
+CONFIGURE_ARGS+= --without-xslt
+.endif
+
.if ${OSVERSION} < 602000
IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif