aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-05-30 09:54:23 +0800
committeredwin <edwin@FreeBSD.org>2008-05-30 09:54:23 +0800
commitfb39299e846cbb3c615c7e02a086c081ef6f3a97 (patch)
treeba78a01b56e9aef03e7870e568c2812868465855 /emulators
parent83aff139de09e730945f549d5584b0165056016e (diff)
downloadfreebsd-ports-gnome-fb39299e846cbb3c615c7e02a086c081ef6f3a97.tar.gz
freebsd-ports-gnome-fb39299e846cbb3c615c7e02a086c081ef6f3a97.tar.zst
freebsd-ports-gnome-fb39299e846cbb3c615c7e02a086c081ef6f3a97.zip
Replace /usr/X11R6 with /usr/local in the Makefile rules
Noticed by: pavrun on amd64/7.0
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fmsx/Makefile6
-rw-r--r--emulators/fmsx/files/patch-EMULib_Rules.Unix9
2 files changed, 13 insertions, 2 deletions
diff --git a/emulators/fmsx/Makefile b/emulators/fmsx/Makefile
index 6c46a051fab0..176a53ab4e7f 100644
--- a/emulators/fmsx/Makefile
+++ b/emulators/fmsx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fmsx
PORTVERSION= 3.5.1
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ahttp://www.mavetju.org/download/adopted/:code \
http://fms.komkon.org/fMSX/:code \
@@ -24,7 +25,7 @@ COMMENT= The Portable MSX/MSX2/MSX2+ Emulator
USE_XORG= xi x11
USE_ZIP= yes
USE_GMAKE= yes
-USE_DOS2UNIX= EMULib/NetUnix.c
+USE_DOS2UNIX= EMULib/NetUnix.c EMULib/Rules.Unix
RESTRICTED= Legal status of distributed ROM images unclear
WRKSRC= ${WRKDIR}
@@ -37,7 +38,8 @@ OPTIONS= BPP8 "With BPP8" Off \
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' \
- ${WRKSRC}/fMSX/Unix/Makefile
+ ${WRKSRC}/fMSX/Unix/Makefile \
+ ${WRKSRC}/EMULib/Rules.Unix
#post-patch:
.ifdef(WITH_BPP32) || defined(PACKAGE_BUILDING) || defined(BATCH)
diff --git a/emulators/fmsx/files/patch-EMULib_Rules.Unix b/emulators/fmsx/files/patch-EMULib_Rules.Unix
new file mode 100644
index 000000000000..c937d3a45f1f
--- /dev/null
+++ b/emulators/fmsx/files/patch-EMULib_Rules.Unix
@@ -0,0 +1,9 @@
+--- EMULib/Rules.Unix.orig 2008-05-30 01:51:56.000000000 +0000
++++ EMULib/Rules.Unix 2008-05-30 01:52:07.000000000 +0000
+@@ -1,5 +1,5 @@
+ include ../../EMULib/Rules.gcc
+
+-CFLAGS += -I/usr/X11R6/include
++CFLAGS += -I%%LOCALBASE%%/include
+ DEFINES+= -DUNIX -DMITSHM
+ LIBS += -lX11 -lXext