aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-07-27 04:55:14 +0800
committerlinimon <linimon@FreeBSD.org>2017-07-27 04:55:14 +0800
commitfb58aac3505cbff82b4419641f23f7e58db2be40 (patch)
tree9378d920c9048a789f8e19d0f5e240fe6f309911 /emulators
parente8a68c15d03fea168b04407ec1da5c4b462c0f25 (diff)
downloadfreebsd-ports-gnome-fb58aac3505cbff82b4419641f23f7e58db2be40.tar.gz
freebsd-ports-gnome-fb58aac3505cbff82b4419641f23f7e58db2be40.tar.zst
freebsd-ports-gnome-fb58aac3505cbff82b4419641f23f7e58db2be40.zip
Add port for QEMU fork for experimental PowerNV work (powerpc64, Non-Virtualized).
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/qemu-ppcnv/Makefile68
-rw-r--r--emulators/qemu-ppcnv/distinfo5
-rw-r--r--emulators/qemu-ppcnv/pkg-descr3
4 files changed, 77 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index acffe03e7528..7b794898dead 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -121,6 +121,7 @@
SUBDIR += qemu-cheri128m
SUBDIR += qemu-devel
SUBDIR += qemu-launcher
+ SUBDIR += qemu-ppcnv
SUBDIR += qemu-riscv
SUBDIR += qemu-sbruno
SUBDIR += qemu-user-static
diff --git a/emulators/qemu-ppcnv/Makefile b/emulators/qemu-ppcnv/Makefile
new file mode 100644
index 000000000000..da783d01c27f
--- /dev/null
+++ b/emulators/qemu-ppcnv/Makefile
@@ -0,0 +1,68 @@
+# $FreeBSD$
+
+PORTNAME= qemu
+PORTVERSION= 2.10.0
+CATEGORIES= emulators
+MASTER_SITES= GH \
+ LOCAL/nox:dtc \
+ http://people.freebsd.org/~nox/tmp/distfiles/:dtc
+PKGNAMESUFFIX?= -ppcnv
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ dtc-v1.4.0${EXTRACT_SUFX}:dtc
+
+MAINTAINER= linimon@FreeBSD.org
+COMMENT= Fork of QEMU with experimental PowerPCNV emulation support
+
+LICENSE= GPLv2
+
+IGNORE_FreeBSD_10= does not build
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libfdt.so:sysutils/dtc
+
+USE_GITHUB= yes
+GH_ACCOUNT= dgibson
+GH_PROJECT= qemu
+GH_TAGNAME= 8d5981c
+
+HAS_CONFIGURE= yes
+USES= gmake libtool makeinfo pkgconfig python:2,build
+USE_XORG= pixman
+USE_GNOME+= glib20
+ONLY_FOR_ARCHS= amd64
+
+CONFIGURE_ARGS+=--target-list=ppc-softmmu,ppcemb-softmmu,ppc64-softmmu \
+ --cc=${CC} \
+ --disable-curl \
+ --disable-docs \
+ --disable-gtk \
+ --disable-gcrypt \
+ --disable-kvm \
+ --disable-libssh2 \
+ --disable-linux-aio \
+ --disable-linux-user \
+ --disable-vnc \
+ --disable-sdl \
+ --disable-nettle \
+ --disable-gnutls \
+ --disable-vte \
+ --disable-xen \
+ --extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\" \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" \
+ --localstatedir=/var \
+ --python=${PYTHON_CMD}
+
+PLIST_FILES= bin/qemu-system-ppcnv \
+ bin/qemu-system-ppc64nv \
+ bin/qemu-system-ppcembnv
+
+# XXX this magic should not be necessary, but seems to be:
+post-patch:
+ @${MV} ${WRKDIR}/dtc ${WRKSRC}
+
+# remap names to avoid conflicts with mainline port
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ppc-softmmu/qemu-system-ppc ${STAGEDIR}${PREFIX}/bin/qemu-system-ppcnv
+ ${INSTALL_PROGRAM} ${WRKSRC}/ppc64-softmmu/qemu-system-ppc64 ${STAGEDIR}${PREFIX}/bin/qemu-system-ppc64nv
+ ${INSTALL_PROGRAM} ${WRKSRC}/ppcemb-softmmu/qemu-system-ppcemb ${STAGEDIR}${PREFIX}/bin/qemu-system-ppcembnv
+
+.include <bsd.port.mk>
diff --git a/emulators/qemu-ppcnv/distinfo b/emulators/qemu-ppcnv/distinfo
new file mode 100644
index 000000000000..d89e82cad9b5
--- /dev/null
+++ b/emulators/qemu-ppcnv/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1501102325
+SHA256 (dgibson-qemu-2.10.0-8d5981c_GH0.tar.gz) = 1a0a19167259d1b4598d73f765b069643d4e8628c099be6c425644e33aa82deb
+SIZE (dgibson-qemu-2.10.0-8d5981c_GH0.tar.gz) = 14435599
+SHA256 (dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
+SIZE (dtc-v1.4.0.tar.gz) = 131893
diff --git a/emulators/qemu-ppcnv/pkg-descr b/emulators/qemu-ppcnv/pkg-descr
new file mode 100644
index 000000000000..0bbaf460c5d6
--- /dev/null
+++ b/emulators/qemu-ppcnv/pkg-descr
@@ -0,0 +1,3 @@
+Fork of QEMU with experimental PowerPC NV emulation support.
+
+WWW: https://github.com/dgibson/qemu/tree/powernv/target-ppc