aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /emulators
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vice/Makefile3
-rw-r--r--emulators/vx68k/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 7a5155551028..b5c901d107ec 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -15,6 +15,7 @@ RESTRICTED= ROMs are copyrighted by Commodore Business Machines
NO_CDROM= ${RESTRICTED}
NO_PACKAGE= ${RESTRICTED}
+USE_REINPLACE= yes
USE_XPM= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -44,7 +45,7 @@ post-extract:
@${RM} -f ${WRKSRC}/doc/vice.info*
post-patch:
- @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/man/vice.1
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/man/vice.1
post-install:
@${LN} -sf vice_toc.html ${DOCSDIR}/index.html
diff --git a/emulators/vx68k/Makefile b/emulators/vx68k/Makefile
index 0bd0a8ee7fa2..a689c0d491b5 100644
--- a/emulators/vx68k/Makefile
+++ b/emulators/vx68k/Makefile
@@ -20,6 +20,7 @@ USE_MESA= yes
USE_GNOMENG= yes
USE_GNOME= gtk12
USE_LIBTOOL= yes
+USE_REINPLACE= yes
LIBTOOLFILES= configure vx68k-gtk/configure
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -31,6 +32,6 @@ LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lGL -lGLU -lglut \
${PTHREAD_LIBS}
post-patch:
- @${PERL} -pi -e "s,Bison ,Bison,g" ${WRKSRC}/vx68k-gtk/configure
+ @${REINPLACE_CMD} -e "s,Bison ,Bison,g" ${WRKSRC}/vx68k-gtk/configure
.include <bsd.port.mk>