aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoralfred <alfred@FreeBSD.org>2016-07-05 16:06:10 +0800
committeralfred <alfred@FreeBSD.org>2016-07-05 16:06:10 +0800
commitff36f3dc7c3505b1877682810970e8248487e5a6 (patch)
tree25d942c644e40d6987a08d69dd078c2fa85f2ba0 /emulators
parentbf1874d6b9d38f2a50d24a6695a1ac3db20cc043 (diff)
downloadfreebsd-ports-gnome-ff36f3dc7c3505b1877682810970e8248487e5a6.tar.gz
freebsd-ports-gnome-ff36f3dc7c3505b1877682810970e8248487e5a6.tar.zst
freebsd-ports-gnome-ff36f3dc7c3505b1877682810970e8248487e5a6.zip
virtualbox-ose-lite minimal deps for packaging
This package has minimal deps, only udp server and vncserver are required. This works really nicely for someone who just wants to run headless vms or the VBoxManage tools without bloat.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/virtualbox-ose-lite/Makefile14
-rw-r--r--emulators/virtualbox-ose/Makefile12
3 files changed, 27 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 364704e87dbf..281b8078de29 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -151,6 +151,7 @@
SUBDIR += virtualbox-ose
SUBDIR += virtualbox-ose-additions
SUBDIR += virtualbox-ose-kmod
+ SUBDIR += virtualbox-ose-lite
SUBDIR += visualboyadvance-m
SUBDIR += vmips
SUBDIR += vmsbackup
diff --git a/emulators/virtualbox-ose-lite/Makefile b/emulators/virtualbox-ose-lite/Makefile
new file mode 100644
index 000000000000..a084e2dcae93
--- /dev/null
+++ b/emulators/virtualbox-ose-lite/Makefile
@@ -0,0 +1,14 @@
+# Created by: Alfred Perlstein <alfred@freebsd.org>
+# $FreeBSD$
+
+PORTREVISION= 0
+
+MAINTAINER= alfred@FreeBSD.org
+COMMENT= Small install of virtualbox without graphics
+
+LITE= yes
+
+MASTERDIR= ${.CURDIR}/../virtualbox-ose
+
+.include "${MASTERDIR}/Makefile"
+
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index f7ad1e0d2a8b..7b093db9e096 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -48,6 +48,14 @@ CONFLICTS_INSTALL= virtualbox-ose-additions-4* \
virtualbox-ose-devel-4* \
virtualbox-ose-legacy-4*
+.if defined(LITE)
+PKGNAMESUFFIX+= -lite
+CONFLICTS_INSTALL+= ${PORTNAME}-[0-9]*
+WITHOUT+= NLS
+.else
+CONFLICTS_INSTALL+= ${PORTNAME}-lite-[0-9]*
+.endif
+
VBOXUSER?= vboxusers
VBOXWSUSER?= vboxusers
VBOXGROUP?= vboxusers
@@ -63,7 +71,11 @@ VBOX_GUEST_VER= ${PORTVERSION}
OPTIONS_DEFINE= DBUS DEBUG GUESTADDITIONS MANUAL NLS PULSEAUDIO PYTHON \
QT4 R0LOGGING UDPTUNNEL VDE VNC VPX WEBSERVICE X11
+.if defined(LITE)
+OPTIONS_DEFAULT= UDPTUNNEL VNC
+.else
OPTIONS_DEFAULT= DBUS PYTHON QT4 UDPTUNNEL VNC WEBSERVICE X11
+.endif
OPTIONS_SUB= yes
DEBUG_DESC= Debug symbols, additional logs and assertions