aboutsummaryrefslogtreecommitdiffstats
path: root/finance/ledgersmb/Makefile
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 01:45:09 +0800
committeraz <az@FreeBSD.org>2013-07-26 01:45:09 +0800
commita17aea5b36965f8ed6ecc0ca55f360944e3f46a8 (patch)
tree17b7739cec5c8bd24318f8970c77d5508f40b335 /finance/ledgersmb/Makefile
parent9bd11f4a568c740d3e38c88bf815647016ecdef7 (diff)
downloadfreebsd-ports-gnome-a17aea5b36965f8ed6ecc0ca55f360944e3f46a8.tar.gz
freebsd-ports-gnome-a17aea5b36965f8ed6ecc0ca55f360944e3f46a8.tar.zst
freebsd-ports-gnome-a17aea5b36965f8ed6ecc0ca55f360944e3f46a8.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'finance/ledgersmb/Makefile')
-rw-r--r--finance/ledgersmb/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/finance/ledgersmb/Makefile b/finance/ledgersmb/Makefile
index 5787ee9cb4e9..acbed1ab34b1 100644
--- a/finance/ledgersmb/Makefile
+++ b/finance/ledgersmb/Makefile
@@ -17,16 +17,9 @@ NO_BUILD= yes
USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
-
-post-patch:
- @${PERL} -pi -e 's|/usr/bin/perl|${PERL}|' \
- `${FIND} ${WRKSRC} -name \*.pl`
- @${PERL} -pe 's|%%PREFIX%%|${PREFIX}|g' \
- ${FILESDIR}/${PORTNAME}-httpd.conf.in \
- > ${WRKDIR}/${PORTNAME}-httpd.conf
- @${PERL} -pe 's|%%PREFIX%%|${PREFIX}|g' \
- ${PKGDIR}/pkg-message \
- > ${PKGMESSAGE}
+USES= shebangfix
+SHEBANG_FILES= *.pl locale/*/*.pl bin/*/*.pl utils/*/*.pl
+SUB_FILES= ${PORTNAME}-httpd.conf.in pkg-message.in
do-install:
@cd ${WRKDIR} ; \