aboutsummaryrefslogtreecommitdiffstats
path: root/finance/p5-Business-OnlinePayment-AuthorizeNet
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-10-25 16:45:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-10-25 16:45:10 +0800
commitad2b1f23d6b937ac1c83d9c440f6aedaf056ea21 (patch)
tree1c66950d3dfe4aa102833407edf4451166dd6040 /finance/p5-Business-OnlinePayment-AuthorizeNet
parent7184c73a34949dc4e8aa5ed77617551042390b2b (diff)
downloadfreebsd-ports-gnome-ad2b1f23d6b937ac1c83d9c440f6aedaf056ea21.tar.gz
freebsd-ports-gnome-ad2b1f23d6b937ac1c83d9c440f6aedaf056ea21.tar.zst
freebsd-ports-gnome-ad2b1f23d6b937ac1c83d9c440f6aedaf056ea21.zip
Add p5-Business-OnlinePayment-AuthorizeNet 3.11, a Business::OnlinePayment
backend module for Authorize.Net.
Diffstat (limited to 'finance/p5-Business-OnlinePayment-AuthorizeNet')
-rw-r--r--finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile28
-rw-r--r--finance/p5-Business-OnlinePayment-AuthorizeNet/distinfo1
-rw-r--r--finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-comment1
-rw-r--r--finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-descr5
-rw-r--r--finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile b/finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile
new file mode 100644
index 000000000000..947870599237
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-AuthorizeNet/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Business::OnlinePayment::AuthorizeNet
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OnlinePayment-AuthorizeNet
+PORTVERSION= 3.11
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/misc/p5-Business-CreditCard \
+ ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/misc/p5-Business-OnlinePayment \
+ ${SITE_PERL}/${PERL_ARCH}/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Business::OnlinePayment::AuthorizeNet.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-OnlinePayment-AuthorizeNet/distinfo b/finance/p5-Business-OnlinePayment-AuthorizeNet/distinfo
new file mode 100644
index 000000000000..01f2d50b243d
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-AuthorizeNet/distinfo
@@ -0,0 +1 @@
+MD5 (Business-OnlinePayment-AuthorizeNet-3.11.tar.gz) = c4fac4b3892433f379cdb21ce2d09250
diff --git a/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-comment b/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-comment
new file mode 100644
index 000000000000..e143287f4177
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-comment
@@ -0,0 +1 @@
+A Business::OnlinePayment backend module for Authorize.Net
diff --git a/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-descr b/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-descr
new file mode 100644
index 000000000000..df9d9a19946d
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-descr
@@ -0,0 +1,5 @@
+This is Business::OnlinePayment::AuthorizeNet, an Business::OnlinePayment
+backend module for Authorize.Net. It is only useful if you have a merchant
+account with Authorize.Net: http://www.authorize.net
+
+This module has been updated and now implements Authorize.Net API version 3.1.
diff --git a/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-plist b/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-plist
new file mode 100644
index 000000000000..4d1c194c51f9
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-AuthorizeNet/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Business/OnlinePayment/AuthorizeNet.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/AuthorizeNet/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/AuthorizeNet/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/AuthorizeNet
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/AuthorizeNet