aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-08-20 09:03:48 +0800
committerWen Heping <wen@FreeBSD.org>2012-08-20 09:03:48 +0800
commit443d7d560b12a01a2ebf559ac1748fbe5fcc6609 (patch)
tree3d3551d3695155dd16a39c41fe5f67cf95628a89 /finance
parentf6c49da45115bd50f09ce4964f539e23d3edb4f2 (diff)
downloadfreebsd-ports-gnome-443d7d560b12a01a2ebf559ac1748fbe5fcc6609.tar.gz
freebsd-ports-gnome-443d7d560b12a01a2ebf559ac1748fbe5fcc6609.tar.zst
freebsd-ports-gnome-443d7d560b12a01a2ebf559ac1748fbe5fcc6609.zip
trytond_country is the country module for tryton.
The country module defines the concepts of country and subdivision and comes preloaded with the ISO 3166 list of countries and subdivisions thanks to the pycountry module. WWW: http://www.tryton.org/ PR: 170557 Submitted by: Matthias Petermann <matthias@d2ux.net>
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/trytond_country/Makefile23
-rw-r--r--finance/trytond_country/distinfo2
-rw-r--r--finance/trytond_country/pkg-descr7
-rw-r--r--finance/trytond_country/pkg-plist40
5 files changed, 73 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 2f0f9fb0fc66..14bc4c58d21d 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -104,6 +104,7 @@
SUBDIR += tinyerp-server
SUBDIR += tryton
SUBDIR += trytond
+ SUBDIR += trytond_country
SUBDIR += trytond_currency
SUBDIR += trytond_product
SUBDIR += venice
diff --git a/finance/trytond_country/Makefile b/finance/trytond_country/Makefile
new file mode 100644
index 000000000000..78e87fcec342
--- /dev/null
+++ b/finance/trytond_country/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: trytond_country
+# Date created: 12 August, 2012
+# Whom: Matthias Petermann<matthias@petermann.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trytond_country
+PORTVERSION= 2.4.0
+CATEGORIES= finance python
+MASTER_SITES= http://downloads2.tryton.org/${PORTVERSION:R}/
+
+MAINTAINER= matthias@petermann.it
+COMMENT= The Country Module for Tryton
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= trytond>=2.4.0:${PORTSDIR}/finance/trytond
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+.include <bsd.port.mk>
diff --git a/finance/trytond_country/distinfo b/finance/trytond_country/distinfo
new file mode 100644
index 000000000000..a096de9cc527
--- /dev/null
+++ b/finance/trytond_country/distinfo
@@ -0,0 +1,2 @@
+SHA256 (trytond_country-2.4.0.tar.gz) = 0f41193a4639b56f7a80ade241351e8c81755669be5b5747d0b6b42c0c4ce81a
+SIZE (trytond_country-2.4.0.tar.gz) = 721689
diff --git a/finance/trytond_country/pkg-descr b/finance/trytond_country/pkg-descr
new file mode 100644
index 000000000000..95e11176dd81
--- /dev/null
+++ b/finance/trytond_country/pkg-descr
@@ -0,0 +1,7 @@
+trytond_country is the country module for tryton.
+
+The country module defines the concepts of country and
+subdivision and comes preloaded with the ISO 3166 list of
+countries and subdivisions thanks to the pycountry module.
+
+WWW: http://www.tryton.org/
diff --git a/finance/trytond_country/pkg-plist b/finance/trytond_country/pkg-plist
new file mode 100644
index 000000000000..bc828f6c9019
--- /dev/null
+++ b/finance/trytond_country/pkg-plist
@@ -0,0 +1,40 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/__tryton__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/__tryton__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/__tryton__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/country.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/country.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/country.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/country.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/bg_BG.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/ca_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/cs_CZ.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/de_DE.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/es_AR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/es_CO.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/es_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/fr_FR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/nl_NL.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale/ru_RU.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/tests/test_country.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/tests/test_country.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/tests/test_country.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country/locale
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/country
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%