aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-14 20:04:18 +0800
committeraz <az@FreeBSD.org>2013-09-14 20:04:18 +0800
commit4c360573894c2f8906ac8b085feab980b48ed846 (patch)
tree0b99f811fd2d870349949708741c6d39ea7b57a5 /finance
parent9c17906cf340f9aa310ce0e513350fda4993f739 (diff)
downloadfreebsd-ports-gnome-4c360573894c2f8906ac8b085feab980b48ed846.tar.gz
freebsd-ports-gnome-4c360573894c2f8906ac8b085feab980b48ed846.tar.zst
freebsd-ports-gnome-4c360573894c2f8906ac8b085feab980b48ed846.zip
- convert to the new perl5 framework
- convert USE_GMAKE to Uses Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'finance')
-rw-r--r--finance/kmymoney-kde4/Makefile3
-rw-r--r--finance/p5-Finance-Bitcoin/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 001eb7c6bf2d..74c19b32dc7a 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -71,7 +71,8 @@ PLIST_SUB+= OFX="@comment "
.endif
.if ${PORT_OPTIONS:MQUOTES}
-USE_PERL5_RUN= yes
+USES+= perl5
+USE_PERL5= run
RUN_DEPENDS+= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-Finance-Quote>=0:${PORTSDIR}/finance/p5-Finance-Quote \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
diff --git a/finance/p5-Finance-Bitcoin/Makefile b/finance/p5-Finance-Bitcoin/Makefile
index 63e64fc8c5f2..e8639af53ef6 100644
--- a/finance/p5-Finance-Bitcoin/Makefile
+++ b/finance/p5-Finance-Bitcoin/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-JSON-RPC>=0.96:${PORTSDIR}/devel/p5-JSON-RPC \
p5-Object-AUTHORITY>=0:${PORTSDIR}/devel/p5-Object-Authority
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Finance::Bitcoin::API.3 \
Finance::Bitcoin::Address.3 \