aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2019-03-17 05:48:43 +0800
committertcberner <tcberner@FreeBSD.org>2019-03-17 05:48:43 +0800
commit92d9959adf68049af5b4dc602c942198622bb55c (patch)
tree330a7170752b047f16cf6e5317695023f8c8973f /finance
parent706a0761c35a45048d896cea0d421022f38d2a51 (diff)
downloadfreebsd-ports-gnome-92d9959adf68049af5b4dc602c942198622bb55c.tar.gz
freebsd-ports-gnome-92d9959adf68049af5b4dc602c942198622bb55c.tar.zst
freebsd-ports-gnome-92d9959adf68049af5b4dc602c942198622bb55c.zip
finance/alkimia: remove qt4 slave (Qt4 deprecation)
- once alkimia-qt4 has gone, clean up PKGNAMESUFFIX Approved by: portmgr (implicit)
Diffstat (limited to 'finance')
-rw-r--r--finance/alkimia-qt4/Makefile3
-rw-r--r--finance/alkimia/Makefile26
2 files changed, 5 insertions, 24 deletions
diff --git a/finance/alkimia-qt4/Makefile b/finance/alkimia-qt4/Makefile
index 1a946647bc8d..0962e7aa1b32 100644
--- a/finance/alkimia-qt4/Makefile
+++ b/finance/alkimia-qt4/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
-SLAVE= qt4
+BROKEN= Not supported
+PKGNAMESUFFIX= qt4
MASTERDIR= ${.CURDIR}/../../finance/alkimia
.include "${MASTERDIR}/Makefile"
diff --git a/finance/alkimia/Makefile b/finance/alkimia/Makefile
index 5b1a36b6fbf5..81b43a30e13e 100644
--- a/finance/alkimia/Makefile
+++ b/finance/alkimia/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= 7.0.2
PORTREVISION= 2
CATEGORIES= finance kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
-PKGNAMESUFFIX= -${SLAVE}
+PKGNAMESUFFIX?= -qt5
MAINTAINER= jhale@FreeBSD.org
COMMENT= KDE financial data handling library
@@ -16,29 +16,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LIB
# Depending on ecm via USE_KDE causes unwanted CMAKE_ARGS to be set
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/kf5-extra-cmake-modules
-USES= cmake compiler:c++11-lang pathfix tar:xz
+USES= cmake compiler:c++11-lang pathfix qt:5 tar:xz
USE_LDCONFIG= yes
-
-SLAVE?= qt5
-.if ${SLAVE} == qt4
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-
-USES+= qt:4
-USE_QT= corelib dbus \
- moc_build qmake_build rcc_build
-# BUILD_QT4 must be set to "1" due to comparison used in src/LibAlkimiaConfig.cmake.in
-CMAKE_ARGS+= -DBUILD_QT4=1
-CMAKE_OFF+= KDE_INSTALL_USE_QT_SYS_PATHS
-INCLUDE_SUBDIR= Qt4
-.else
-USES+= qt:5
USE_QT= core dbus \
buildtools_build qmake_build
-CMAKE_ON+= KDE_INSTALL_USE_QT_SYS_PATHS
+CMAKE_ON= KDE_INSTALL_USE_QT_SYS_PATHS
INCLUDE_SUBDIR= Qt5
QTVER_SUFFIX= 5
-.endif
PLIST_SUB= INCLUDE_SUBDIR=${INCLUDE_SUBDIR} \
QTVER_SUFFIX=${QTVER_SUFFIX} \
@@ -57,11 +41,7 @@ GMP_CMAKE_BOOL= CMAKE_DISABLE_FIND_PACKAGE_MPIR
MPIR_DESC= MPIR (multiple precision arithmetic) support
MPIR_LIB_DEPENDS= libmpir.so:math/mpir
-.if ${SLAVE} == qt4
-TEST_USE= QT=qtestlib
-.else
TEST_USE= QT=testlib
-.endif
TEST_CMAKE_BOOL= BUILD_TESTING
TEST_TEST_TARGET= test